Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-39571

Jenkins doesn't start after plugin update

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Reopened (View Workflow)
    • Priority: Major
    • Resolution: Unresolved
    • Component/s: core
    • Labels:
      None
    • Environment:
      Jenkins 2.27
    • Similar Issues:

      Description

      Hi,

      Every time after restarting Jenkins due to updates of plugins, the web page stucks in "Please wait while Jenkins is getting ready to work...". I only can resolve this by restarting the corresponding Windows service manually. This is my system configuration:
      Jenkins: 2.27
      OS: Windows Server 2012 R2
      RAM: 4 GB

      The attached documents cover the reports of jmap and jstack.

      Are there any suggestions how to solve this issue?

      Regards
      mu88

        Attachments

        1. Logs.zip
          3 kB
        2. Reports.zip
          7 kB
        3. support_2016-11-11_12.58.39.zip
          64 kB
        4. support_2016-11-11_13.48.03.zip
          2.02 MB

          Issue Links

            Activity

            mu88 M U created issue -
            oleg_nenashev Oleg Nenashev added a comment -

            According to the provided logs, Jenkins starts up successfully

            oleg_nenashev Oleg Nenashev added a comment -

            Which plugins have you updated?

            I also wonder what is this guy

            "SocketListener(szhm25662.local.)" #45 daemon prio=5 os_prio=0 tid=0x18499000 nid=0x312c runnable [0x15b6f000]
               java.lang.Thread.State: RUNNABLE
            	at java.net.TwoStacksPlainDatagramSocketImpl.receive0(Native Method)
            	- locked <0x0af4d438> (a java.net.TwoStacksPlainDatagramSocketImpl)
            	at java.net.TwoStacksPlainDatagramSocketImpl.receive(Unknown Source)
            	- locked <0x0af4d438> (a java.net.TwoStacksPlainDatagramSocketImpl)
            	at java.net.DatagramSocket.receive(Unknown Source)
            	- locked <0x0af4d478> (a java.net.DatagramPacket)
            	- locked <0x0af4d498> (a java.net.MulticastSocket)
            	at javax.jmdns.impl.SocketListener.run(SocketListener.java:41)
            
            oleg_nenashev Oleg Nenashev added a comment -

            Likely it duplicates JENKINS-39633

            oleg_nenashev Oleg Nenashev made changes -
            Field Original Value New Value
            Link This issue is related to JENKINS-39633 [ JENKINS-39633 ]
            jglick Jesse Glick added a comment -

            No log from the failed startup seems to be attached.

            jglick Jesse Glick made changes -
            Resolution Incomplete [ 4 ]
            Status Open [ 1 ] Resolved [ 5 ]
            evan_p Evan Pratama made changes -
            Link This issue is related to JENKINS-39641 [ JENKINS-39641 ]
            mu88 M U made changes -
            Resolution Incomplete [ 4 ]
            Status Resolved [ 5 ] Reopened [ 4 ]
            mu88 M U added a comment -

            Oleg Nenashev: I don't think it is a duplicate of your mentioned ticket because I don't see a similar picture. Regarding your second question about the plugins: I can not tell you, it were about 20 (Git, Copy Artifact, Credentials, etc.).
            The problem occurs since a couple of month every time when doing an update of either plugins or Jenkins itself. I assume it is more likely that the problem is related to my environment rather than Jenkins.
            I have no idea about the Java exception, I just followed these instructions: https://wiki.jenkins-ci.org/display/JENKINS/Jenkins+is+hanging

            Jesse Glick: is it your typical workflow to close a ticket instead of providing further help for solving the issue? Definitely great for the monthly statistic about the resolved issues, but quite poor from the user's perspective.

            oleg_nenashev Oleg Nenashev added a comment -

            > Regarding your second question about the plugins: I can not tell you, it were about 20 (Git, Copy Artifact, Credentials, etc.)

            I recommend to install https://wiki.jenkins-ci.org/display/JENKINS/Support+Core+Plugin and to upload the support bundle generated by it. It should provide us all information we may need.

            > Jesse Glick: is it your typical workflow to close a ticket instead of providing further help for solving the issue? Definitely great for the monthly statistic about the resolved issues, but quite poor from the user's perspective.

            No, it's not common. We sometimes close issues as Incomplete if the requester does not provide the required info and then does not respond to pings, but here is another case. Jess just did a mistake, but please do not be offensive/sarcastic. It does not help anyone

            mu88 M U added a comment -

            Okay, the plugin is installed. What would be the most helpful workflow for you? Create an initial bundle, do the update of some plugins for enforce the restart problem and create a second bundle afterwards?

            oleg_nenashev Oleg Nenashev added a comment -

            Yes, it would be nice

            mu88 M U made changes -
            Attachment support_2016-11-11_12.58.39.zip [ 34798 ]
            Attachment support_2016-11-11_13.48.03.zip [ 34799 ]
            mu88 M U added a comment -

            Please take a look at the following files:
            support_2016-11-11_12.58.39.zip support_2016-11-11_13.48.03.zip

            What I did:

            1. Created the first bundle
            2. Updated some plugins and activated "restart Jenkins after installation"
            3. Jenkins tried to restart, but stucks in "Please wait while Jenkins is getting ready to work..."
            4. Restarted Jenkins' Windows service
            5. Created the second bundle
            jglick Jesse Glick added a comment -

            I closed it as incomplete because AFAICT it was, and is—if there is some attached file demonstrating the error blocking startup, I do not see it here. Or steps to reproduce the issue from scratch?

            JIRA is not a help forum. An issue should be open only when there is a demonstrated bug that developers can act to resolve on behalf of all users, which generally requires diagnostics to be collected and refined on the reporter’s side.

            danielbeck Daniel Beck added a comment -

            Oleg Nenashev I +1 Jesse. Our JIRA never was a support site and never will be. There is no bug here.

            I've closed hundreds of "How do I" and "How to fix" issues over the years as Not a Defect – is has nothing to do with stats, but this just pollutes our issue tracker and makes the actual issues more difficult to find.

            danielbeck Daniel Beck added a comment -

            M U Let me present the other side of this:

            We're already dealing with way more reported issues than we can handle. Issues that aren't actually actionable, or are incomplete, just end up wasting time we could spend more productively elsewhere. For example, I've spent probably several weeks of full time work over 3 years trying to track down issues that were fixed and released by the time a bug was filed against an older version of Jenkins.

            Therefore we added, in bold red letters, with red border, below the 'Summary' field when creating a new issue:

            Please read our JIRA guidelines before creating an issue.

            The first sentence, a "notice" on the linked wiki page, on yellow "note" background, with "warning" symbol next to it:

            The Jenkins JIRA is not a support site. If you need assistance or have general questions, visit us in chat, or email one of the mailing lists.

            This is followed by quite detailed instructions what to do before filing a bug, and what information to provide.

            So don't be surprised then if issues that look like requests for help, and don't provide crucial information, receive negative responses.

            And to clarify – it's not like we're not reading IRC or the mailing lists either and just want you to go away; the three people responding to you here are among the most active users there!

            mu88 M U added a comment -

            Dear Daniel Beck,
            I perfectly understand your situation, but try to understand my position: I've read https://wiki.jenkins-ci.org/display/JENKINS/Jenkins+is+hanging and created the requested reports. Afterwards, I've opened an entry in your Google group https://groups.google.com/forum/#!topic/jenkinsci-users/t6P3hjM3DEA and got the advice to create a bug report. Within the ticket, I've added all the created reports.

            I see no point in your JIRA guidelines that would change my opinion of creating a bug report: I've checked all the existing tickets, but none of them did describe my problem exactly.
            I was using the current version of Jenkins when opening the ticket, so your general complaint that you often have to close tickets because the reported issues have been solved in newer versions may be right and comprehensible, but not relevant in my special case. This is an unobjective fact.

            To summarize and emphasize: the Jenkins-Update-UI provides a CheckBox to trigger a restart. As far as I understand a restart, it should stop and start the system properly so that it can be used again. When using the Restart-CheckBox, Jenkins gets stopped and partially started, but does not return so that it can be used - therefore it is a bug.
            Whether this behaviour occurs because of Jenkins, Java, Windows or the lord himself is not the point, it occurs within Jenkins. If you would find out that Java is responsible, then I would have to contact Oracle and closing the JIRA ticket would be the correct way.

            I really don't want to struggle, but saying that the requestor is the only person making a mistake and negating the fact that the software does not work properly is a little biased. Anyway, I know that we disagree about the communication, but I would appreciate focussing on the solution on the real issue of this ticket, because I still encounter the problem, even in Jenkins 2.37.
            So if you have further questions regarding the technical problems, please do not hesitate to contact me. If you have further words to say about the non-technical stuff, we should clarify this by PM, because this really pollutes the issue.

            Regards


              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              mu88 M U
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated: