Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-40068

Dashboard view masks later commit failure with earlier commit success

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Cannot Reproduce
    • blueocean-plugin
    • None
    • blue-ocean beta 1.0.0-b12, Jenkins ver. 2.19.3 inside a docker container
    • iapetus

    Description

      Scenario
      Commit history looks like:

      • r2 - commit that breaks
      • r1 - commit that works

      If commit r1 finishes later than r2 then the dashboard shows a successful card for r1 instead of the lasted failure for r2.

      Original
      I'm using subversion and pipelines
      I favourite a particular pipeline X
      I make a pipeline X-passing commit and then a failing pipeline X commit
      The failing commit fails early in the pipeline i.e. unit tests
      The earlier good commit continues through the pipeline and finishes successfully and at a time after the end of the failing commit's pipeline
      The blue-ocean beta dashboard view shows me a green tick box rather than a red angry box

      This is not what I want, I want to know that my last commit broke the world.

      Additional:

      Branch view of multibranch project only shows one branch at a time - it may be not showing the most appropriate branch either (in this case I was seeing the most recent success even when there were running builds)

      Attachments

        Activity

          jamesdumay James Dumay added a comment -

          mattjmlane thanks for taking the time to report this issue.

          In your scenario you have two commits - one that will cause the Pipeline to fail and another commit that will cause the Pipeline to pass.

          Your history looks like:

          • r2 - commit that breaks
          • r1 - commit that works

          Did r1 end up finishing after r2?

          jamesdumay James Dumay added a comment - mattjmlane thanks for taking the time to report this issue. In your scenario you have two commits - one that will cause the Pipeline to fail and another commit that will cause the Pipeline to pass. Your history looks like: r2 - commit that breaks r1 - commit that works Did r1 end up finishing after r2 ?
          mattjmlane matt lane added a comment -

          Hi, sorry for the delay.

          Yes r1 ends up finishing after r2.

          mattjmlane matt lane added a comment - Hi, sorry for the delay. Yes r1 ends up finishing after r2.
          jamesdumay James Dumay added a comment -

          mattjmlane thanks!

          jamesdumay James Dumay added a comment - mattjmlane thanks!
          michaelneale Michael Neale added a comment -

          This may also be a problem on the branch screen - it can only show one branch running - and it might be pickign the right one.

          michaelneale Michael Neale added a comment - This may also be a problem on the branch screen - it can only show one branch running - and it might be pickign the right one.
          imeredith Ivan Meredith added a comment -

          mattjmlane I think this may have been already fixed. If you can confirm with latest release that would be appreciated.

          imeredith Ivan Meredith added a comment - mattjmlane I think this may have been already fixed. If you can confirm with latest release that would be appreciated.

          People

            imeredith Ivan Meredith
            mattjmlane matt lane
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: