Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-42580

With 'HP Application Automation Tools' v5.1 installed running a pipeline from script stored in Perforce results in NPE

    XMLWordPrintable

    Details

    • Similar Issues:
    • Epic Link:

      Description

      Trying to run a pipeline job with the pipeline groovy script downloaded from Perforce (with the P4 plugin) fails with a null pointer exception (NPE).

      java.lang.NullPointerException
      	at com.hp.application.automation.tools.octane.events.SCMListenerImpl.onChangeLogParsed(SCMListenerImpl.java:84)
      	at org.jenkinsci.plugins.workflow.job.WorkflowRun.onCheckout(WorkflowRun.java:751)
      	at org.jenkinsci.plugins.workflow.job.WorkflowRun.access$1500(WorkflowRun.java:125)
      	at org.jenkinsci.plugins.workflow.job.WorkflowRun$SCMListenerImpl.onCheckout(WorkflowRun.java:936)
      	at org.jenkinsci.plugins.workflow.steps.scm.SCMStep.checkout(SCMStep.java:123)
      	at org.jenkinsci.plugins.workflow.cps.CpsScmFlowDefinition.create(CpsScmFlowDefinition.java:130)
      	at org.jenkinsci.plugins.workflow.cps.CpsScmFlowDefinition.create(CpsScmFlowDefinition.java:59)
      	at org.jenkinsci.plugins.workflow.job.WorkflowRun.run(WorkflowRun.java:232)
      	at hudson.model.ResourceController.execute(ResourceController.java:98)
      	at hudson.model.Executor.run(Executor.java:404)
      

      Note that the exact same configuration works without any issues when using HP Application Automation Tools v5.0 instead of v5.1.

        Attachments

          Issue Links

            Activity

            jbogers Jeroen Bogers created issue -
            yafim_kazak Yafim Kazak made changes -
            Field Original Value New Value
            Assignee Ofir Shaked [ ofirshaked ] Yafim Kazak [ yafim_kazak ]
            yafim_kazak Yafim Kazak added a comment -

            Hi please add information on the used build step.

            Also could you please add your Build config and log, job config.

            fredericmeyrou Frédéric Meyrou added a comment -

            Hi,

            Same pb here without perforce but SVN on latest LTS version of Jenkins.

             

            ./FM

            fredericmeyrou Frédéric Meyrou added a comment -

            REverting to V5.0 is solving the problem.

            yafim_kazak Yafim Kazak added a comment -

            I'm investigating this - it's quite an odd issue, since we didn't modify any of the LR parts in this release.

             

            I have a feeling it's kind of dependency issue -

            could you please send build logs and config here or to my email at kazak[at]hpe[dot]com.

             

            Please try to also simply set scenario and general timeout.

            We will try to publish a fix asap.

             

             

            yafim_kazak Yafim Kazak added a comment -

            Could you please add here or send to Kazak[at]hpe[dot]com the following -

            <jenkins installation on master>\jobs\<job name>\config.xml

            zip whole folder - <jenkins installation on master>\jobs\<job name>\builds\<bad build number>

             

            Thanks ahaed.

             

            fredericmeyrou Frédéric Meyrou added a comment -

            Files sent today by eMail.

            KR,

             

            ./FM

            yafim_kazak Yafim Kazak made changes -
            Status Open [ 1 ] In Progress [ 3 ]
            rpocase Robby Pocase added a comment -

            I'm getting this error on my Perforce instance as well. Seems to be occurring on both classic depots and streams.

            rpocase Robby Pocase added a comment -

            For my specific use case, I'm able to work around this using try/catch.

             

            try {
              p4sync args
            } catch (NullPointerException e) {
              echo "Ignoring NPE"
            }
            mseldin Michael Seldin made changes -
            Link This issue is related to JENKINS-43109 [ JENKINS-43109 ]
            yafim_kazak Yafim Kazak made changes -
            Epic Link JENKINS-43110 [ 180223 ]
            yafim_kazak Yafim Kazak made changes -
            Assignee Yafim Kazak [ yafim_kazak ] Michael Seldin [ mseldin ]
            yafim_kazak Yafim Kazak made changes -
            Labels ALM
            yafim_kazak Yafim Kazak added a comment - - edited

            This should be resolved in our latest beta release 5.1.0.2 and will be formally released in Aug 2017

            • To get the beta follow the instruction here:

            https://hpsa.github.io/JenkinsPluginUpdateCenter/

            • Or download it manually:

            https://updates.jenkins-ci.org/experimental/latest/hp-application-automation-tools-plugin.hpi

            rpionke Raphael Pionke added a comment -

            Yafim Kazak this issue breaks nearly every build on our productive CI system. We can't use the plugin anymore. Why dont you fix this asap as version 5.1.1 or something like this? 

            yafim_kazak Yafim Kazak added a comment -

            Hi - it was resolved in 5.1.0.2.

            Please download it and update us if it still continuous.

            jbogers Jeroen Bogers added a comment -

            Raphael Pionke, if you are unwilling to run a beta version you can always revert back to 5.0 as that version still works. We are running 5.0 on our systems for this reason. We will probably wait until 5.1.0.2 is officially released before we upgrade again.

            yafim_kazak Yafim Kazak made changes -
            Link This issue is duplicated by JENKINS-44021 [ JENKINS-44021 ]
            yafim_kazak Yafim Kazak made changes -
            Link This issue is duplicated by JENKINS-33433 [ JENKINS-33433 ]
            yafim_kazak Yafim Kazak made changes -
            Labels ALM ALM octane
            yafim_kazak Yafim Kazak made changes -
            Link This issue is related to JENKINS-44021 [ JENKINS-44021 ]
            yafim_kazak Yafim Kazak made changes -
            Link This issue is related to JENKINS-44021 [ JENKINS-44021 ]
            yafim_kazak Yafim Kazak made changes -
            Link This issue is duplicated by JENKINS-44021 [ JENKINS-44021 ]
            mseldin Michael Seldin made changes -
            Resolution Fixed [ 1 ]
            Status In Progress [ 3 ] Resolved [ 5 ]
            sezendebruijn Sezen de Bruijn added a comment -

            Came across the exact same issue within version 5.2. Could it have been reintroduced?

            yafim_kazak Yafim Kazak made changes -
            Resolution Fixed [ 1 ]
            Status Resolved [ 5 ] Reopened [ 4 ]
            roy_lu Roy Lu added a comment -

            Hi Yafim Kazak,

            I saw you reopened this. Is it still not resolved?

            mseldin Michael Seldin made changes -
            Resolution Cannot Reproduce [ 5 ]
            Status Reopened [ 4 ] Fixed but Unreleased [ 10203 ]

              People

              Assignee:
              mseldin Michael Seldin
              Reporter:
              jbogers Jeroen Bogers
              Votes:
              3 Vote for this issue
              Watchers:
              9 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: