Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-4290

The Jabber plugin prevents the end of the build

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Critical
    • Resolution: Fixed
    • jabber-plugin
    • None
    • Platform: All, OS: All

    Description

      since version 0.9 of the Hudson Jabber notifier plugin
      my build do not complete, they stop on jabber notification, either on manually
      entered targets or on scm suspects.

      nothing shows up in logs, and the build can't be stopped from hudson interface.
      killing their processes does not work either since there is no process to kill.

      so i end up having to restart hudson.

      Details :
      we're using an internal jabber server, and our organization is using a proxy,
      but to connect to the jabber server, the proxy is not needed.

      example of logs :
      after build :
      Sending notification to: javabuild-status@f4-group.com

      in hudson.log :
      INFO: $PROJECT_NAME$ #441 main build action completed: SUCCESS

      if i disable the jabber plugin, everything works fine.

      Attachments

        1. stack.full
          53 kB
        2. stack.light
          42 kB

        Activity

          kutzi kutzi added a comment -

          It would be incredibly helpful, if you could attach a stacktrace taken at the
          moment when the build is not responding anymore. Otherwise I can probably only
          guess what's the problem. You can use jstack
          (http://java.sun.com/javase/6/docs/technotes/tools/share/jstack.html) fot that.

          kutzi kutzi added a comment - It would be incredibly helpful, if you could attach a stacktrace taken at the moment when the build is not responding anymore. Otherwise I can probably only guess what's the problem. You can use jstack ( http://java.sun.com/javase/6/docs/technotes/tools/share/jstack.html ) fot that.
          kutzi kutzi added a comment -

          Also, please append any logs. For instance: don't you have any log entries like:
          "Connected to XMPP on "
          or
          "Trying to reconnect"
          ?

          kutzi kutzi added a comment - Also, please append any logs. For instance: don't you have any log entries like: "Connected to XMPP on " or "Trying to reconnect" ?
          cactusbone cactusbone added a comment -

          i'm trying to reproduce the problem to get you a stacktrace.
          this doesn't seem to happen if i don't use the suffix feature.

          i have some
          Aug 24, 2009 10:43:08 AM hudson.plugins.jabber.im.transport.JabberIMConnection
          connectAll
          INFO: Connected to XMPP on im.f4-toys.com:5222
          Aug 24, 2009 10:43:07 AM
          hudson.plugins.jabber.im.transport.JabberIMConnection$Connector run
          INFO: Connect thread interrupted

          in the logs, and some working notifications.

          while i had the problems, i could not find anything in the logs related to
          jabber. i'll update as soon as i reproduce (or close otherwise)

          cactusbone cactusbone added a comment - i'm trying to reproduce the problem to get you a stacktrace. this doesn't seem to happen if i don't use the suffix feature. i have some Aug 24, 2009 10:43:08 AM hudson.plugins.jabber.im.transport.JabberIMConnection connectAll INFO: Connected to XMPP on im.f4-toys.com:5222 Aug 24, 2009 10:43:07 AM hudson.plugins.jabber.im.transport.JabberIMConnection$Connector run INFO: Connect thread interrupted in the logs, and some working notifications. while i had the problems, i could not find anything in the logs related to jabber. i'll update as soon as i reproduce (or close otherwise)
          kutzi kutzi added a comment -

          I've got an idea how the build could hang, but that involves a blocking firewall
          and a reconnection attempt from the plugin to the Jabber server.

          kutzi kutzi added a comment - I've got an idea how the build could hang, but that involves a blocking firewall and a reconnection attempt from the plugin to the Jabber server.
          cactusbone cactusbone added a comment -

          the problem does not appear anymore, despite going back to the options which
          generated the problem at first.

          i'll reopen with stack and logs if i happen to reproduce in the future.

          thanks for the help anyway

          (our jabber server is not behind a firewall so this is probably not the problem i
          encountered)

          cactusbone cactusbone added a comment - the problem does not appear anymore, despite going back to the options which generated the problem at first. i'll reopen with stack and logs if i happen to reproduce in the future. thanks for the help anyway (our jabber server is not behind a firewall so this is probably not the problem i encountered)
          cactusbone cactusbone added a comment -

          closing.

          cactusbone cactusbone added a comment - closing.
          cactusbone cactusbone added a comment -

          ok it just happened again

          logs (from the logs file, filtered with jabber keyword)

          Aug 27, 2009 11:20:00 AM
          hudson.plugins.jabber.im.transport.JabberIMConnection$Connector run
          INFO: Connect thread interrupted
          Aug 27, 2009 11:20:00 AM hudson.plugins.jabber.im.transport.JabberIMConnection
          connectAll
          INFO: Connected to XMPP on im.f4-toys.com:5222
          ...
          Aug 27, 2009 11:54:26 AM hudson.plugins.jabber.im.IMPublisher perform
          INFO: Notifying suspects
          Aug 27, 2009 11:54:26 AM hudson.plugins.jabber.im.IMPublisher
          calculateSuspectsTargets
          INFO: Default Suffix: @f4-group.com
          Aug 27, 2009 11:54:26 AM hudson.plugins.jabber.im.IMPublisher
          calculateSuspectsTargets
          INFO: Possible target: dmo dmo
          Aug 27, 2009 11:54:26 AM hudson.plugins.jabber.im.IMPublisher
          calculateSuspectsTargets
          INFO: Possible target: dmo dmo
          Aug 27, 2009 11:54:26 AM hudson.plugins.jabber.im.IMPublisher
          calculateSuspectsTargets
          INFO: Possible target: yjo yjo
          ...
          Aug 27, 2009 12:50:31 PM hudson.plugins.jabber.im.IMPublisher perform
          INFO: Notifying suspects
          Aug 27, 2009 12:50:31 PM hudson.plugins.jabber.im.IMPublisher
          calculateSuspectsTargets
          INFO: Default Suffix: @f4-group.com
          Aug 27, 2009 12:50:31 PM hudson.plugins.jabber.im.IMPublisher
          calculateSuspectsTargets
          INFO: Possible target: dmo dmo
          Aug 27, 2009 12:50:31 PM hudson.plugins.jabber.im.IMPublisher
          calculateSuspectsTargets
          INFO: Possible target: yjo yjo
          Aug 27, 2009 12:50:31 PM hudson.plugins.jabber.im.IMPublisher
          calculateSuspectsTargets
          INFO: Possible target: yjo yjo
          Aug 27, 2009 12:50:31 PM hudson.plugins.jabber.im.IMPublisher
          calculateSuspectsTargets
          INFO: Possible target: yjo yjo

          however i have this in logs :
          Aug 27, 2009 11:21:20 AM org.jinterop.dcom.core.PingObject read
          SEVERE: Some error ! Simple ping failed , hresult: 1912
          like a thousand times

          in the build console logs i have :
          Recording test results
          Sending notification to suspect: yjo@f4-group.com
          Sending notification to suspect: dmo@f4-group.com

          and that's the last lines.

          stack traces incoming

          cactusbone cactusbone added a comment - ok it just happened again logs (from the logs file, filtered with jabber keyword) Aug 27, 2009 11:20:00 AM hudson.plugins.jabber.im.transport.JabberIMConnection$Connector run INFO: Connect thread interrupted Aug 27, 2009 11:20:00 AM hudson.plugins.jabber.im.transport.JabberIMConnection connectAll INFO: Connected to XMPP on im.f4-toys.com:5222 ... Aug 27, 2009 11:54:26 AM hudson.plugins.jabber.im.IMPublisher perform INFO: Notifying suspects Aug 27, 2009 11:54:26 AM hudson.plugins.jabber.im.IMPublisher calculateSuspectsTargets INFO: Default Suffix: @f4-group.com Aug 27, 2009 11:54:26 AM hudson.plugins.jabber.im.IMPublisher calculateSuspectsTargets INFO: Possible target: dmo dmo Aug 27, 2009 11:54:26 AM hudson.plugins.jabber.im.IMPublisher calculateSuspectsTargets INFO: Possible target: dmo dmo Aug 27, 2009 11:54:26 AM hudson.plugins.jabber.im.IMPublisher calculateSuspectsTargets INFO: Possible target: yjo yjo ... Aug 27, 2009 12:50:31 PM hudson.plugins.jabber.im.IMPublisher perform INFO: Notifying suspects Aug 27, 2009 12:50:31 PM hudson.plugins.jabber.im.IMPublisher calculateSuspectsTargets INFO: Default Suffix: @f4-group.com Aug 27, 2009 12:50:31 PM hudson.plugins.jabber.im.IMPublisher calculateSuspectsTargets INFO: Possible target: dmo dmo Aug 27, 2009 12:50:31 PM hudson.plugins.jabber.im.IMPublisher calculateSuspectsTargets INFO: Possible target: yjo yjo Aug 27, 2009 12:50:31 PM hudson.plugins.jabber.im.IMPublisher calculateSuspectsTargets INFO: Possible target: yjo yjo Aug 27, 2009 12:50:31 PM hudson.plugins.jabber.im.IMPublisher calculateSuspectsTargets INFO: Possible target: yjo yjo however i have this in logs : Aug 27, 2009 11:21:20 AM org.jinterop.dcom.core.PingObject read SEVERE: Some error ! Simple ping failed , hresult: 1912 like a thousand times in the build console logs i have : Recording test results Sending notification to suspect: yjo@f4-group.com Sending notification to suspect: dmo@f4-group.com and that's the last lines. stack traces incoming
          cactusbone cactusbone added a comment -

          right now, i have 2 builds stuck in the same way.
          i did two stack trace, one with all my running build, one with hudson in shuting
          down mode and the 2 stuck builds (which i can't stop from hudson)

          cactusbone cactusbone added a comment - right now, i have 2 builds stuck in the same way. i did two stack trace, one with all my running build, one with hudson in shuting down mode and the 2 stuck builds (which i can't stop from hudson)
          kutzi kutzi added a comment -

          As far as I've seen org.jinterop.dcom.core.PingObject has nothing to do with the
          Jabber plugin.

          Please remember to attach the stacktraces.

          thanks

          kutzi kutzi added a comment - As far as I've seen org.jinterop.dcom.core.PingObject has nothing to do with the Jabber plugin. Please remember to attach the stacktraces. thanks
          cactusbone cactusbone added a comment -

          Created an attachment (id=874)
          stack with full builds hudson

          cactusbone cactusbone added a comment - Created an attachment (id=874) stack with full builds hudson
          cactusbone cactusbone added a comment -

          Created an attachment (id=875)
          stack with only stuck builds on hudson

          cactusbone cactusbone added a comment - Created an attachment (id=875) stack with only stuck builds on hudson
          cactusbone cactusbone added a comment -

          just to confirm :
          this line : SEVERE: Some error ! Simple ping failed , hresult: 1912 doesn't appear
          anymore, but the builds still get stuck. (I restarted hudson)

          seems like this is linked to the Default Suffix feature. (because without a
          specified suffix, it works well)

          both users in the previous log have a Jabber ID specified.

          cactusbone cactusbone added a comment - just to confirm : this line : SEVERE: Some error ! Simple ping failed , hresult: 1912 doesn't appear anymore, but the builds still get stuck. (I restarted hudson) seems like this is linked to the Default Suffix feature. (because without a specified suffix, it works well) both users in the previous log have a Jabber ID specified.
          cactusbone cactusbone added a comment -

          on a sidenote, i did not receive mails for those stuck builds, so it might be the
          mail plugin that's failing. it is possible the suffix feature impacts the mail
          sending ? (or it might simply be that mails are sent after the jabber plugin
          returns)

          cactusbone cactusbone added a comment - on a sidenote, i did not receive mails for those stuck builds, so it might be the mail plugin that's failing. it is possible the suffix feature impacts the mail sending ? (or it might simply be that mails are sent after the jabber plugin returns)
          kutzi kutzi added a comment -

          I assume that the previous build in the cases where Hudson did lock up was an
          aborted (or 'not_build') build?

          In that case, it is fixed in 0.10

          kutzi kutzi added a comment - I assume that the previous build in the cases where Hudson did lock up was an aborted (or 'not_build') build? In that case, it is fixed in 0.10
          cactusbone cactusbone added a comment -

          yup, the stuck builds were indeed aborted
          i updated, i'll close tomorrow if it's ok

          thanks for the quick fix !

          cactusbone cactusbone added a comment - yup, the stuck builds were indeed aborted i updated, i'll close tomorrow if it's ok thanks for the quick fix !
          cactusbone cactusbone added a comment -

          it works ! thanks

          cactusbone cactusbone added a comment - it works ! thanks

          People

            kutzi kutzi
            cactusbone cactusbone
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: