Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-42956

Unable to install ant plugin (java.util.zip.ZipException: error in opening zip file)

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Blocker
    • Resolution: Cannot Reproduce
    • Component/s: ant-plugin
    • Environment:
    • Similar Issues:

      Description

      1. Installed Jenkins 2.7.2 wit the help of installer

      2. Windows service is running

      3. Successfully connected to the Jenkins URL (http://localhost:8081)

      Requirement:

      I want to install ant plugin and when I tried to upload ant hpi manually thriugh 'Manage plugins' page it was looking for lot of dependent files and hence i chose to install from command prompt which would ease the process.

      Hence I typed below command from jenkins installed directory

      java -jar jenkins-cli.jar -s http://localhost:8081/ -noCertificateCheck install-plugin http://updates.jenkins.io/download/plugins/ant/1.4/ant.hpi -deploy -restart

      Here I'm bypassing the ssl checks since updates.jenkins.io is a https enabled server and the output of above command is as below

      Issue: (Output)

      Skipping HTTPS certificate checks altogether. Note that this is not secure at all.
      Installing a plugin from http://updates.jenkins.io/download/plugins/ant/1.4/ant.hpi

      ERROR: Unexpected exception occurred while performing install-plugin command.
      java.util.zip.ZipException: error in opening zip file
      at java.util.zip.ZipFile.open(Native Method)
      at java.util.zip.ZipFile.<init>(Unknown Source)
      at java.util.zip.ZipFile.<init>(Unknown Source)
      at java.util.jar.JarFile.<init>(Unknown Source)
      at java.util.jar.JarFile.<init>(Unknown Source)
      at hudson.ClassicPluginStrategy.getShortName(ClassicPluginStrategy.java:114)
      at hudson.PluginManager.dynamicLoad(PluginManager.java:787)
      at hudson.PluginManager.dynamicLoad(PluginManager.java:775)
      at hudson.cli.InstallPluginCommand.run(InstallPluginCommand.java:106)
      at hudson.cli.CLICommand.main(CLICommand.java:257)
      at hudson.cli.CliManagerImpl.main(CliManagerImpl.java:92)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      at java.lang.reflect.Method.invoke(Unknown Source)
      at hudson.remoting.RemoteInvocationHandler$RPCRequest.perform(RemoteInvocationHandler.java:884)
      at hudson.remoting.RemoteInvocationHandler$RPCRequest.call(RemoteInvocationHandler.java:859)
      at hudson.remoting.RemoteInvocationHandler$RPCRequest.call(RemoteInvocationHandler.java:818)
      at hudson.remoting.UserRequest.perform(UserRequest.java:153)
      at hudson.remoting.UserRequest.perform(UserRequest.java:50)
      at hudson.remoting.Request$2.run(Request.java:332)
      at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:68)
      at hudson.cli.CliManagerImpl$1.call(CliManagerImpl.java:63)
      at hudson.remoting.CallableDecoratorAdapter.call(CallableDecoratorAdapter.java:18)
      at hudson.remoting.CallableDecoratorList$1.call(CallableDecoratorList.java:21)
      at jenkins.util.ContextResettingExecutorService$2.call(ContextResettingExecutorService.java:46)
      at java.util.concurrent.FutureTask.run(Unknown Source)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
      at java.lang.Thread.run(Unknown Source)

        Attachments

          Activity

          sridattasp sridatta s created issue -
          sridattasp sridatta s made changes -
          Field Original Value New Value
          Description 1. Installed Jenkins 2.7.2 wit the help of installer

          2. Windows service is running

          3. Successfully connected to the Jenkins URL ([http://localhost:8081)|http://localhost:8081)/]

          *+Requirement:+*

          I want to install ant plugin and when I tried to upload ant hpi manually thriugh 'Manage plugins' page it was looking for lot of dependent files and hence i chose to install from command prompt which would ease the process.

          Hence I typed below command from jenkins installed directory

          java -jar jenkins-cli.jar -s http://localhost:8081/ -noCertificateCheck install-plugin http://updates.jenkins.io/download/plugins/ant/1.4/ant.hpi -deploy -restart

          Here I'm bypassing the ssl checks since updates.jenkins.io is a https enabled server and the output of above command is as below

          Skipping HTTPS certificate checks altogether. Note that this is not secure at all.
          Installing a plugin from http://updates.jenkins.io/download/plugins/ant/1.4/ant.hpi

          +*Issue:*+

          ERROR: Unexpected exception occurred while performing install-plugin command.
          java.util.zip.ZipException: error in opening zip file
           at java.util.zip.ZipFile.open(Native Method)
           at java.util.zip.ZipFile.<init>(Unknown Source)
           at java.util.zip.ZipFile.<init>(Unknown Source)
           at java.util.jar.JarFile.<init>(Unknown Source)
           at java.util.jar.JarFile.<init>(Unknown Source)
           at hudson.ClassicPluginStrategy.getShortName(ClassicPluginStrategy.java:114)
           at hudson.PluginManager.dynamicLoad(PluginManager.java:787)
           at hudson.PluginManager.dynamicLoad(PluginManager.java:775)
           at hudson.cli.InstallPluginCommand.run(InstallPluginCommand.java:106)
           at hudson.cli.CLICommand.main(CLICommand.java:257)
           at hudson.cli.CliManagerImpl.main(CliManagerImpl.java:92)
           at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
           at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
           at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
           at java.lang.reflect.Method.invoke(Unknown Source)
           at hudson.remoting.RemoteInvocationHandler$RPCRequest.perform(RemoteInvocationHandler.java:884)
           at hudson.remoting.RemoteInvocationHandler$RPCRequest.call(RemoteInvocationHandler.java:859)
           at hudson.remoting.RemoteInvocationHandler$RPCRequest.call(RemoteInvocationHandler.java:818)
           at hudson.remoting.UserRequest.perform(UserRequest.java:153)
           at hudson.remoting.UserRequest.perform(UserRequest.java:50)
           at hudson.remoting.Request$2.run(Request.java:332)
           at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:68)
           at hudson.cli.CliManagerImpl$1.call(CliManagerImpl.java:63)
           at hudson.remoting.CallableDecoratorAdapter.call(CallableDecoratorAdapter.java:18)
           at hudson.remoting.CallableDecoratorList$1.call(CallableDecoratorList.java:21)
           at jenkins.util.ContextResettingExecutorService$2.call(ContextResettingExecutorService.java:46)
           at java.util.concurrent.FutureTask.run(Unknown Source)
           at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
           at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
           at java.lang.Thread.run(Unknown Source)
          1. Installed Jenkins 2.7.2 wit the help of installer

          2. Windows service is running

          3. Successfully connected to the Jenkins URL ([http://localhost:8081)|http://localhost:8081)/]

          *+Requirement:+*

          I want to install ant plugin and when I tried to upload ant hpi manually thriugh 'Manage plugins' page it was looking for lot of dependent files and hence i chose to install from command prompt which would ease the process.

          Hence I typed below command from jenkins installed directory

          java -jar jenkins-cli.jar -s [http://localhost:8081/] -noCertificateCheck install-plugin [http://updates.jenkins.io/download/plugins/ant/1.4/ant.hpi] -deploy -restart

          Here I'm bypassing the ssl checks since updates.jenkins.io is a https enabled server and the output of above command is as below

          *+Issue: (Output)+*

          Skipping HTTPS certificate checks altogether. Note that this is not secure at all.
           Installing a plugin from [http://updates.jenkins.io/download/plugins/ant/1.4/ant.hpi]

          ERROR: Unexpected exception occurred while performing install-plugin command.
           java.util.zip.ZipException: error in opening zip file
           at java.util.zip.ZipFile.open(Native Method)
           at java.util.zip.ZipFile.<init>(Unknown Source)
           at java.util.zip.ZipFile.<init>(Unknown Source)
           at java.util.jar.JarFile.<init>(Unknown Source)
           at java.util.jar.JarFile.<init>(Unknown Source)
           at hudson.ClassicPluginStrategy.getShortName(ClassicPluginStrategy.java:114)
           at hudson.PluginManager.dynamicLoad(PluginManager.java:787)
           at hudson.PluginManager.dynamicLoad(PluginManager.java:775)
           at hudson.cli.InstallPluginCommand.run(InstallPluginCommand.java:106)
           at hudson.cli.CLICommand.main(CLICommand.java:257)
           at hudson.cli.CliManagerImpl.main(CliManagerImpl.java:92)
           at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
           at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
           at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
           at java.lang.reflect.Method.invoke(Unknown Source)
           at hudson.remoting.RemoteInvocationHandler$RPCRequest.perform(RemoteInvocationHandler.java:884)
           at hudson.remoting.RemoteInvocationHandler$RPCRequest.call(RemoteInvocationHandler.java:859)
           at hudson.remoting.RemoteInvocationHandler$RPCRequest.call(RemoteInvocationHandler.java:818)
           at hudson.remoting.UserRequest.perform(UserRequest.java:153)
           at hudson.remoting.UserRequest.perform(UserRequest.java:50)
           at hudson.remoting.Request$2.run(Request.java:332)
           at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:68)
           at hudson.cli.CliManagerImpl$1.call(CliManagerImpl.java:63)
           at hudson.remoting.CallableDecoratorAdapter.call(CallableDecoratorAdapter.java:18)
           at hudson.remoting.CallableDecoratorList$1.call(CallableDecoratorList.java:21)
           at jenkins.util.ContextResettingExecutorService$2.call(ContextResettingExecutorService.java:46)
           at java.util.concurrent.FutureTask.run(Unknown Source)
           at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
           at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
           at java.lang.Thread.run(Unknown Source)
          sridattasp sridatta s made changes -
          Description 1. Installed Jenkins 2.7.2 wit the help of installer

          2. Windows service is running

          3. Successfully connected to the Jenkins URL ([http://localhost:8081)|http://localhost:8081)/]

          *+Requirement:+*

          I want to install ant plugin and when I tried to upload ant hpi manually thriugh 'Manage plugins' page it was looking for lot of dependent files and hence i chose to install from command prompt which would ease the process.

          Hence I typed below command from jenkins installed directory

          java -jar jenkins-cli.jar -s [http://localhost:8081/] -noCertificateCheck install-plugin [http://updates.jenkins.io/download/plugins/ant/1.4/ant.hpi] -deploy -restart

          Here I'm bypassing the ssl checks since updates.jenkins.io is a https enabled server and the output of above command is as below

          *+Issue: (Output)+*

          Skipping HTTPS certificate checks altogether. Note that this is not secure at all.
           Installing a plugin from [http://updates.jenkins.io/download/plugins/ant/1.4/ant.hpi]

          ERROR: Unexpected exception occurred while performing install-plugin command.
           java.util.zip.ZipException: error in opening zip file
           at java.util.zip.ZipFile.open(Native Method)
           at java.util.zip.ZipFile.<init>(Unknown Source)
           at java.util.zip.ZipFile.<init>(Unknown Source)
           at java.util.jar.JarFile.<init>(Unknown Source)
           at java.util.jar.JarFile.<init>(Unknown Source)
           at hudson.ClassicPluginStrategy.getShortName(ClassicPluginStrategy.java:114)
           at hudson.PluginManager.dynamicLoad(PluginManager.java:787)
           at hudson.PluginManager.dynamicLoad(PluginManager.java:775)
           at hudson.cli.InstallPluginCommand.run(InstallPluginCommand.java:106)
           at hudson.cli.CLICommand.main(CLICommand.java:257)
           at hudson.cli.CliManagerImpl.main(CliManagerImpl.java:92)
           at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
           at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
           at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
           at java.lang.reflect.Method.invoke(Unknown Source)
           at hudson.remoting.RemoteInvocationHandler$RPCRequest.perform(RemoteInvocationHandler.java:884)
           at hudson.remoting.RemoteInvocationHandler$RPCRequest.call(RemoteInvocationHandler.java:859)
           at hudson.remoting.RemoteInvocationHandler$RPCRequest.call(RemoteInvocationHandler.java:818)
           at hudson.remoting.UserRequest.perform(UserRequest.java:153)
           at hudson.remoting.UserRequest.perform(UserRequest.java:50)
           at hudson.remoting.Request$2.run(Request.java:332)
           at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:68)
           at hudson.cli.CliManagerImpl$1.call(CliManagerImpl.java:63)
           at hudson.remoting.CallableDecoratorAdapter.call(CallableDecoratorAdapter.java:18)
           at hudson.remoting.CallableDecoratorList$1.call(CallableDecoratorList.java:21)
           at jenkins.util.ContextResettingExecutorService$2.call(ContextResettingExecutorService.java:46)
           at java.util.concurrent.FutureTask.run(Unknown Source)
           at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
           at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
           at java.lang.Thread.run(Unknown Source)
          1. Installed Jenkins 2.7.2 wit the help of installer

          2. Windows service is running

          3. Successfully connected to the Jenkins URL ([http://localhost:8081)|http://localhost:8081)/]

          *+Requirement:+*

          I want to install ant plugin and when I tried to upload ant hpi manually thriugh 'Manage plugins' page it was looking for lot of dependent files and hence i chose to install from command prompt which would ease the process.

          Hence I typed below command from jenkins installed directory

          {color:#d04437}*java -jar jenkins-cli.jar -s [http://localhost:8081/] -noCertificateCheck install-plugin [http://updates.jenkins.io/download/plugins/ant/1.4/ant.hpi] -deploy -restart*{color}

          Here I'm bypassing the ssl checks since updates.jenkins.io is a https enabled server and the output of above command is as below

          *+Issue: (Output)+*

          Skipping HTTPS certificate checks altogether. Note that this is not secure at all.
           Installing a plugin from [http://updates.jenkins.io/download/plugins/ant/1.4/ant.hpi]

          ERROR: Unexpected exception occurred while performing install-plugin command.
           java.util.zip.ZipException: error in opening zip file
           at java.util.zip.ZipFile.open(Native Method)
           at java.util.zip.ZipFile.<init>(Unknown Source)
           at java.util.zip.ZipFile.<init>(Unknown Source)
           at java.util.jar.JarFile.<init>(Unknown Source)
           at java.util.jar.JarFile.<init>(Unknown Source)
           at hudson.ClassicPluginStrategy.getShortName(ClassicPluginStrategy.java:114)
           at hudson.PluginManager.dynamicLoad(PluginManager.java:787)
           at hudson.PluginManager.dynamicLoad(PluginManager.java:775)
           at hudson.cli.InstallPluginCommand.run(InstallPluginCommand.java:106)
           at hudson.cli.CLICommand.main(CLICommand.java:257)
           at hudson.cli.CliManagerImpl.main(CliManagerImpl.java:92)
           at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
           at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
           at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
           at java.lang.reflect.Method.invoke(Unknown Source)
           at hudson.remoting.RemoteInvocationHandler$RPCRequest.perform(RemoteInvocationHandler.java:884)
           at hudson.remoting.RemoteInvocationHandler$RPCRequest.call(RemoteInvocationHandler.java:859)
           at hudson.remoting.RemoteInvocationHandler$RPCRequest.call(RemoteInvocationHandler.java:818)
           at hudson.remoting.UserRequest.perform(UserRequest.java:153)
           at hudson.remoting.UserRequest.perform(UserRequest.java:50)
           at hudson.remoting.Request$2.run(Request.java:332)
           at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:68)
           at hudson.cli.CliManagerImpl$1.call(CliManagerImpl.java:63)
           at hudson.remoting.CallableDecoratorAdapter.call(CallableDecoratorAdapter.java:18)
           at hudson.remoting.CallableDecoratorList$1.call(CallableDecoratorList.java:21)
           at jenkins.util.ContextResettingExecutorService$2.call(ContextResettingExecutorService.java:46)
           at java.util.concurrent.FutureTask.run(Unknown Source)
           at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
           at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
           at java.lang.Thread.run(Unknown Source)
          jglick Jesse Glick added a comment -

          Maybe you got a corrupted download somehow?

          jglick Jesse Glick made changes -
          Resolution Cannot Reproduce [ 5 ]
          Status Open [ 1 ] Resolved [ 5 ]

            People

            Assignee:
            armfergom Armando Fernandez
            Reporter:
            sridattasp sridatta s
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: