Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-44021

Issue with HP Application Automation Tools plugin

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      I am trying to utilize HP Application Automation Tools plugin to connect to ALM QC server from Jenkins to execute testscripts created as VAPI-XP-TEST. But I am not seeing "Running Tests Sets from ALM" at options and when I am trying with Running Performance Tests using HP Performance Center option it doesnt work. 

      Also when I am using this plugin some of my other builds failing with below error. Someone could help me to fix these issues?

      I am mainly looking for pipeline script options.
      java.lang.NullPointerException
      at com.hp.application.automation.tools.octane.events.SCMListenerImpl.onChangeLogParsed(SCMListenerImpl.java:84)

        Attachments

          Activity

          Hide
          yafim_kazak Yafim Kazak added a comment -

          Hi,

          please separate each issue into different tickets.

          Please also state the following in environment so that we can better identify the issue:

          1. Jenkins version and plugin version
          2. Master/Slave configuration and OS version
          3. HPE PC version

           

          Thanks,

          Yafim.

          Show
          yafim_kazak Yafim Kazak added a comment - Hi, please separate each issue into different tickets. Please also state the following in environment so that we can better identify the issue: Jenkins version and plugin version Master/Slave configuration and OS version HPE PC version   Thanks, Yafim.
          Hide
          eldojoseph1234 Eldo Joseph added a comment -

          Hi Yafim,

          Please find the details.

          Jenkins version and plugin version

                        CloudBees Jenkins Enterprise 2.46.2.1

          Master/Slave configuration and OS version

                          Linux x86_64 master/slave

          HPE PC version

              12.53

          Show
          eldojoseph1234 Eldo Joseph added a comment - Hi Yafim, Please find the details. Jenkins version and plugin version               CloudBees Jenkins Enterprise 2.46.2.1 Master/Slave configuration and OS version                 Linux x86_64 master/slave HPE PC version     12.53
          Hide
          eldojoseph1234 Eldo Joseph added a comment -

          Yafim,

          Which issue you will be working on this ticket?

          Show
          eldojoseph1234 Eldo Joseph added a comment - Yafim, Which issue you will be working on this ticket?
          Hide
          yafim_kazak Yafim Kazak added a comment -

          Whatever you prefer 

          Show
          yafim_kazak Yafim Kazak added a comment - Whatever you prefer 
          Hide
          eldojoseph1234 Eldo Joseph added a comment -

          I prefer to go with below issue   It will be great if you can fix the issue soon. We are waiting to enable QC test execution.

          I am trying to utilize HP Application Automation Tools plugin to connect to ALM QC server from Jenkins to execute testscripts created as VAPI-XP-TEST. But I am not seeing "Running Tests Sets from ALM" at options and when I am trying with Running Performance Tests using HP Performance Center option it doesnt work. 

          Show
          eldojoseph1234 Eldo Joseph added a comment - I prefer to go with below issue   It will be great if you can fix the issue soon. We are waiting to enable QC test execution. I am trying to utilize HP Application Automation Tools plugin to connect to ALM QC server from Jenkins to execute testscripts created as VAPI-XP-TEST. But I am not seeing "Running Tests Sets from ALM" at options and when I am trying with Running Performance Tests using HP Performance Center option it doesnt work. 
          Hide
          yafim_kazak Yafim Kazak added a comment -

          Please add the plugin version you're using.

          Show
          yafim_kazak Yafim Kazak added a comment - Please add the plugin version you're using.
          Hide
          eldojoseph1234 Eldo Joseph added a comment -

          HP Application Automation Tools 5.1

          Show
          eldojoseph1234 Eldo Joseph added a comment - HP Application Automation Tools 5.1
          Hide
          eldojoseph1234 Eldo Joseph added a comment -

          We made some configuration changes at server and we were able to move forward with windows machine. But we are receiving below error. Is it required plugin upgrade?

           
          The OTA version is not compatible with the current version of the Application Lifecycle Management server:
          http://higalmqcenter/qcbin/wcomsrv.dll
          .
          OTA version: 11.52, OTA build number: 514. Server version: 12.53, server build number: 1683.
          Error: Cannot Login to QC: Authorization failed.
          Build step 'Execute HP functional tests from HP ALM' changed build result to FAILURE

          Show
          eldojoseph1234 Eldo Joseph added a comment - We made some configuration changes at server and we were able to move forward with windows machine. But we are receiving below error. Is it required plugin upgrade?   The OTA version is not compatible with the current version of the Application Lifecycle Management server: http://higalmqcenter/qcbin/wcomsrv.dll . OTA version: 11.52, OTA build number: 514. Server version: 12.53, server build number: 1683. Error: Cannot Login to QC: Authorization failed. Build step 'Execute HP functional tests from HP ALM' changed build result to FAILURE
          Hide
          yafim_kazak Yafim Kazak added a comment -

          xiwen zhao please review.

          Show
          yafim_kazak Yafim Kazak added a comment - xiwen zhao please review.
          Hide
          xiwenhpe xiwen zhao added a comment -

          Hi Joseph,

          Could you please try to run test without Jenkins? Launch UFT on your windows slave, run a test on ALM see if it gets same error.

          Thanks

          Show
          xiwenhpe xiwen zhao added a comment - Hi Joseph, Could you please try to run test without Jenkins? Launch UFT on your windows slave, run a test on ALM see if it gets same error. Thanks
          Hide
          xiwenhpe xiwen zhao added a comment -

          Confirmed with ALM team, OTA must match server version.

          Open ALM on your slave machine, click "Tools", click "HP ALM Client Registration", click "Register HP ALM"

          It should solve your problem.

          Show
          xiwenhpe xiwen zhao added a comment - Confirmed with ALM team, OTA must match server version. Open ALM on your slave machine, click "Tools", click "HP ALM Client Registration", click "Register HP ALM" It should solve your problem.
          Hide
          yafim_kazak Yafim Kazak added a comment -

          Hi Eldo Joseph,
          please confirm if this resolves this issue and close the ticket if it does.
          Thanks.

          Show
          yafim_kazak Yafim Kazak added a comment - Hi Eldo Joseph , please confirm if this resolves this issue and close the ticket if it does. Thanks.
          Hide
          eldojoseph1234 Eldo Joseph added a comment -

          Yafim Kazak, sorry issue is still there. We tried after doing Register process. We are getting a different error now.

           
          HpToolsLauncher.exe -paramfile props26052017111301608.txt
          "Started..."
          Timeout is set to: 60
          Run mode is set to: RUN_PLANNED_HOST
          ============================================================================
          Starting test set execution
          Test set name: SmokeTestSuite, Test set id: 2551
          Could not create scheduler, please verify ALM client installation on run machine by downloading and in installing the add-in form:
          http://higalmqcenter/qcbin//TDConnectivity_index.html

           

          We tried installing TDConnectivity_index.html but not working.

          Show
          eldojoseph1234 Eldo Joseph added a comment - Yafim Kazak , sorry issue is still there. We tried after doing Register process. We are getting a different error now.   HpToolsLauncher.exe -paramfile props26052017111301608.txt "Started..." Timeout is set to: 60 Run mode is set to: RUN_PLANNED_HOST ============================================================================ Starting test set execution Test set name: SmokeTestSuite, Test set id: 2551 Could not create scheduler, please verify ALM client installation on run machine by downloading and in installing the add-in form: http://higalmqcenter/qcbin//TDConnectivity_index.html   We tried installing  TDConnectivity_index.html  but not working.
          Hide
          xiwenhpe xiwen zhao added a comment -

          Hi,

          this is a duplicated issue (JENKINS-19374)

          We are not able to reproduce the problem locally, there is not much we can do at this stage.

          If you need to solve this issue please contact UFT support or ALM support to open a ticket, professional support team will follow up this issue. In this way your problem will have monitoring and tracking, in addition the case will be raised to higher level if it can not be solved in a short time. In another word it is guaranteed to be fixed by raising a support ticket.

          Meanwhile I will mark this issue as closed.

          Show
          xiwenhpe xiwen zhao added a comment - Hi, this is a duplicated issue ( JENKINS-19374 ) We are not able to reproduce the problem locally, there is not much we can do at this stage. If you need to solve this issue please contact UFT support or ALM support to open a ticket, professional support team will follow up this issue. In this way your problem will have monitoring and tracking, in addition the case will be raised to higher level if it can not be solved in a short time. In another word it is guaranteed to be fixed by raising a support ticket. Meanwhile I will mark this issue as closed.

            People

            Assignee:
            evanchen Evan Chen
            Reporter:
            eldojoseph1234 Eldo Joseph
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: