Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-44295

Indexing run a lot of cloning processes on master

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Duplicate
    • Labels:
      None
    • Environment:
      Jenkins ver. 2.46.2
      github-branch-source-plugin 2.0.5
    • Similar Issues:

      Description

      We have big project (~300G) in github and ~300 pull requests and team ~ 100 developers.
      When enable "Scan Repository Triggers" in multibranch it schedule the jobs and all this jobs run on master for clone repository for receive jenkinsfile. It lead to overloading the master and down.
      It not allow use scan trigger.

        Attachments

          Issue Links

            Activity

            dubrsl Viacheslav Dubrovskyi created issue -
            stephenconnolly Stephen Connolly added a comment -

            Closing as a duplicate of a better described RFE.

            This is not a bug but and RFE:

            • the code works
            • the code could work better
            stephenconnolly Stephen Connolly made changes -
            Field Original Value New Value
            Link This issue is blocked by JENKINS-44729 [ JENKINS-44729 ]
            stephenconnolly Stephen Connolly made changes -
            Resolution Duplicate [ 3 ]
            Status Open [ 1 ] Resolved [ 5 ]
            stephenconnolly Stephen Connolly made changes -
            Link This issue duplicates JENKINS-44729 [ JENKINS-44729 ]
            stephenconnolly Stephen Connolly made changes -
            Link This issue is blocked by JENKINS-44729 [ JENKINS-44729 ]

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              dubrsl Viacheslav Dubrovskyi
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: