Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-44625

The job config Cog is not taking into account the organization root folder

    XMLWordPrintable

Details

    • Blue Ocean 1.1, Blue Ocean 1.1

    Description

      If you have an organization lets say api.team which base is on the folder API, when you are on the job supply-chain-portal-app -> build on blue ocean and click on the configure cog, you will be taken to the following ur:

      http://jenkins_url/api.teams/job/supply-chain-portal-app/job/build/configure

      instead of:
      http://jenkins_url/api.teams/job/API/job/supply-chain-portal-app/job/build/configure

      It seems that the root folder of the org: API is not taken into account.

      Attachments

        Issue Links

          Activity

            alobato Alvaro Lobato created issue -
            recampbell Ryan Campbell added a comment - - edited

            Blue Ocean team needs to know what revision this was reproduced on. Have we seen it on 1.1.0-beta9?

            recampbell Ryan Campbell added a comment - - edited Blue Ocean team needs to know what revision this was reproduced on. Have we seen it on 1.1.0-beta9?
            michaelneale Michael Neale added a comment -

            Additionally - does the "escape to jenkins" link (the exit door icon) go to the right place or does it have the same problem? 

            michaelneale Michael Neale added a comment - Additionally - does the "escape to jenkins" link (the exit door icon) go to the right place or does it have the same problem? 
            michaelneale Michael Neale added a comment - - edited

            this seems to be skipping the folder, but the org name is correct. Is there a way to reproduce this in vanilla blue ocean? 

            michaelneale Michael Neale added a comment - - edited this seems to be skipping the folder, but the org name is correct. Is there a way to reproduce this in vanilla blue ocean? 
            alobato Alvaro Lobato added a comment -

            I'm afraid not, because you need to have an org with the base ItemContainer distinct from the Jenkins root, which is not possible with vanilla blue ocean AFIK

            alobato Alvaro Lobato added a comment - I'm afraid not, because you need to have an org with the base ItemContainer distinct from the Jenkins root, which is not possible with vanilla blue ocean AFIK
            michaelneale Michael Neale added a comment -

            alobato what about the escape to jenkins link - is it correct here? 

            michaelneale Michael Neale added a comment - alobato what about the escape to jenkins link - is it correct here? 
            michaelneale Michael Neale made changes -
            Field Original Value New Value
            Sprint Blue Ocean 1.1 [ 321 ]
            alobato Alvaro Lobato added a comment -

            We don't have that link, it has been removed, so I can tell.

            alobato Alvaro Lobato added a comment - We don't have that link, it has been removed, so I can tell.
            vivek Vivek Pandey made changes -
            Status Open [ 1 ] In Progress [ 3 ]
            vivek Vivek Pandey made changes -
            Assignee Vivek Pandey [ vivek ]
            vivek Vivek Pandey made changes -
            Status In Progress [ 3 ] In Review [ 10005 ]
            jamesdumay James Dumay made changes -
            Sprint Blue Ocean 1.1 [ 321 ] Blue Ocean 1.1, Blue Ocean 1.1 [ 321, 331 ]
            michaelneale Michael Neale added a comment - alobato PR ready for you to take a look at:  https://github.com/jenkinsci/blueocean-plugin/pull/1120
            jamesdumay James Dumay made changes -
            Rank Ranked higher
            vivek Vivek Pandey made changes -
            Resolution Fixed [ 1 ]
            Status In Review [ 10005 ] Resolved [ 5 ]
            amuniz Antonio Muñiz made changes -
            Link This issue is related to JENKINS-44818 [ JENKINS-44818 ]
            cloudbees CloudBees Inc. made changes -
            Remote Link This issue links to "CloudBees Internal CJP-7057 (Web Link)" [ 19149 ]
            jbriden Jenn Briden made changes -
            Status Resolved [ 5 ] Closed [ 6 ]

            People

              vivek Vivek Pandey
              alobato Alvaro Lobato
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: