Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-44881

Blue Ocean cannot be opened after upgrade: Chrome browser fluttering

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Fixed
    • Component/s: blueocean-plugin
    • Labels:
    • Environment:
      Jenkins 2.65
      Blue Ocean 1.1.0
      Chrome 58.0.3029.110 (64-bit), on Mac
    • Similar Issues:
    • Sprint:
      Blue Ocean 1.2-beta1

      Description

      After upgrade to new version of Blue Ocean, pressing the link "Open Blue Ocean" in pipeline job does not have the desired effect. The Blue Ocean does not open, instead the browser tries to endless again and again load the page, without displaying anything. 

      Update: this issue correlates with the Chrome browser. Blue Ocean still works with Firefox.

        Attachments

          Issue Links

            Activity

            inkychris Chris Wright added a comment - - edited

            I'm also experiencing this problem in Chrome (58.0.3029.110 (64-bit) Windows 7). I have found that clearing the cache (Clear browsing data: Cached images and files) temporarily solves the issue. The chrome console returns the following error each time it tries to refresh:

            Navigated to http://localhost:8080/blue/organizations/jenkins/test/branches/
            blueocean.js:18561 Browser configuration of @jenkins-cd/logging is explained at https://tfennelly.github.io/jenkins-js-logging/index.html#browser-config
            blueocean.js:2424 Uncaught (in promise) Error: refreshing apge
             at checkRefreshHeader (blueocean.js:2424)
             at <anonymous>
            checkRefreshHeader @ blueocean.js:2424
            inodekker Ino Dekker added a comment -

            We're having the same issue. Blue Ocean dashboard only loads in Chrome incognito or Firefox privacy windows, but not in normal windows. Clearing browser data does not help. Tested on both Windows & Linux versions of the browsers.

            algorys Estrada Matthieu added a comment - - edited

            Same for me. Clear the cache does NOT help on Chrome (Ubuntu 16.04).

            jamesdumay James Dumay added a comment -

            Chris Wright Ino Dekker Estrada Matthieu I am going to escalate this immediately to our engineering team. What would be a great help is if you could Capture a HAR file of the failed page load and upload it securely using this link. The HAR file should give us the appropriate diagnostic information.

            cliffmeyers Cliff Meyers added a comment -

            Hello Ino Dekker and Estrada Matthieu - could you please provide the version of Chrome of being used? Thank you.

            cliffmeyers Cliff Meyers added a comment -

            I'm not able to reproduce this locally, although I certainly don't dispute the problem is happening. If someone could provide a HAR file as James indicated above, it would be really helpful. I need to see if the values of the "X-Blueocean-Refresher" header are not as expected and triggering a refresh loop; we use this header to let the UI decide to refresh itself in the event a browser tab is left open for a long period of time. It's a hint to the UI that something on the server has changed and the UI's code may be out of date.

            There are some other tweaks we could make to defend against this, but I'd like to have some more info before making changes that may not be helpful. Thanks! cc Michael Hüttermann Chris Wright Ino Dekker Estrada Matthieu

            mpapo Michael Pailloncy added a comment -

            I'm able to reproduce with version 58.0.3029.110 (64-bit) of Chrome. It works correctly with Chrome in Incognito mode and clearing cache has no effect.

            Here is a Dockerfile with exact versions of all installed plugins : 

            FROM jenkinsci/jenkins:2.65-alpine
            
            RUN /usr/local/bin/install-plugins.sh \ 
            workflow-aggregator:2.5	\
            pipeline-stage-view:2.8	\
            workflow-multibranch:2.15	\
            pipeline-utility-steps:1.3.0	\
            pipeline-model-definition:1.1.6	\
            blueocean:1.1.0	\
            github-branch-source:2.0.6	\
            cloudbees-bitbucket-branch-source:2.1.2	\
            digitalocean-plugin:0.12	\
            ssh-agent:1.15	\
            buildtriggerbadge:2.8.1 \
            pipeline-maven:2.4.0 \
            greenballs:1.15
            
            ENV JAVA_OPTS "-Djenkins.install.runSetupWizard=false"
            
            

             

            mpapo Michael Pailloncy added a comment -

            Here is a HAR file :  JENKINS-44881.har

            jamesdumay James Dumay added a comment -

            Michael are you using our official docker image?

            mpapo Michael Pailloncy added a comment -

            Not the official BO image.

            I'm using https://hub.docker.com/r/jenkinsci/jenkins/ since I'm currently working on a demo of Jenkins Pipeline + BO for a conference and I want to use latest weekly version => some days ago I had some trouble with install-plugins.sh using the official LTS image and fixed plugins version, but it's working correctly with latest weekly (I need to dig into this problem).

            cliffmeyers Cliff Meyers added a comment -

            James Dumay the value of the "X-Blueocean-Refresher" header returned for the localization bundle for blueocean-personalization is different than the value for blueocean-web and blueocean-dashboard. The latter two do match each other. This seems consistent across the different page sessions.

            The other thing that jumps out is for example in the second page session. /blue is loaded at "19:32:23 GMT" and most of the other requests are at approximately the same time. The blueocean-personalization has a "Date" response header value of "Wed, 14 Jun 2017 11:15:22 GMT" and this is the response with the incorrect refresher header value.

            cliffmeyers Cliff Meyers added a comment -

            Michael Pailloncy thank you for the HAR file. Could you explain the setup where Jenkins is deployed? Do you have a proxy in front of the Jenkins server? Jenkins appears to be running in Jetty based on the response headers I see.

            cliffmeyers Cliff Meyers added a comment -

            The lack of cookies being sent for almost requests is a little strange too. The exception seems to be the see-gateway connection, which is sending about ~10 JSESSIONID's

            imeredith Ivan Meredith added a comment - - edited

            The refrsher header is set directly from the session hash. If refresher token is changing it means the session is changing. Can people that are havng issue please try and load up https://ci.jenkins.io/blue/pipelines and see if the same thing happens?

             

            When I look at my requests I'm seeing JSESSIONID cookies on every request, but on the uploaded HAR it is not loading.

            mpapo Michael Pailloncy added a comment -

            Cliff Meyers my Jenkins is deployed on a container built with the Dockerfile given above (from https://hub.docker.com/r/jenkinsci/jenkins/ with some plugins pre-installed, including BO 1.1.0) on a DigitalOcean droplet. No proxy, I have configured a DNS record targeting the droplet IP address (but the problem also occurs if I access Jenkins directly with the IP address).
            I can easily create a dedicated (and disposable) instance to let you reproduce the problem by giving you credentials associated if you want.

            Ivan Meredith BO is loading correctly on https://ci.jenkins.io/blue/pipelines for me.

            cliffmeyers Cliff Meyers added a comment -

            Michael Pailloncy sure that would be great. You can reach me privately at cmeyers@cloudbees.com.

            jamesdumay James Dumay added a comment -

            Michael Pailloncy would you mind trying to reproduce by changing the base docker image from FROM jenkinsci/jenkins:2.65-alpine to FROM jenkinsci/jenkins:lts-alpine ?

            Cliff Meyers Ivan Meredith and I are on a call right now trying to debug exactly what is going on here. What is odd is that it looks, from your har file, that the value we use to refresh your browser when Blue Ocean is upgraded is changing. This value should never change unless you restart Jenkins.

            What is common between all the reported cases so far is that everyone is using 2.65. This is a weekly build of Jenkins and these do tend to have strange problems.

            jamesdumay James Dumay added a comment -

            Michael Pailloncy you should change your dockerfile to be this:

            FROM jenkinsci/jenkins:lts-alpine
            
            RUN /usr/local/bin/install-plugins.sh \
            workflow-job:2.11 \ 
            workflow-aggregator:2.5	\
            pipeline-stage-view:2.8	\
            workflow-multibranch:2.15	\
            pipeline-utility-steps:1.3.0	\
            pipeline-model-definition:1.1.6	\
            blueocean:1.1.0	\
            github-branch-source:2.0.6	\
            cloudbees-bitbucket-branch-source:2.1.2	\
            digitalocean-plugin:0.12	\
            ssh-agent:1.15	\
            buildtriggerbadge:2.8.1 \
            pipeline-maven:2.4.0 \
            greenballs:1.15
            
            ENV JAVA_OPTS "-Djenkins.install.runSetupWizard=false"
            

            Key changes are:

            • force workflow-job to version 2.11
            • change baseline docker image to the latest alpine based LTS (more stable)
            mpapo Michael Pailloncy added a comment -

            Thanks James Dumay, forcing workflow-job to 2.11 seems to solve the problem I had some days ago. 

            And by targeting LTS instead of 2.65, I confirm that I'm not able to reproduce the current issue.

            imeredith Ivan Meredith added a comment -
            jamesdumay James Dumay added a comment - - edited

            Michael Pailloncy that is good news (its Jenkins not Blue Ocean) but bad news, because Jenkins weekly has a bug

            Ivan Meredith please follow up with a mailing list post referring to this ticket and summarise the findings on the description of this ticket?

            robsonpeixoto Robson Peixoto added a comment -

            James Dumay a downgrade solve the problem? I'm using the LTS version.

            imeredith Ivan Meredith added a comment -

            Robson Peixoto Do you mean you are having issue on LTS? If so what version.

            jamesdumay James Dumay added a comment -

            Robson Peixoto are you using the official blueocean image? That was a known issue where we know it is not working (see JENKINS-44752 - we just resolved it moments ago) and you will need to pull a new version of the docker image.

            jg_lgc Justin Georgeson added a comment -

            I am seeing this same issue on LTS 2.46.2 after installing the BlueOcean 1.1.0 updates.

            jg_lgc Justin Georgeson added a comment -

            but only on one of two servers, both running 2.46.2 release.

            imeredith Ivan Meredith added a comment -

            Justin Georgeson Can you please try manually installing blueocean-rest-impl.hpito see if that fixes things on the server that is not working.

            jg_lgc Justin Georgeson added a comment -

            I just upgraded a few more plugins on the good server to match the bad server and now they're both having the problem. Here are the plugins I updated

            $ diff np2.txt np2-2.txt 
            74c74
            < pipeline-maven Pipeline Maven Integration Plugin 2.4.0-beta-2 (2.4.0)
            ---
            > pipeline-maven Pipeline Maven Integration Plugin 2.4.0
            92c92
            < ssh-agent SSH Agent Plugin 1.14 (1.15)
            ---
            > ssh-agent SSH Agent Plugin 1.15
            98c98
            < token-macro Token Macro Plugin 2.0 (2.1)
            ---
            > token-macro Token Macro Plugin 2.1
            

            However, downgrading them back did not resolve the issue.

            jg_lgc Justin Georgeson added a comment -

            I'm installing the test hpi now.

            jg_lgc Justin Georgeson added a comment -

            I installed by URL via the command-line, and on restart the Open Blue Ocean link in the sidebar is gone. Going to Manage Jenkins > Manage Plugins shows these plugin dependency errors

            There are dependency errors loading some plugins:
            GitHub Pipeline for Blue Ocean v1.1.0
            Pipeline implementation for Blue Ocean v1.1.0 failed to load. Fix this plugin first.
            REST Implementation for Blue Ocean v1.1.1-SNAPSHOT (private-6843fb05-ivan)
            JWT for Blue Ocean v1.1.0 is older than required. To fix, install v1.1.1-SNAPSHOT or later.
            REST API for Blue Ocean v1.1.0 is older than required. To fix, install v1.1.1-SNAPSHOT or later.
            Web for Blue Ocean v1.1.0 is older than required. To fix, install v1.1.1-SNAPSHOT or later.
            Events API for Blue Ocean v1.1.0
            Pipeline implementation for Blue Ocean v1.1.0 failed to load. Fix this plugin first.
            Blue Ocean Pipeline Editor v0.2.0
            Pipeline implementation for Blue Ocean v1.1.0 failed to load. Fix this plugin first.
            Blue Ocean v1.1.0
            Pipeline implementation for Blue Ocean v1.1.0 failed to load. Fix this plugin first.
            Pipeline implementation for Blue Ocean v1.1.0
            REST Implementation for Blue Ocean v1.1.1-SNAPSHOT (private-6843fb05-ivan) failed to load. Fix this plugin first.

             

            There's a Correct button at right, shall I click that?

            imeredith Ivan Meredith added a comment -

            No it seems i have made a mistake, am fixing

            imeredith Ivan Meredith added a comment -

            Ok i rebased my changes onto the release tag. blueocean-rest-impl.hpi

            jg_lgc Justin Georgeson added a comment -

            same state with the new plugin. I tried installing via URL with CLI, and by manually downloading the file to upload it via the UI.

            imeredith Ivan Meredith added a comment -

            Great news, im getting this locally (on 2.32.2) now so should be able to make more progress

            jamesdumay James Dumay added a comment -

            Fantastic news Ivan!

            imeredith Ivan Meredith added a comment -

            Figured out what is going on, am currently working on a fix

            robsonpeixoto Robson Peixoto added a comment -

            Ivan Meredith I'm using 2.46.3
            James Dumay I'm using the jenkins official image

            more info here: https://gist.github.com/robsonpeixoto/7502666d3b5de654a0bed66529c448a2

            imeredith Ivan Meredith added a comment -

            blueocean-web.hpishould fix the issue. Please give it a try. We will work to get (what i assume will be) 1.1.1 out as fast as possible.

            jg_lgc Justin Georgeson added a comment -

            I'm still seeing the same plugin dependency errors, should I unstinall and reinstall it.

            imeredith Ivan Meredith added a comment -

            Revert plugins back to stock, then repleace blueocean-web and it should work. As long as you are on 1.1.0

            inodekker Ino Dekker added a comment -

            James Dumay, not sure if you still need me to create a HAR file, but I tested with blueocean-web.hpiprovided by Ivan Meredith and that seems to solve the issues.

            Thanks for picking this up so quickly.

            jg_lgc Justin Georgeson added a comment -

            Well, I've completely uninstalled all the plugins that match the filter "blue" and restarted Jenkins twice, then installed the blueocean-web.hpi, restarted, then installed all the rest of the plugins that match the filter "blue" and I still have the plugin dependency errors rooted at having installed the blueocean-rest.hpi. Is there a way to manually scrub the server config of any knowledge of that plugin version?

            jamesdumay James Dumay added a comment -

            We've just released Blue Ocean 1.1.1 which resolves the fluttering issue described here.

            It will take a further 2-3 hours to be available on all update center mirrors.

            Thank you everyone who helped us diagnose this problem

            jg_lgc Justin Georgeson added a comment -

            Installing the 1.1.1 plugins has resolved both the original issue and the plugin dependency errors I had from installing the blueocean-rest.hpi.

            jamesdumay James Dumay added a comment -

            Justin Georgeson thats great to hear!

            Sorry for all the trouble everyone.

            huettermann Michael Hüttermann added a comment -

            Hi team,
            with v1.1.1 it works again like a charm. Thanks for the great work and the awesome cycle time.


              People

              Assignee:
              imeredith Ivan Meredith
              Reporter:
              huettermann Michael Hüttermann
              Votes:
              6 Vote for this issue
              Watchers:
              16 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: