Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-45511

Blue Ocean Favorite bug

    XMLWordPrintable

    Details

    • Similar Issues:
    • Epic Link:
    • Sprint:
      Blue Ocean 1.2-beta3, Blue Ocean 1.2-beta4, Blue Ocean 1.2, Blue Ocean 1.3, Blue Ocean 1.4 - beta 1, Blue Ocean 1.4 - beta 2, Blue Ocean 1.6 - beta 2, Blue Ocean - 1.6 - beta 4

      Description

      Scope

      • Write a test that reproduces this scenario

      Out of scope

      • Test with active directory plugin

      Original Probem
      Hi, when I as Administrator User add some favorite job I see it on top of blueocean page.

      If another user want add favorites too nothing happens. Only Star is now yellow.

      This is without any error.

      For Authenitification I use Active Directory plugin.

      Active Directory plugin v. 2.6

      Blue Ocean 1.1.4

       

        Attachments

          Activity

          Hide
          jamesdumay James Dumay added a comment -

          Roman Malík can you please clarify - are you favoriting pipelines as Admin and expecting these to be shown for all users? If so, favourites doesn't work like that.

          Show
          jamesdumay James Dumay added a comment - Roman Malík can you please clarify - are you favoriting pipelines as Admin and expecting these to be shown for all users? If so, favourites doesn't work like that.
          Hide
          hustoles Roman Malík added a comment -

          James Dumay

          No, I dont expect that. I expeting that users set their own favorite jobs. But If user wants to do that, it happens what I wrote. No favorites on top only golden stars.

          Show
          hustoles Roman Malík added a comment - James Dumay No, I dont expect that. I expeting that users set their own favorite jobs. But If user wants to do that, it happens what I wrote. No favorites on top only golden stars.
          Hide
          jamesdumay James Dumay added a comment -

          Roman Malík ahh I understand now. To help debug, could you please capture a HAR file of the page load for the user where the favourites are not displaying and upload the HAR file to this secure location?

          Show
          jamesdumay James Dumay added a comment - Roman Malík ahh I understand now. To help debug, could you please capture a HAR file of the page load for the user where the favourites are not displaying and upload the HAR file to this secure location ?
          Hide
          jamesdumay James Dumay added a comment -

          Assigning to myself for investigation

          Show
          jamesdumay James Dumay added a comment - Assigning to myself for investigation
          Hide
          hustoles Roman Malík added a comment -

          James Dumay OK, I just send you HAR file and screen capture.

          Show
          hustoles Roman Malík added a comment - James Dumay OK, I just send you HAR file and screen capture.
          Hide
          jamesdumay James Dumay added a comment -

          Thanks Roman I'll take a look tomorrow.

          Show
          jamesdumay James Dumay added a comment - Thanks Roman I'll take a look tomorrow.
          Hide
          jamesdumay James Dumay added a comment - - edited

          Hi Roman Malík,

          Thanks for sending those through. Do you have a reverse HTTP proxy setup? By the looks of those errors we can't show the favourite cards because the calls to load the state of the last run seem to be 404ing.

          If your reverse proxy is not setup correctly and the pipeline has special characters or spaces, we might not be able to reach the data correctly. The good news is that its easily fixed - just follow the links under the heading "Running behind a proxy? Read this" on this page.

          To help me diagnose, could you please install the Support Core plugin and generate a support bundle? That should help me rule out any other issues

          Thanks,
          James

          Show
          jamesdumay James Dumay added a comment - - edited Hi Roman Malík , Thanks for sending those through. Do you have a reverse HTTP proxy setup? By the looks of those errors we can't show the favourite cards because the calls to load the state of the last run seem to be 404ing. If your reverse proxy is not setup correctly and the pipeline has special characters or spaces, we might not be able to reach the data correctly. The good news is that its easily fixed - just follow the links under the heading "Running behind a proxy? Read this" on this page . To help me diagnose, could you please install the Support Core plugin and generate a support bundle? That should help me rule out any other issues Thanks, James
          Hide
          hustoles Roman Malík added a comment -

          Hi James Dumay 

          What if everything works on my/admin account? And on other not? I think this isnt caused by reverse proxy right?

          Show
          hustoles Roman Malík added a comment - Hi James Dumay   What if everything works on my/admin account? And on other not? I think this isnt caused by reverse proxy right?
          Hide
          jamesdumay James Dumay added a comment -

          Roman Malík if you can see the same favourites as cards in the admin account, then its another problem. Are you able to provide me the support bundle?

          Show
          jamesdumay James Dumay added a comment - Roman Malík if you can see the same favourites as cards in the admin account, then its another problem. Are you able to provide me the support bundle?
          Hide
          hustoles Roman Malík added a comment -

          James Dumay you think send you HAR from my account where it works?

          Show
          hustoles Roman Malík added a comment - James Dumay you think send you HAR from my account where it works?
          Hide
          jamesdumay James Dumay added a comment - - edited

          Roman Malík the strange thing is that the HAR file didn't have any errors in it. Did you capture the HAR file from the session where it did not work?

          BTW the support bundle is a different thing to the HAR in case you are confused.

          Show
          jamesdumay James Dumay added a comment - - edited Roman Malík the strange thing is that the HAR file didn't have any errors in it. Did you capture the HAR file from the session where it did not work? BTW the support bundle is a different thing to the HAR in case you are confused.
          Hide
          hustoles Roman Malík added a comment -

          James Dumay Yes, I did it from session where it not work. Do you have some good link how to do support bundle?

          Show
          hustoles Roman Malík added a comment - James Dumay Yes, I did it from session where it not work. Do you have some good link how to do support bundle?
          Hide
          jamesdumay James Dumay added a comment -

          Roman Malík sorry for the late reply as I have been on vacation. You can generate the support bundle using this plugin

          Show
          jamesdumay James Dumay added a comment - Roman Malík sorry for the late reply as I have been on vacation. You can generate the support bundle using this plugin
          Hide
          kshultz Karl Shultz added a comment -

          Testing Notes:

          • Visual Verification that a non-administrator user's favorites are sorted to the top of the page, as they are for administrator users
          • FavoritesTest.java could be enhanced to provide this same visual verification
          Show
          kshultz Karl Shultz added a comment - Testing Notes : Visual Verification that a non-administrator user's favorites are sorted to the top of the page, as they are for administrator users FavoritesTest.java could be enhanced to provide this same visual verification
          Hide
          imeredith Ivan Meredith added a comment -

          Does favoriting in classic ui work properly? We are basically just using the favorites plugin to do favorites in blueocean so im a bit confused as to how this is happening. Unless Active Directory plugin does something funky with users.

          Show
          imeredith Ivan Meredith added a comment - Does favoriting in classic ui work properly? We are basically just using the favorites plugin to do favorites in blueocean so im a bit confused as to how this is happening. Unless Active Directory plugin does something funky with users.

            People

            Assignee:
            olamy Olivier Lamy
            Reporter:
            hustoles Roman Malík
            Votes:
            1 Vote for this issue
            Watchers:
            5 Start watching this issue

              Dates

              Created:
              Updated: