Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-45598

Git SCM Source's credentials field is not supposed to be transient

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Critical
    • Resolution: Fixed
    • git-plugin
    • None
    • SCM API Plugin (2.2.0 and 2.2.0-beta1)
      Git plugin (3.4.0 and 3.4.0-beta2)
      Pipeline: Shared Groovy Libraries (2.8)

    Description

      After update our servers to the recent Bitbucket Branch Source Plugin beta and now to the latest release version we have an issue on the "Pipeline: Shared Groovy Libraries" plugin.

      We had define some pipeline library (one repo with 3 version/branches) in the Configure Jenkins page. All of them are configured to use Modern SCM of kind git and use an SSH credentials.

      Every restart of jenkins instance (for example after update plugins) the pipeline library plugin forgots the SSH credentials field and this cause authentication failure of "git fetch" command in all multibranch jobs.

      The problem raised with the beta version of the plugin (now the same in released version).

      Attachments

        Issue Links

          Activity

            nfalco Nikolas Falco created issue -
            nfalco Nikolas Falco made changes -
            Field Original Value New Value
            Attachment settings.jpg [ 38922 ]
            Attachment settings-error.jpg [ 38923 ]
            stephenconnolly Stephen Connolly made changes -
            Component/s workflow-cps-global-lib-plugin [ 21714 ]
            Component/s git-plugin [ 15543 ]
            Component/s scm-api-plugin [ 18054 ]
            stephenconnolly Stephen Connolly made changes -
            Assignee Stephen Connolly [ stephenconnolly ]

            I suspect this is a duplicate / side-effect of JENKINS-45466

            stephenconnolly Stephen Connolly added a comment - I suspect this is a duplicate / side-effect of  JENKINS-45466
            stephenconnolly Stephen Connolly made changes -
            Link This issue is duplicated by JENKINS-45600 [ JENKINS-45600 ]
            stephenconnolly Stephen Connolly added a comment - - edited

            Could you confirm if the attached -SNAPSHOT build of workflow-cps-global-lib plugin resolves the issue for you?

            Nevermind, found the root cause, the credentialsId field in the git plugin was mistakenly marked transient.

            Git plugin version 3.4.1 being released ATM

            stephenconnolly Stephen Connolly added a comment - - edited Could you confirm if the attached -SNAPSHOT  build of workflow-cps-global-lib plugin resolves the issue for you? Nevermind, found the root cause, the credentialsId field in the git plugin was mistakenly marked transient. Git plugin version 3.4.1 being released ATM
            stephenconnolly Stephen Connolly made changes -
            Attachment workflow-cps-global-lib.hpi [ 38925 ]
            stephenconnolly Stephen Connolly made changes -
            Component/s git-plugin [ 15543 ]
            Component/s workflow-cps-global-lib-plugin [ 21714 ]
            stephenconnolly Stephen Connolly made changes -
            Assignee Stephen Connolly [ stephenconnolly ]
            stephenconnolly Stephen Connolly made changes -
            Summary Shared Pipeline Library does not persist the SSH credentials information Git SCM Source's credentials field is not supposed to be transient
            stephenconnolly Stephen Connolly added a comment - https://github.com/jenkinsci/git-plugin/commit/4d4635df05b59ea601f651eb72e6966a2c0e14a4
            nfalco Nikolas Falco made changes -
            Description After update our servers to the recent Bitbucket Branch Source Plugin beta and now to the latest release version we have an issue on the "Pipeline: Shared Groovy Libraries" plugin.

            We had define some pipeline library (one repo with 3 version/branches) in the Configure Jenkins page. All of them are configured to use Modern SCM of kind git and use an SSH credentials.

            Every restart of jenkins instance (for example after update plugins) the pipeline library plugin forgots the SSH credentials field and this cause authentication failure of "git fetch" command in all multibranch jobs.

            The problem raised with the beta version of the plugin (now the same in released version).
            After update our servers to the recent Bitbucket Branch Source Plugin beta and now to the latest release version we have an issue on the "Pipeline: Shared Groovy Libraries" plugin.

            We had define some pipeline library (one repo with 3 version/branches) in the Configure Jenkins page. All of them are configured to use Modern SCM of kind git and use an SSH credentials.

            Every restart of jenkins instance (for example after update plugins) the pipeline library plugin forgots the SSH credentials field and this cause authentication failure of "git fetch" command in all multibranch jobs.

            The problem raised with the beta version of the plugin (now the same in released version).
            The
            casz Joseph Petersen (old) added a comment - - edited

            Woops  good catch

            Was made transient in PR 494

            casz Joseph Petersen (old) added a comment - - edited Woops  good catch Was made transient in PR 494
            nfalco Nikolas Falco made changes -
            Description After update our servers to the recent Bitbucket Branch Source Plugin beta and now to the latest release version we have an issue on the "Pipeline: Shared Groovy Libraries" plugin.

            We had define some pipeline library (one repo with 3 version/branches) in the Configure Jenkins page. All of them are configured to use Modern SCM of kind git and use an SSH credentials.

            Every restart of jenkins instance (for example after update plugins) the pipeline library plugin forgots the SSH credentials field and this cause authentication failure of "git fetch" command in all multibranch jobs.

            The problem raised with the beta version of the plugin (now the same in released version).
            The
            After update our servers to the recent Bitbucket Branch Source Plugin beta and now to the latest release version we have an issue on the "Pipeline: Shared Groovy Libraries" plugin.

            We had define some pipeline library (one repo with 3 version/branches) in the Configure Jenkins page. All of them are configured to use Modern SCM of kind git and use an SSH credentials.

            Every restart of jenkins instance (for example after update plugins) the pipeline library plugin forgots the SSH credentials field and this cause authentication failure of "git fetch" command in all multibranch jobs.

            The problem raised with the beta version of the plugin (now the same in released version).
            nfalco Nikolas Falco added a comment -

            I do not open this bug to workflow-cps-global-lib-plugin component because the jelly demands scm to the <f:descriptorRadioList> and because with previous version of git and scm-api I got the same UI issue but persistence works.

            Anyway I'm happy this is fixed _

            nfalco Nikolas Falco added a comment - I do not open this bug to workflow-cps-global-lib-plugin component because the jelly demands scm to the <f:descriptorRadioList> and because with previous version of git and scm-api I got the same UI issue but persistence works. Anyway I'm happy this is fixed _
            stephenconnolly Stephen Connolly made changes -
            Remote Link This issue links to "Page (Jenkins Wiki)" [ 17291 ]
            stephenconnolly Stephen Connolly made changes -
            Resolution Fixed [ 1 ]
            Status Open [ 1 ] Resolved [ 5 ]
            stephenconnolly Stephen Connolly made changes -
            Status Resolved [ 5 ] Closed [ 6 ]

            People

              stephenconnolly Stephen Connolly
              nfalco Nikolas Falco
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: