Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-45719

Description for a pipeline run is not compatible and cannot be disabled

    XMLWordPrintable

Details

    • Blue Ocean 1.4 - beta 1

    Description

      jamesdumay added recently description display to blue ocean in JENKINS-41769. Unfortunately it is not rendering build description property in consistent manner. The build property is multi-line and supports HTML content, while its blue ocean presentation expects single-line and plain text.

      I was already using this property, filling it with html tables, links and images, and now at blue ocean it presents itself as HTML source.

      Possible solutions:

      • allow to disable display of description in blue ocean
      • make the blue ocean description rendered in same manner as it is in other parts of Jenkins
      • make the blue ocean description relay on other property, i.e. Summary, Brief, Note

       

      Attachments

        Issue Links

          Activity

            quas Jakub Pawlinski created issue -
            quas Jakub Pawlinski made changes -
            Field Original Value New Value
            Epic Link JENKINS-43952 [ 181484 ]
            quas Jakub Pawlinski made changes -
            Description [~jamesdumay] added recently description display to blue ocean in <JENKINS-41769|https://issues.jenkins-ci.org/browse/JENKINS-41769>. Unfortunately it is not compatible with build description property it is using. The build property is multi-line and supports HTML content, while its blue ocean presentation expects single-line and plain text.

            I'm already using this property, filling it with html tables, links and images, now at blue ocean it presents itself as HTML source.

            Possible solutions:
             * allow to disable display of description in blue ocean
             * make the blue ocean description rendered in same manner as it is in other parts of jenkins
             * make the blue ocean description relay on other property, i.e. Summary, Brief, Note

             
            [~jamesdumay] added recently description display to blue ocean in -JENKINS-41769-.Unfortunately it is not rendering build description property in consistent manner. The build property is multi-line and supports HTML content, while its blue ocean presentation expects single-line and plain text.

            I was already using this property, filling it with html tables, links and images, and now at blue ocean it presents itself as HTML source.

            Possible solutions:
             * allow to disable display of description in blue ocean
             * make the blue ocean description rendered in same manner as it is in other parts of Jenkins
             * make the blue ocean description relay on other property, i.e. Summary, Brief, Note

             
            jamesdumay James Dumay made changes -
            Description [~jamesdumay] added recently description display to blue ocean in -JENKINS-41769-.Unfortunately it is not rendering build description property in consistent manner. The build property is multi-line and supports HTML content, while its blue ocean presentation expects single-line and plain text.

            I was already using this property, filling it with html tables, links and images, and now at blue ocean it presents itself as HTML source.

            Possible solutions:
             * allow to disable display of description in blue ocean
             * make the blue ocean description rendered in same manner as it is in other parts of Jenkins
             * make the blue ocean description relay on other property, i.e. Summary, Brief, Note

             
            [~jamesdumay] added recently description display to blue ocean in JENKINS-41769. Unfortunately it is not rendering build description property in consistent manner. The build property is multi-line and supports HTML content, while its blue ocean presentation expects single-line and plain text.

            I was already using this property, filling it with html tables, links and images, and now at blue ocean it presents itself as HTML source.

            Possible solutions:
             * allow to disable display of description in blue ocean
             * make the blue ocean description rendered in same manner as it is in other parts of Jenkins
             * make the blue ocean description relay on other property, i.e. Summary, Brief, Note

             
            jamesdumay James Dumay made changes -
            Link This issue relates to JENKINS-41769 [ JENKINS-41769 ]
            bkorren Barak Korren added a comment -

            HTML in the build description is pretty commonly used. The GitHub PR Builder plugin uses it for linking back to PRs for example. We've used it in our system for many other things like linking to Gerrit patches, or to JIRA tickets tracking analysis of job failures.

            bkorren Barak Korren added a comment - HTML in the build description is pretty commonly used. The GitHub PR Builder plugin uses it for linking back to PRs for example. We've used it in our system for many other things like linking to Gerrit patches, or to JIRA tickets tracking analysis of job failures.
            michaelneale Michael Neale added a comment -

            quas bkorren very interesting. 

             

            So - I think links and the link should be reasonable in markup - but as for other elements - that won't really work without a very odd looking sandbox (or iframe), I would like to see a screen cap of a display description with tables and images though - if you have one handy you can share? 

             

             

            michaelneale Michael Neale added a comment - quas bkorren  very interesting.    So - I think links and the link should be reasonable in markup - but as for other elements - that won't really work without a very odd looking sandbox (or iframe), I would like to see a screen cap of a display description with tables and images though - if you have one handy you can share?     
            quas Jakub Pawlinski made changes -
            Attachment 2017_09_13_12_02_34_CAF_TestJob_Jenkins_.png [ 39681 ]
            quas Jakub Pawlinski made changes -
            Attachment 2017_09_13_15_03_04_CAF_CPP01_Jenkins_.jpg [ 39688 ]
            quas Jakub Pawlinski made changes -
            Attachment 2017_09_13_12_02_34_CAF_TestJob_Jenkins_.png [ 39681 ]
            quas Jakub Pawlinski made changes -
            Attachment 2017_09_13_15_03_04_CAF_CPP01_Jenkins_.jpg [ 39688 ]
            quas Jakub Pawlinski made changes -
            Attachment 2017_09_13_15_03_04.jpg [ 39689 ]

            attached example where you can see description property used in two different ways:

            • with images (icons) and links in build history
            • with table, links in pipeline description

            in some cases we have attached graphs from build and test performance and as well 

            quas Jakub Pawlinski added a comment - attached example where you can see description property used in two different ways: with images (icons) and links in build history with table, links in pipeline description in some cases we have attached graphs from build and test performance and as well 
            bkorren Barak Korren made changes -
            bkorren Barak Korren added a comment -

            My stuff is publicly accessible so I don't need to censor screenshots

             

            Attached screenshot with descriptions created by the GHPRB plugin, with links to PRs.

            Also note the use of the "title" attribute in the link HTML tags, to provide more information on mouse hover.

            bkorren Barak Korren added a comment - My stuff is publicly accessible so I don't need to censor screenshots   Attached screenshot with descriptions created by the GHPRB plugin, with links to PRs. Also note the use of the " title " attribute in the link HTML tags, to provide more information on mouse hover.

            in my case its easier to censor than to explain why I didn't

            quas Jakub Pawlinski added a comment - in my case its easier to censor than to explain why I didn't
            nimrod Kasia Gauza made changes -
            Attachment desription link icons.png [ 39809 ]
            nimrod Kasia Gauza added a comment -

            In one of our projects I use link icons in description for a quick access to metrics and artifacts. It is of course not rendered in Blue Ocean. 

            nimrod Kasia Gauza added a comment - In one of our projects I use link icons in description for a quick access to metrics and artifacts. It is of course not rendered in Blue Ocean. 
            jamesdumay James Dumay made changes -
            Status Open [ 1 ] In Progress [ 3 ]
            jamesdumay James Dumay made changes -
            Status In Progress [ 3 ] In Review [ 10005 ]
            jamesdumay James Dumay made changes -
            Assignee James Dumay [ jamesdumay ]
            jamesdumay James Dumay made changes -
            Sprint Blue Ocean 1.4 - beta 1 [ 401 ]
            jamesdumay James Dumay added a comment -

            In Blue Ocean 1.4, passing the following system property at startup will allow you to disable descriptions:

            -Dblueocean.feature.run.description.enabled=false
            
            jamesdumay James Dumay added a comment - In Blue Ocean 1.4, passing the following system property at startup will allow you to disable descriptions: -Dblueocean.feature.run.description.enabled= false
            jamesdumay James Dumay made changes -
            Resolution Fixed [ 1 ]
            Status In Review [ 10005 ] Resolved [ 5 ]
            jamesdumay James Dumay added a comment -

            nimrod is that using the run description?

            jamesdumay James Dumay added a comment - nimrod is that using the run description?
            jamesdumay James Dumay made changes -
            Remote Link This issue links to "CloudBees Internal UX-658 (Web Link)" [ 18183 ]
            jamesdumay James Dumay made changes -
            Remote Link This issue links to "CloudBees Internal UX-658 (Web Link)" [ 18293 ]
            michaelneale Michael Neale made changes -
            Remote Link This issue links to "Page (Jenkins Wiki)" [ 19852 ]
            kjpopovbg Krasimir Popov added a comment - - edited

            I am also experiencing the same issue but I do not want to disable build description. I want to display links there via Markdown or HTML it does not matter.

            But I need a way to have my build description to look nice and to contain links in both UI's. 

            kjpopovbg Krasimir Popov added a comment - - edited I am also experiencing the same issue but I do not want to disable build description. I want to display links there via Markdown or HTML it does not matter. But I need a way to have my build description to look nice and to contain links in both UI's. 

            We need way to display links in build description for both UI's

            kjpopovbg Krasimir Popov added a comment - We need way to display links in build description for both UI's
            kjpopovbg Krasimir Popov made changes -
            Resolution Fixed [ 1 ]
            Status Resolved [ 5 ] Reopened [ 4 ]
            kjpopovbg Krasimir Popov made changes -
            Status Reopened [ 4 ] Open [ 1 ]
            magikid Chris Jones added a comment -

            React (which Blue Ocean uses) strips out HTML elements which is probably where the problem is coming from.  An easy solution (not sure about good) would be to use a JS library like react-render-html to wrap the message prop passed in RunDescription.jsx.  That uses an Alert component to display the description so it might also need to be wrapped there but that could affect a lot more.

            magikid Chris Jones added a comment - React (which Blue Ocean uses) strips out HTML elements which is probably where the problem is coming from.  An easy solution (not sure about good) would be to use a JS library like react-render-html to wrap the message prop passed in RunDescription.jsx .  That uses an Alert  component to display the description so it might also need to be wrapped there but that could affect a lot more.
            stephenyeargin Stephen Yeargin made changes -

            I appear to be running into this issue as well in the Blue Ocean interface when viewing the recent build history. I am assuming these are directly related, and that any fix would address it as well?

             

            stephenyeargin Stephen Yeargin added a comment - I appear to be running into this issue as well in the Blue Ocean interface when viewing the recent build history. I am assuming these are directly related, and that any fix would address it as well?  

            Vote for the issue so it will be developed sooner

            kjpopovbg Krasimir Popov added a comment - Vote for the issue so it will be developed sooner

            magikid Would you be able to submit a patch to the blueocean-plugin to try this?

            rodrigc Craig Rodrigues added a comment - magikid Would you be able to submit a patch to the blueocean-plugin to try this?
            magikid Chris Jones added a comment -

            I'll see what I can put together for it.

            magikid Chris Jones added a comment - I'll see what I can put together for it.

            Hi,

            Is there any plan to get this fixed in a future version of the Blue Ocean plugin(s)?

            Thanks

            damien_coraboeuf Damien Coraboeuf added a comment - Hi, Is there any plan to get this fixed in a future version of the Blue Ocean plugin(s)? Thanks

            Give a vote and hope for magikid to have time to try the patch mentioned above

            kjpopovbg Krasimir Popov added a comment - Give a vote and hope for magikid to have time to try the patch mentioned above
            chantivlad chanti vlad added a comment -

            magikid would you have some update on this issue to share please?

            chantivlad chanti vlad added a comment - magikid would you have some update on this issue to share please?

            +1

            We have HTML auto-populated build descriptions (with tables and etc). It turns to unreadable tons of text, and we have to scroll 10 screens down to execution graph.

            At least we need an option to switch off build description in Blue Ocean.

            novimax Maximilian Novikov added a comment - +1 We have HTML auto-populated build descriptions (with tables and etc). It turns to unreadable tons of text, and we have to scroll 10 screens down to execution graph. At least we need an option to switch off build description in Blue Ocean.

            Adding this to the startup options worked to disable display of descriptions for runs in BlueOcean (haven't tried in recent versions):

            -Dblueocean.feature.run.description.enabled=false

            schniedergers Klaus Schniedergers added a comment - Adding this to the startup options worked to disable display of descriptions for runs in BlueOcean (haven't tried in recent versions): -Dblueocean.feature.run.description.enabled=false
            halkeye Gavin Mogan made changes -
            Assignee James Dumay [ jamesdumay ]
            steffen_wilke Steffen Wilke added a comment -

            magikid are there any updates on this?

            steffen_wilke Steffen Wilke added a comment - magikid are there any updates on this?
            jimtut James Tuttle added a comment -

            +1 for supporting HTML in the description.  We don't have the complex tables that other mentioned, but just a simple link back to the pull-request.  Really miss having this in Blue Ocean, although at least for a link I can copy/paste it go there.

            jimtut James Tuttle added a comment - +1 for supporting HTML in the description.  We don't have the complex tables that other mentioned, but just a simple link back to the pull-request.  Really miss having this in Blue Ocean, although at least for a link I can copy/paste it go there.

            Any update on this? It's also a need for us

            thibautlelevier Thibaut LE LEVIER added a comment - Any update on this? It's also a need for us
            jrjurman Jesse Jurman added a comment -

            For those who are using a browser that supports chrome extensions, I've worked on this: https://chrome.google.com/webstore/detail/blue-ocean-description-ht/maahpenodjcdhodbonmdkfgnceddigae

            This chrome extension will update the description box to use HTML. The source code can be found here: https://github.com/JRJurman/blue-ocean-description-htmlify-chrome-extension

            If you find any issues or would like to propose a change feel free to post a PR or Issue on github. 

            jrjurman Jesse Jurman added a comment - For those who are using a browser that supports chrome extensions, I've worked on this:  https://chrome.google.com/webstore/detail/blue-ocean-description-ht/maahpenodjcdhodbonmdkfgnceddigae This chrome extension will update the description box to use HTML. The source code can be found here:  https://github.com/JRJurman/blue-ocean-description-htmlify-chrome-extension If you find any issues or would like to propose a change feel free to post a PR or Issue on github. 

            Any update on this one ?

            We need to display some data in order to quickly understand who launched a pipeline and what it did and therefore.

            It would be very nice if we could have the same nice display as in the old interface.

            robinc robin courgeon added a comment - Any update on this one ? We need to display some data in order to quickly understand who launched a pipeline and what it did and therefore. It would be very nice if we could have the same nice display as in the old interface.
            jonathand131 Jonathan Delizy made changes -
            Link This issue is duplicated by JENKINS-55599 [ JENKINS-55599 ]

            People

              Unassigned Unassigned
              quas Jakub Pawlinski
              Votes:
              82 Vote for this issue
              Watchers:
              72 Start watching this issue

              Dates

                Created:
                Updated: