Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-46049

Cloud Foundry Plugin is not working after update to version 2.1

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      After upgrade the Cloud Foundry Plugin to version 2.1 i've started to problems to make the app push.

      In the attachments there are the console text and the configuration I'm using.

       

        Attachments

          Issue Links

            Activity

            sergiofm Sergio Mendonça created issue -
            olamy Olivier Lamy added a comment -

            The logs says 

            org.cloudfoundry.client.v2.ClientV2Exception: CF-AppInvalid(100001): The app is invalid: disk_quota too little disk requested (must be greater than zero) 

            sworisbreathing Steven Swor added a comment - - edited

            Sergio Mendonça - is disk_quota specified in manifest-dev.yml?

            sergiofm Sergio Mendonça added a comment -

            Yes, it is defined as 1048M.

            sworisbreathing Steven Swor added a comment -

            Sergio Mendonça - Good spotting. It's a bug with cf-java-client. I've just raised https://github.com/cloudfoundry/cf-java-client/issues/792 and am about to submit a PR to fix it. Will leave this issue open until the fix is released and we update the dependency version for the Jenkins plugin.

            sworisbreathing Steven Swor made changes -
            Field Original Value New Value
            Status Open [ 1 ] In Progress [ 3 ]
            sergiofm Sergio Mendonça added a comment -

            Steven Swor I'm happy to help and is good to know you find out what is causing this bug. I hope this can be fixed soon. 

            sworisbreathing Steven Swor added a comment -

            In the meantime you should be able to get away with just disk_quota: 1024 since cf-java-client assumes MB unless units are specified.

            sworisbreathing Steven Swor made changes -
            Assignee olamy [ olamy ] Steven Swor [ sworisbreathing ]
            sergiofm Sergio Mendonça added a comment -

            Is there any prevision when this issue will be fixed?

            sworisbreathing Steven Swor added a comment -

            Still struggling with this one. The upstream PR was accepted and released, but there appears to be a regression in the new version of cf-java-client that breaks our ability to get the cloudfoundry logs. I'm still looking into it but don't have an ETA - I'm still trying to track down what other changes have been made since v2.15.0.RELEASE.

            sworisbreathing Steven Swor added a comment -

            ok I've raised https://github.com/cloudfoundry/cf-java-client/issues/818 for the logging issue.

            sworisbreathing Steven Swor added a comment -

            Upstream issue has been fixed and I've succesfully tested the plugin against cf-java-client 2.20.0.BULD-SNAPSHOT. Hopefully we can close this once 2.20.0.RELEASE drops.

            sworisbreathing Steven Swor added a comment -

            Fixed in version 2.2.0

            sworisbreathing Steven Swor made changes -
            Resolution Fixed [ 1 ]
            Status In Progress [ 3 ] Resolved [ 5 ]
            sworisbreathing Steven Swor made changes -
            Remote Link This issue links to "Page (Jenkins Wiki)" [ 17837 ]

              People

              Assignee:
              sworisbreathing Steven Swor
              Reporter:
              sergiofm Sergio Mendonça
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: