Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-4707

Can't view annotated source for warnings

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Fixed
    • warnings-plugin
    • None
    • Platform: All, OS: Mac OS X

    Description

      I installed Warnings on my master machine. I enabled it for a project. When I
      try to look at annotated source, I always get an error:

      Content of file CDocWinDispatch.cpp

      null
      01 hudson.util.IOException2: remote file operation failed
      02 at hudson.FilePath.act(FilePath.java:672)
      03 at hudson.FilePath.act(FilePath.java:660)
      04 at hudson.FilePath.copyTo(FilePath.java:1272)
      05 at
      hudson.plugins.warnings.util.HealthAwarePublisher.copyFilesWithAnnotationsToBuil
      dFolder(HealthAwarePublisher.java:187)
      06 at hudson.plugins.warnings.util.HealthAwarePublisher.perform
      (HealthAwarePublisher.java:144)
      07 at hudson.tasks.BuildStepMonitor$3.perform(BuildStepMonitor.java:36)
      08 at hudson.model.AbstractBuild$AbstractRunner.perform
      (AbstractBuild.java:501)
      09 at hudson.model.AbstractBuild$AbstractRunner.performAllBuildStep
      (AbstractBuild.java:487)
      10 at hudson.model.AbstractBuild$AbstractRunner.performAllBuildStep
      (AbstractBuild.java:475)
      11 at hudson.model.Build$RunnerImpl.post2(Build.java:181)
      12 at hudson.model.AbstractBuild$AbstractRunner.post(AbstractBuild.java:459)
      13 at hudson.model.Run.run(Run.java:1143)
      14 at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
      15 at hudson.model.ResourceController.execute(ResourceController.java:88)
      16 at hudson.model.Executor.run(Executor.java:123)
      17 Caused by: java.io.FileNotFoundException: [exec] In file included
      from /Users/rthomson/hudson/jobs/Bryce7/workspace/bryce7/src/Bryce/UI/CDocWinDis
      patch.cpp (No such file or directory)
      18 at java.io.FileInputStream.open(Native Method)
      19 at java.io.FileInputStream.<init>(FileInputStream.java:106)
      20 at hudson.FilePath$30.invoke(FilePath.java:1276)
      21 at hudson.FilePath$30.invoke(FilePath.java:1272)
      22 at hudson.FilePath$FileCallableWrapper.call(FilePath.java:2052)
      23 at hudson.remoting.LocalChannel.call(LocalChannel.java:45)
      24 at hudson.FilePath.act(FilePath.java:667)
      25 ... 14 more
      26 Can't copy file from workspace to build folder: workspace=[exec] In file
      included
      from /Users/rthomson/hudson/jobs/Bryce7/workspace/bryce7/src/Bryce/UI/CDocWinDis
      patch.cpp, build folder=/Users/rthomson/hudson/jobs/Bryce7/builds/2009-10-24_20-
      55-09/workspace-files/57035c4a.tmp

      Hudson version 1.329

      I checked and the source file is present in the workspace, but it seems to be
      talking about some other file that is referenced by inclusion in this file.

      Attachments

        Activity

          legalize Richard created issue -
          legalize Richard added a comment -

          Hudson master and build are running on Mac OS X

          legalize Richard added a comment - Hudson master and build are running on Mac OS X
          drulli Ulli Hafner added a comment -

          Can you please add the actual warning message in the log that is parsed by my
          plug-in? Seems that my regular expression extracts the text
          "[exec] In file included from /Users/rthomson/" as file name which is wrong.

          drulli Ulli Hafner added a comment - Can you please add the actual warning message in the log that is parsed by my plug-in? Seems that my regular expression extracts the text " [exec] In file included from /Users/rthomson/" as file name which is wrong.
          legalize Richard added a comment -

          Created an attachment (id=1007)
          Build log for 3DSExport.cpp

          legalize Richard added a comment - Created an attachment (id=1007) Build log for 3DSExport.cpp
          legalize Richard added a comment -

          I've attached a log excerpt.

          legalize Richard added a comment - I've attached a log excerpt.
          gommo gommo added a comment -

          I also am seeing this error, however, by the look of the path it is using to copy, it is right, and the source code file is present. It just can't find it?

          Can't copy file from workspace to build folder: workspace=[infrastructure] /data/workspace/Automation-Trunk-x86/trunk/sup/lib/infrastructure/src/unitsystem/SignalDescription.cpp, build folder=D:\hudsonhome\jobs\Automation-Trunk-x86\builds\2009-12-09_07-41-53\workspace-files\f54ca0d9.tmp

          The workspace=[infrastructure] is weird, because that is NOT the workspace name? Could this be the issue somehow?

          gommo gommo added a comment - I also am seeing this error, however, by the look of the path it is using to copy, it is right, and the source code file is present. It just can't find it? Can't copy file from workspace to build folder: workspace= [infrastructure] /data/workspace/Automation-Trunk-x86/trunk/sup/lib/infrastructure/src/unitsystem/SignalDescription.cpp, build folder=D:\hudsonhome\jobs\Automation-Trunk-x86\builds\2009-12-09_07-41-53\workspace-files\f54ca0d9.tmp The workspace= [infrastructure] is weird, because that is NOT the workspace name? Could this be the issue somehow?
          drulli Ulli Hafner added a comment -

          That is exactly the same problem. Somehow the [infrastructure] is parsed by the Regexp as a part of the filename.

          @gommo: Can you please also attach your parsed log message? Then I have another example for the test suite...

          drulli Ulli Hafner added a comment - That is exactly the same problem. Somehow the [infrastructure] is parsed by the Regexp as a part of the filename. @ gommo : Can you please also attach your parsed log message? Then I have another example for the test suite...
          drulli Ulli Hafner added a comment -

          Already fixed quite some time ago.

          drulli Ulli Hafner added a comment - Already fixed quite some time ago.
          drulli Ulli Hafner made changes -
          Field Original Value New Value
          Resolution Fixed [ 1 ]
          Status Open [ 1 ] Closed [ 6 ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 134780 ] JNJira + In-Review [ 203059 ]

          People

            drulli Ulli Hafner
            legalize Richard
            Votes:
            1 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: