Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-47467

No Jobs getting executed

    XMLWordPrintable

Details

    Description

      My parameterized scheduler is not starting the jobs:

      This is my configuration line:

      */2 * * * * % BuildBot=ATSE-BBOT3

      The job has a parameter of type choice with the name "BuildBot" and one of the choice values is "ATSE-BBOT3"

       

      How can I get more details from the logs for you?

       

      Attachments

        Activity

          walteste Stefan Walter created issue -
          walteste Stefan Walter made changes -
          Field Original Value New Value
          Rank Ranked higher
          batmat Baptiste Mathus made changes -
          Summary No Jobs getting exeuted No Jobs getting executed

          walteste I tried reproducing and it works for me, and there are also tests that should cover that totally standard use case. The only thing I didn't do was testing on Windows, but I don't why/how this could be the reason.

          So, I would welcome possibly a screencast of the issue to be sure of the workflow you're following. And possibly send also a support bundle (via that plugin: https://wiki.jenkins.io/display/JENKINS/Support+Core+Plugin) so that I know more about your very instance setup. You can either attach it to this ticket if you make sure to not select the checkboxes that can lead to private data attaching (like the config files), or send it privately to me to avoid any risk.

          Thanks!

          batmat Baptiste Mathus added a comment - walteste I tried reproducing and it works for me, and there are also tests that should cover that totally standard use case. The only thing I didn't do was testing on Windows, but I don't why/how this could be the reason. So, I would welcome possibly a screencast of the issue to be sure of the workflow you're following. And possibly send also a support bundle (via that plugin: https://wiki.jenkins.io/display/JENKINS/Support+Core+Plugin ) so that I know more about your very instance setup. You can either attach it to this ticket if you make sure to not select the checkboxes that can lead to private data attaching (like the config files), or send it privately to me to avoid any risk. Thanks!
          walteste Stefan Walter added a comment -

          Thanks, for some unknown reasons it started working for me. Probably because I configured a new job.

          walteste Stefan Walter added a comment - Thanks, for some unknown reasons it started working for me. Probably because I configured a new job.

          Closing as per the last comment, seems resolved finally. Feel free to reopen if I misunderstood. Thanks

          batmat Baptiste Mathus added a comment - Closing as per the last comment, seems resolved finally. Feel free to reopen if I misunderstood. Thanks
          batmat Baptiste Mathus made changes -
          Resolution Not A Defect [ 7 ]
          Status Open [ 1 ] Closed [ 6 ]
          mtdeguzis Michael DeGuzis added a comment - - edited

          We cannot get the jobs to execute or schedule. The normal cron scheduler will show "Job would have last run at X, will run at Y", but this plugin does not. I even setup a new job with very very simple actions. I can't seem to paste images here. They fail to render on save.

          Nothing gets scheduled. Does this conflict with any plugin? Logs to get to you?

          mtdeguzis Michael DeGuzis added a comment - - edited We cannot get the jobs to execute or schedule. The normal cron scheduler will show "Job would have last run at X, will run at Y", but this plugin does not. I even setup a new job with very very simple actions. I can't seem to paste images here. They fail to render on save. Nothing gets scheduled. Does this conflict with any plugin? Logs to get to you?
          mtdeguzis Michael DeGuzis made changes -
          Resolution Not A Defect [ 7 ]
          Status Closed [ 6 ] Reopened [ 4 ]
          mtdeguzis Michael DeGuzis made changes -
          Attachment support_2018-06-06_12.52.56.zip [ 42796 ]
          mtdeguzis Michael DeGuzis made changes -
          Comment [ Added support bundle ]
          mtdeguzis Michael DeGuzis made changes -
          Attachment support_2018-06-06_12.52.56.zip [ 42796 ]

          mtdeguzis please do not reopen without actual bug cause or clear reproduction steps.
          AFAICT, this was for instance not a bug previously, so in that case you want to use the users mailing list, as JIRA here is not a support website.

          If you can create a clear reproducer from scratch, I will welcome your feedback here (or in a new JIRA issue) and will even probably try to fix it.

          Until this step is done, I am going to close this issue again.

          Thank you!

          batmat Baptiste Mathus added a comment - mtdeguzis please do not reopen without actual bug cause or clear reproduction steps. AFAICT, this was for instance not a bug previously, so in that case you want to use the users mailing list, as JIRA here is not a support website. If you can create a clear reproducer from scratch, I will welcome your feedback here (or in a new JIRA issue) and will even probably try to fix it. Until this step is done, I am going to close this issue again. Thank you!
          batmat Baptiste Mathus made changes -
          Resolution Not A Defect [ 7 ]
          Status Reopened [ 4 ] Closed [ 6 ]
          mtdeguzis Michael DeGuzis added a comment - - edited

          Reproduction steps on my side:

          1. new item
          2. project name "test-parameterized-scheduler"
          3. Check "This project is parameterized"
            1. name: some_string
            2. Default Value: some_value
          4. Save job
          5. Configure job again
          6. Check "Build periodically with parameters"
            1. Schedule:
              * * * * * % some_string=blah
          1. Build section
            1. Execute shell
              echo "testing"
          1. Save

          Job never fires off

          Plugin version: 0.5

          If you want this in a new JIRA, let me know.

          mtdeguzis Michael DeGuzis added a comment - - edited Reproduction steps on my side: new item project name "test-parameterized-scheduler" Check "This project is parameterized" name: some_string Default Value: some_value Save job Configure job again Check "Build periodically with parameters" Schedule: * * * * * % some_string=blah Build section Execute shell echo "testing" Save Job never fires off Plugin version: 0.5 If you want this in a new JIRA, let me know.

          People

            batmat Baptiste Mathus
            walteste Stefan Walter
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: