Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-48220

incorrect display of folder contents in list-jobs output

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      Hello!
      For example, my project structure:

      folder_1/folder_1_1/job_1_1
      folder_1/folder_1_2/job_1_2
      folder_1/job_1
      folder_2/folder_2_1/job_2_1
      folder_2/folder_2_2/job_2_2
      folder_2/job_2

       When i run "list-jobs" command with no parameters, the root folder is displayed correctly:

      ssh jcli list-jobs
      folder_1
      folder_2
      

      But when i run "list-jobs" command for a folder, i see:

      ssh jcli list-jobs folder_1
      folder_1_1
      job_1_1
      folder_1_2
      job_1_2
      job_1
      

      instead

      ssh jcli list-jobs folder_1
      folder_1_1
      folder_1_2
      job_1
      

      is it a bug? or am I doing something wrong?
      thank you in advance

        Attachments

          Activity

          theli Vyacheslav Bogachenkov created issue -
          jglick Jesse Glick added a comment -

          Maybe a bug in ListJobsCommand, not sure offhand.

          jglick Jesse Glick made changes -
          Field Original Value New Value
          Component/s core [ 15593 ]
          Component/s cloudbees-folder-plugin [ 18137 ]
          Labels cli folders
          Priority Blocker [ 1 ] Minor [ 4 ]
          oleg_nenashev Oleg Nenashev made changes -
          Labels cli folders cli folders newbie-friendly
          oleg_nenashev Oleg Nenashev made changes -
          Component/s cli [ 15624 ]
          oleg_nenashev Oleg Nenashev added a comment -

          Seems to be a newbie-friendly issue for the core,
          ListJobsCommand is a part of the core codebase

          mfgmateus Mateus Gonçalves made changes -
          Status Open [ 1 ] In Progress [ 3 ]
          mfgmateus Mateus Gonçalves made changes -
          Status In Progress [ 3 ] Open [ 1 ]
          v2v Victor Martinez made changes -
          Assignee Victor Martinez [ v2v ]
          v2v Victor Martinez made changes -
          Status Open [ 1 ] In Progress [ 3 ]
          v2v Victor Martinez added a comment -

          As far as I see this particular behaviour has been there for a while:

          jglick Jesse Glick added a comment -
          theli Vyacheslav Bogachenkov added a comment -

          this behavior still persists in lts

          allanc Allan C added a comment -

          Victor Martinez Hi Victor. I am new to Jenkins Developer Community and I am trying to start with some simple bug fix. I wonder if you are still working on this issue? If not, I am happy to take it over if you can kindly give me some hints about where to look for in the codebase. Many thanks!

          v2v Victor Martinez added a comment -

          Allan C, thanks for asking, actually If I did work on this i already lost track, so please feel free to assign yourself and work on this. Thanks for supporting the project and work on this. 

          v2v Victor Martinez made changes -
          Assignee Victor Martinez [ v2v ]
          allanc Allan C made changes -
          Assignee Allan C [ allanc ]
          allanc Allan C added a comment -

          Victor Martinez Thank you. I wonder if anyone can offer some advice regarding which part of the core I should look into. Are there any documentations that I should be aware of? 

          vishalghyv Vishal added a comment -

          Hey, Allan C  I would like to work on this for next few days Hope it's not a problem, I am assigning myself to it, If I am not able to fix, I will reassign you.

          vishalghyv Vishal made changes -
          Assignee Allan C [ allanc ] Vishal [ JIRAUSER131024 ]
          vishalghyv Vishal added a comment -

          Jobs are listing as expected

          vishalghyv Vishal made changes -
          Resolution Fixed [ 1 ]
          Status In Progress [ 3 ] Resolved [ 5 ]
          jglick Jesse Glick added a comment -

          Cannot be Fixed when there is no linked fix. Did you mean Works for me or similar?

          jglick Jesse Glick made changes -
          Resolution Fixed [ 1 ]
          Status Resolved [ 5 ] Reopened [ 4 ]
          vishalghyv Vishal added a comment - - edited

          Right, It shouldn't be closed,
          But for discussion kindly see Issue

          The issue have committed changes
          It seems that the issue have been fixed there, also yes while testing the exact same configuration it worked for me see Pull request

          jglick Jesse Glick made changes -
          Resolution Cannot Reproduce [ 5 ]
          Status Reopened [ 4 ] Resolved [ 5 ]

            People

            Assignee:
            vishalghyv Vishal
            Reporter:
            theli Vyacheslav Bogachenkov
            Votes:
            0 Vote for this issue
            Watchers:
            7 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: