Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-48386

Incorrect messages "No GitLab connection configured"

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Done
    • Labels:
      None
    • Environment:
      Jenkins version 2.73.3
      Gitlab-plugin version 1.5.2
      Matrix-project plugin version 1.12
    • Similar Issues:

      Description

      I've got a matrix job, that is triggered by the Gitlab plugin through webhooks.

      Job configuration contains configured "Gitlab connection" in General settings and 3 postbuild actions: "Add note with build status on Gitlab Merge requests", "Add vote for build status for Gitlab Merge requests" and "Publish build status to Gitlab commit".

      It also contains a secret token in the advanced settings for Build triggers, and this token is entered in the settings of the Gitlab project.

      Configured build trigger is the only "Build when a change is pushed to GitLab. GitLab CI Service URL: "

      Console output contains 4 messages "No GitLab connection configured", one after git checkout and before build start, and 3 more in the end of the log.

      The respective merge request in Gitlab contains messages like

      "Administrator @root commented about an hour ago

      :white_check_mark: Jenkins Build SUCCESS

      Results available at: Jenkins matrix_job #66 "

      that suggests, that build statuses are actually reported

        Attachments

          Activity

          wl2776 Vladimir Eremeev created issue -
          wl2776 Vladimir Eremeev made changes -
          Field Original Value New Value
          Description I've got a matrix job, that is triggered by the Gitlab plugin through webhooks.

          Job configuration contains configured "Gitlab connection" in General settings and 3 postbuild actions: "Add note with build status on Gitlab Merge requests", "Add vote for build status for Gitlab Merge requests" and "Publish build status to Gitlab commit".

          It also contains a secret token in the advanced settings for Build triggers, and this token is entered in the settings of the Gitlab project

          Console output contains 4 messages "No GitLab connection configured", one after git checkout and before build start, and 3 more in the end of the log.
          I've got a matrix job, that is triggered by the Gitlab plugin through webhooks.

          Job configuration contains configured "Gitlab connection" in General settings and 3 postbuild actions: "Add note with build status on Gitlab Merge requests", "Add vote for build status for Gitlab Merge requests" and "Publish build status to Gitlab commit".

          It also contains a secret token in the advanced settings for Build triggers, and this token is entered in the settings of the Gitlab project

          Console output contains 4 messages "No GitLab connection configured", one after git checkout and before build start, and 3 more in the end of the log.

          The respective merge request in Gitlab contains messages like

          {quote}
          "Administrator @root commented about an hour ago

          :white_check_mark: Jenkins Build SUCCESS

          Results available at: Jenkins [matrix_job #66] "
          {quote}
          wl2776 Vladimir Eremeev made changes -
          Description I've got a matrix job, that is triggered by the Gitlab plugin through webhooks.

          Job configuration contains configured "Gitlab connection" in General settings and 3 postbuild actions: "Add note with build status on Gitlab Merge requests", "Add vote for build status for Gitlab Merge requests" and "Publish build status to Gitlab commit".

          It also contains a secret token in the advanced settings for Build triggers, and this token is entered in the settings of the Gitlab project

          Console output contains 4 messages "No GitLab connection configured", one after git checkout and before build start, and 3 more in the end of the log.

          The respective merge request in Gitlab contains messages like

          {quote}
          "Administrator @root commented about an hour ago

          :white_check_mark: Jenkins Build SUCCESS

          Results available at: Jenkins [matrix_job #66] "
          {quote}
          I've got a matrix job, that is triggered by the Gitlab plugin through webhooks.

          Job configuration contains configured "Gitlab connection" in General settings and 3 postbuild actions: "Add note with build status on Gitlab Merge requests", "Add vote for build status for Gitlab Merge requests" and "Publish build status to Gitlab commit".

          It also contains a secret token in the advanced settings for Build triggers, and this token is entered in the settings of the Gitlab project

          Console output contains 4 messages "No GitLab connection configured", one after git checkout and before build start, and 3 more in the end of the log.

          The respective merge request in Gitlab contains messages like

          {quote}
          "Administrator @root commented about an hour ago

          :white_check_mark: Jenkins Build SUCCESS

          Results available at: Jenkins [matrix_job #66] "
          {quote}

          that suggests, that build statuses are actually reported
          wl2776 Vladimir Eremeev made changes -
          Description I've got a matrix job, that is triggered by the Gitlab plugin through webhooks.

          Job configuration contains configured "Gitlab connection" in General settings and 3 postbuild actions: "Add note with build status on Gitlab Merge requests", "Add vote for build status for Gitlab Merge requests" and "Publish build status to Gitlab commit".

          It also contains a secret token in the advanced settings for Build triggers, and this token is entered in the settings of the Gitlab project

          Console output contains 4 messages "No GitLab connection configured", one after git checkout and before build start, and 3 more in the end of the log.

          The respective merge request in Gitlab contains messages like

          {quote}
          "Administrator @root commented about an hour ago

          :white_check_mark: Jenkins Build SUCCESS

          Results available at: Jenkins [matrix_job #66] "
          {quote}

          that suggests, that build statuses are actually reported
          I've got a matrix job, that is triggered by the Gitlab plugin through webhooks.

          Job configuration contains configured "Gitlab connection" in General settings and 3 postbuild actions: "Add note with build status on Gitlab Merge requests", "Add vote for build status for Gitlab Merge requests" and "Publish build status to Gitlab commit".

          It also contains a secret token in the advanced settings for Build triggers, and this token is entered in the settings of the Gitlab project.

          Configured build trigger is the only "Build when a change is pushed to GitLab. GitLab CI Service URL: "

          Console output contains 4 messages "No GitLab connection configured", one after git checkout and before build start, and 3 more in the end of the log.

          The respective merge request in Gitlab contains messages like

          {quote}
          "Administrator @root commented about an hour ago

          :white_check_mark: Jenkins Build SUCCESS

          Results available at: Jenkins [matrix_job #66] "
          {quote}

          that suggests, that build statuses are actually reported
          owenmehegan Owen Mehegan made changes -
          Resolution Done [ 10000 ]
          Status Open [ 1 ] Closed [ 6 ]

            People

            Assignee:
            owenmehegan Owen Mehegan
            Reporter:
            wl2776 Vladimir Eremeev
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: