Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-48386

Incorrect messages "No GitLab connection configured"

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Done
    • Labels:
      None
    • Environment:
      Jenkins version 2.73.3
      Gitlab-plugin version 1.5.2
      Matrix-project plugin version 1.12
    • Similar Issues:

      Description

      I've got a matrix job, that is triggered by the Gitlab plugin through webhooks.

      Job configuration contains configured "Gitlab connection" in General settings and 3 postbuild actions: "Add note with build status on Gitlab Merge requests", "Add vote for build status for Gitlab Merge requests" and "Publish build status to Gitlab commit".

      It also contains a secret token in the advanced settings for Build triggers, and this token is entered in the settings of the Gitlab project.

      Configured build trigger is the only "Build when a change is pushed to GitLab. GitLab CI Service URL: "

      Console output contains 4 messages "No GitLab connection configured", one after git checkout and before build start, and 3 more in the end of the log.

      The respective merge request in Gitlab contains messages like

      "Administrator @root commented about an hour ago

      :white_check_mark: Jenkins Build SUCCESS

      Results available at: Jenkins matrix_job #66 "

      that suggests, that build statuses are actually reported

        Attachments

          Activity

          owenmehegan Owen Mehegan added a comment -

          So, the build triggers successfully and reports to GitLab successfully, it's just that it is logging messages about no GitLab connection being configured? If I understand this correctly, it may be a bug in our implementation of matrix job support.

          wl2776 Vladimir Eremeev added a comment -

          Yes, that's right, just incorrect log messages.
          My colleagues, not experienced in Jenkins tuning, see these messages in log and think that they are the cause of failed builds, not compiler errors or memory leaks, or failed unit tests.

          owenmehegan Owen Mehegan added a comment -

          Can you please open this as an issue on our GitHub page? That is where we track bugs with this plugin. https://github.com/jenkinsci/gitlab-plugin/


            People

            Assignee:
            owenmehegan Owen Mehegan
            Reporter:
            wl2776 Vladimir Eremeev
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: