Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-48466

Provide JUnit 5 support for JenkinsRule

    XMLWordPrintable

Details

    • 1813.v14f5db_a_f2b_d3

    Description

      JUnit 4 rules are not supported by JUnit 5. In order to use JenkinsRule in a test one cannot switch to JUnit 5 for these tests. You still need to have a dependency to JUnit 4.

      Attachments

        Activity

          ethorsa ethorsa added a comment - Next Iteration: https://github.com/jenkinsci/jenkins-test-harness/pull/438
          drulli Ulli Hafner added a comment -

          Yes, I tried to see if I can get it running without test harness. And it looks quite good, so I tried to move to a separate library: https://github.com/jenkins-infra/repository-permissions-updater/issues/2467.

          drulli Ulli Hafner added a comment - Yes, I tried to see if I can get it running without test harness. And it looks quite good, so I tried to move to a separate library: https://github.com/jenkins-infra/repository-permissions-updater/issues/2467 .
          jglick Jesse Glick added a comment -

          Now moved to plugin-util-api-plugin #161 drulli?

          jglick Jesse Glick added a comment - Now moved to plugin-util-api-plugin #161 drulli ?
          jglick Jesse Glick added a comment -

          Reverted again I am afraid.

          jglick Jesse Glick added a comment - Reverted again I am afraid.
          ethorsa ethorsa added a comment -

          JUnit 5 is available with Test Harness 1690.vfcb_959006c07 again .

          I guess we can close here?

          ethorsa ethorsa added a comment - JUnit 5 is available with Test Harness 1690.vfcb_959006c07 again  . I guess we can close here?

          People

            reda_alaoui Réda Housni Alaoui
            drulli Ulli Hafner
            Votes:
            11 Vote for this issue
            Watchers:
            14 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: