Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-48849

No downstream links in Blue Ocean with Bitbucket Multibranch

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      Steps to reproduce:

      • Use a BitBucket Team/Project (multibranch)
      • Have a Job with a Jenkinsfile
      • Use a valid build step in the Jenkinfile e.g. like build 'GROUP/repository/branch'
      • Run the job
      • Open the job details in Blue Ocean view
      • Try to open the downstream built job using a link which doesn't exist

      In the step details (console) it should say something like

      Scheduling project: GROUP »repository » branch
      Starting building: GROUP » repository » branch #7

      Both of them are working links to the GROUP/repository/branch job (the second one linking to the exact build) in the plain old Jenkins view, but none of them are links in the Blue Ocean view.

        Attachments

          Issue Links

            Activity

            schneida Simon Schneider created issue -
            schneida Simon Schneider made changes -
            Field Original Value New Value
            Description Steps to reproduce:
             * Use a BitBucket Team/Project (multibranch)
             * Have a Job with a Jenkinsfile
             * Use a valid build step in the Jenkinfile e.g. like {{build 'GROUP/repository/branch'}}{{}}
             * Run the job
             * Open the job details in Blue Ocean view
             * Try to open the downstream built job using a link which doesn't exist

            In the step details (console) it should say something like

             

            {{Scheduling project: GROUP » repository » branch
            }}{{[|http://10.16.34.52:8080/blue/organizations/jenkins/CATS%20CI/detail/CATS%20CI/28/pipeline/191#step-209-log-2]Starting building: GROUP » repository » branch #7}}

            Both of them are working links to the GROUP/repository/branch job (the second one linking to the exact build) in the plain old Jenkins view, but none of them are links in the Blue Ocean view.
            Steps to reproduce:
             * Use a BitBucket Team/Project (multibranch)
             * Have a Job with a Jenkinsfile
             * Use a valid build step in the Jenkinfile e.g. like {{build 'GROUP/repository/branch'}}
             * Run the job
             * Open the job details in Blue Ocean view
             * Try to open the downstream built job using a link which doesn't exist

            In the step details (console) it should say something like

            {{Scheduling project: CATS » cats-endpoint-gigaspaces » develop}}
            {{Starting building: CATS » cats-endpoint-gigaspaces » develop #7}}

            Both of them are working links to the GROUP/repository/branch job (the second one linking to the exact build) in the plain old Jenkins view, but none of them are links in the Blue Ocean view.
            schneida Simon Schneider made changes -
            Description Steps to reproduce:
             * Use a BitBucket Team/Project (multibranch)
             * Have a Job with a Jenkinsfile
             * Use a valid build step in the Jenkinfile e.g. like {{build 'GROUP/repository/branch'}}
             * Run the job
             * Open the job details in Blue Ocean view
             * Try to open the downstream built job using a link which doesn't exist

            In the step details (console) it should say something like

            {{Scheduling project: CATS » cats-endpoint-gigaspaces » develop}}
            {{Starting building: CATS » cats-endpoint-gigaspaces » develop #7}}

            Both of them are working links to the GROUP/repository/branch job (the second one linking to the exact build) in the plain old Jenkins view, but none of them are links in the Blue Ocean view.
            Steps to reproduce:
             * Use a BitBucket Team/Project (multibranch)
             * Have a Job with a Jenkinsfile
             * Use a valid build step in the Jenkinfile e.g. like {{build 'GROUP/repository/branch'}}
             * Run the job
             * Open the job details in Blue Ocean view
             * Try to open the downstream built job using a link which doesn't exist

            In the step details (console) it should say something like

            {{Scheduling project: GROUP »repository » branch}}
            {{Starting building: GROUP » repository » branch #7}}

            Both of them are working links to the GROUP/repository/branch job (the second one linking to the exact build) in the plain old Jenkins view, but none of them are links in the Blue Ocean view.
            jamesdumay James Dumay added a comment -

            Duplicate of JENKINS-38339 which is in progress.

            jamesdumay James Dumay made changes -
            Link This issue duplicates JENKINS-38339 [ JENKINS-38339 ]
            jamesdumay James Dumay made changes -
            Resolution Duplicate [ 3 ]
            Status Open [ 1 ] Resolved [ 5 ]
            jbriden Jenn Briden made changes -
            Status Resolved [ 5 ] Closed [ 6 ]

              People

              Assignee:
              imeredith Ivan Meredith
              Reporter:
              schneida Simon Schneider
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: