Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-49616

Estimated time remaining NA

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Duplicate
    • Component/s: core
    • Labels:
      None
    • Environment:
      Docker/Ubuntu LTS 2.89.4
    • Similar Issues:

      Description

      After upgrading to LTS 2.89.4 the estimate time remaining is always NA

        Attachments

          Issue Links

            Activity

            uncletall uncletall created issue -
            oleg_nenashev Oleg Nenashev added a comment -

            Please provide more info about the issue: Job types you use, UI screenshots, etc.

            uncletall uncletall made changes -
            Field Original Value New Value
            Attachment 2018-02-20 08_16_37-Dashboard [Jenkins].png [ 41532 ]
            uncletall uncletall added a comment -

            The jobs are different kind of pipeline jobs.

            ben_c Benjamin Coover made changes -
            Attachment pipeline_remaining01.png [ 41544 ]
            Attachment pipeline_remaining02.png [ 41545 ]
            ben_c Benjamin Coover added a comment -

            We are seeing this as well. Our jobs are regular pipelines (Scripted-style, as opposed to Declarative) using Jenkinsfile from SCM. The nodes being used are Windows 7 and Ubuntu 14.04 virtual machines and master is Windows Server 2012. Freestyle jobs still display estimated remaining time.

            seldor Matthias Keller made changes -
            Attachment image-2018-02-21-19-28-24-208.png [ 41559 ]
            seldor Matthias Keller added a comment - - edited

            Same here, we're seeing this since the last updates. Most projects are pipelines as well. Right after starting (and probably before the pipeline really starts), the ETA is displayed. However, shortly afterwards and until the build is completely finished, the time isn't here anymore:

            According to https://groups.google.com/forum/#!topic/jenkinsci-users/BdKmRrkjir4 the bug is very easy to fix:

            Resetting the executableEstimatedDuration only when there is no asynchrounous execution seems to solve the problem. So the resulting Code in hudson.model.Executor is

            [...]
            458 } finally {
            459  if (asynchronousExecution == null) {
            460   finish2();
            461   executableEstimatedDuration = DEFAULT_ESTIMATED_DURATION;
            462  }
            463 }
            [...]
            aaron312 Aaron Curley added a comment -

            Also seeing this on LTS 2.89.4 after upgrading from 2.89.2.

            hentis Henti Smith added a comment -

            Same problem after upgrading to LTS on all our builds. 

            deftez Andrii Danyleiko added a comment -

            The same for me after upgrading 2.89.3 -> 2.89.4 on two instances

            oleg_nenashev Oleg Nenashev added a comment -

            According to the investigation by Matthias Keller and Berno Langer, closing it as a duplicate of JENKINS-48821 so we do not have a split discussion

            oleg_nenashev Oleg Nenashev made changes -
            Link This issue duplicates JENKINS-48821 [ JENKINS-48821 ]
            oleg_nenashev Oleg Nenashev made changes -
            Resolution Duplicate [ 3 ]
            Status Open [ 1 ] Resolved [ 5 ]
            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Berno Langer
            Path:
            core/src/main/java/hudson/model/Executor.java
            http://jenkins-ci.org/commit/jenkins/3fc392108ae382a4616964aa8bbb6b8cb9dff0dc
            Log:
            JENKINS-48821 - Don't forget estimated duration of asynchronous jobs (#3329)

            • Don't forget estimated duration of asynchronous jobs.

            When jobs are executed, the estimated duration is calculated, memorized
            and reseted when the job is finished.

            But when the job is executed asynchronously (e.g. as for pipeline
            scripts), the execution is just triggered. Therefore the estimated
            duration should remain - and not be reseted after triggering.

            JENKINS-48821: Time remaining for all pipeline jobs is N/A
            JENKINS-49616: Estimated time remaining NA

            • Reset cached estimated duration also when asynchronous job ends.
            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Berno Langer
            Path:
            core/src/main/java/hudson/model/Executor.java
            http://jenkins-ci.org/commit/jenkins/1400918ddaef45470720e60d4d1dbfd2f6ac78d4
            Log:
            JENKINS-48821 - Don't forget estimated duration of asynchronous jobs (#3329)

            • Don't forget estimated duration of asynchronous jobs.

            When jobs are executed, the estimated duration is calculated, memorized
            and reseted when the job is finished.

            But when the job is executed asynchronously (e.g. as for pipeline
            scripts), the execution is just triggered. Therefore the estimated
            duration should remain - and not be reseted after triggering.

            JENKINS-48821: Time remaining for all pipeline jobs is N/A
            JENKINS-49616: Estimated time remaining NA

            • Reset cached estimated duration also when asynchronous job ends.

            (cherry picked from commit 3fc392108ae382a4616964aa8bbb6b8cb9dff0dc)


              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              uncletall uncletall
              Votes:
              6 Vote for this issue
              Watchers:
              13 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: