Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-5000

FATAL error in the clover plugin stops processing of post-build actions.

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      Problem:
      When the clover.xml file is invalid xml, the clover post-build action fails and stops the remaining post-build actions from executing.

      Suggested solution:
      Fail the build when the clover.xml file is invalid but leave the remaining post-build actions execute.

      Example clover.xml file that causes the error:
      <?xml version="1.0" encoding="utf-8"?>
      <coverage clover="0.3.2" generated="1259344237">
      <project timestamp="1259344237" name="NoseXUnit"

      Error that occurs in the build log:
      Publishing Clover coverage report...
      Publishing Clover HTML report...
      Publishing Clover XML report...
      Publishing Clover coverage results...
      FATAL: Unable to copy coverage from /var/lib/hudson/jobs/python-logconfig/workspace/reports/cover to /var/lib/hudson/jobs/python-logconfig/builds/2009-11-27_12-50-33
      hudson.util.IOException2: Cannot parse coverage results
      at hudson.plugins.clover.CloverCoverageParser.parse(CloverCoverageParser.java:89)
      at hudson.plugins.clover.CloverCoverageParser.parse(CloverCoverageParser.java:51)
      at hudson.plugins.clover.CloverPublisher.processCloverXml(CloverPublisher.java:191)
      at hudson.plugins.clover.CloverPublisher.perform(CloverPublisher.java:152)
      at hudson.tasks.BuildStepMonitor$3.perform(BuildStepMonitor.java:36)
      at hudson.model.AbstractBuild$AbstractRunner.perform(AbstractBuild.java:541)
      at hudson.model.AbstractBuild$AbstractRunner.performAllBuildStep(AbstractBuild.java:527)
      at hudson.model.AbstractBuild$AbstractRunner.performAllBuildStep(AbstractBuild.java:515)
      at hudson.model.Build$RunnerImpl.post2(Build.java:152)
      at hudson.model.AbstractBuild$AbstractRunner.post(AbstractBuild.java:499)
      at hudson.model.Run.run(Run.java:1199)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
      at hudson.model.ResourceController.execute(ResourceController.java:88)
      at hudson.model.Executor.run(Executor.java:123)
      Caused by: org.xml.sax.SAXParseException: XML document structures must start and end within the same entity.
      at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(AbstractSAXParser.java:1231)
      at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.parse(SAXParserImpl.java:522)
      at org.apache.commons.digester.Digester.parse(Digester.java:1666)
      at hudson.plugins.clover.CloverCoverageParser.parse(CloverCoverageParser.java:87)
      ... 13 more
      FATAL: null
      java.lang.NullPointerException
      at hudson.plugins.clover.CloverBuildAction.<init>(CloverBuildAction.java:133)
      at hudson.plugins.clover.CloverBuildAction.load(CloverBuildAction.java:265)
      at hudson.plugins.clover.CloverPublisher.processCloverXml(CloverPublisher.java:197)
      at hudson.plugins.clover.CloverPublisher.perform(CloverPublisher.java:152)
      at hudson.tasks.BuildStepMonitor$3.perform(BuildStepMonitor.java:36)
      at hudson.model.AbstractBuild$AbstractRunner.perform(AbstractBuild.java:541)
      at hudson.model.AbstractBuild$AbstractRunner.performAllBuildStep(AbstractBuild.java:527)
      at hudson.model.AbstractBuild$AbstractRunner.performAllBuildStep(AbstractBuild.java:515)
      at hudson.model.Build$RunnerImpl.post2(Build.java:152)
      at hudson.model.AbstractBuild$AbstractRunner.post(AbstractBuild.java:499)
      at hudson.model.Run.run(Run.java:1199)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
      at hudson.model.ResourceController.execute(ResourceController.java:88)
      at hudson.model.Executor.run(Executor.java:123)

        Attachments

          Activity

          wyrdvans wyrdvans created issue -
          stephenconnolly Stephen Connolly made changes -
          Field Original Value New Value
          Assignee stephenconnolly [ stephenconnolly ] npellow [ npellow ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 135084 ] JNJira + In-Review [ 174255 ]
          marekparf Marek Parfianowicz added a comment - - edited

          In my opinion this is a valid behavior that build execution (in that particular case - execution of post-build actions) does not continue in case of a failure. 

          Furthermore, Clover plugin failed because of the invalid XML file (truncated), so it also behaved correctly. 

          Won't fix.

          marekparf Marek Parfianowicz made changes -
          Assignee npellow [ npellow ] Marek Parfianowicz [ marekparf ]
          Resolution Won't Fix [ 2 ]
          Status Open [ 1 ] Closed [ 6 ]

            People

            Assignee:
            marekparf Marek Parfianowicz
            Reporter:
            wyrdvans wyrdvans
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: