Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-5022

ci game failed with last pmd plugin

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      upgrading ci-game failed when upgrading to last pmd plugin

      SEVERE: Executor throw an exception unexpectedly
      java.lang.NoClassDefFoundError: hudson/plugins/pmd/util/model/Priority
              at hudson.plugins.cigame.rules.plugins.pmd.PmdRuleSet.loadRules(PmdRuleS
      et.java:14)
              at hudson.plugins.cigame.rules.plugins.PluginRuleSet.getRules(PluginRule
      Set.java:48)
              at hudson.plugins.cigame.model.ScoreCard.record(ScoreCard.java:33)
              at hudson.plugins.cigame.model.ScoreCard.record(ScoreCard.java:54)
              at hudson.plugins.cigame.GamePublisher.perform(GamePublisher.java:56)
              at hudson.plugins.cigame.GamePublisher.perform(GamePublisher.java:42)
              at hudson.tasks.BuildStepMonitor$3.perform(BuildStepMonitor.java:36)
              at hudson.model.AbstractBuild$AbstractRunner.perform(AbstractBuild.java:
      577)
      

        Attachments

          Issue Links

            Activity

            olamy Olivier Lamy created issue -
            olamy Olivier Lamy added a comment -

            Currently some plugins doesn't provide anymore jars :

            • pmd
            • findbugs

            You must publish new build of this plugins including jar.
            By adding this part in the build sections

                  <plugin>
                    <groupId>org.apache.maven.plugins</groupId>
                    <artifactId>maven-jar-plugin</artifactId>
                    <version>2.3</version>
                    <executions>
                      <execution>
                        <goals>
                          <goal>jar</goal>
                        </goals>
                        <phase>prepare-package</phase>
                      </execution>
                    </executions>
                  </plugin>
            

            A fix of this will need a release of pmd and findbugs plugins.

            olamy Olivier Lamy added a comment -

            here a patch which include patches for pmd and findbugs plugins.

            olamy Olivier Lamy made changes -
            Field Original Value New Value
            Attachment JENKINS-5022 [ 18951 ]
            olamy Olivier Lamy added a comment -

            or give me karma to fix that (uid olamy)

            olamy Olivier Lamy added a comment -

            so the hpi plugin attached normaly a jar with classes.
            Why the jar is not here : http://maven.glassfish.org/content/groups/public/org/jvnet/hudson/plugins/findbugs/4.0/

            ?

            kohsuke Kohsuke Kawaguchi added a comment -

            olamy, you now have the commit access.

            Did something change in the POM in the findbugs plugin that prevents it from attaching the jar artifact?

            mindless Alan Harder made changes -
            Link This issue is duplicated by JENKINS-5029 [ JENKINS-5029 ]
            mindless Alan Harder made changes -
            Component/s findbugs [ 15496 ]
            Component/s pmd [ 15511 ]
            drulli Ulli Hafner added a comment -

            I think this problem is not related to the publishing of jars. In previous releases the jar wasn't published too:
            http://maven.glassfish.org/content/groups/public/org/jvnet/hudson/plugins/findbugs/3.13/

            The ci-plug-in needs to have a dependency to the new analysis-core plug-in...

            drulli Ulli Hafner made changes -
            Component/s checkstyle [ 15512 ]
            Component/s dry [ 15591 ]
            Component/s warnings [ 15513 ]
            drulli Ulli Hafner made changes -
            Component/s tasks-plugin [ 15498 ]
            drulli Ulli Hafner made changes -
            Link This issue is duplicated by JENKINS-5029 [ JENKINS-5029 ]
            redsolo redsolo added a comment -

            I have a patch from a user, and will apply it shortly. Drulli is correct that the ci game is missing a vital dependency.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in hudson
            User: : olamy
            Path:
            trunk/hudson/plugins/ci-game/pom.xml
            trunk/hudson/plugins/ci-game/src/main/java/hudson/plugins/cigame/rules/plugins/findbugs/FindBugsRuleSet.java
            trunk/hudson/plugins/ci-game/src/main/java/hudson/plugins/cigame/rules/plugins/findbugs/FixedFindBugsWarningsRule.java
            trunk/hudson/plugins/ci-game/src/main/java/hudson/plugins/cigame/rules/plugins/findbugs/NewFindBugsWarningsRule.java
            trunk/hudson/plugins/ci-game/src/main/java/hudson/plugins/cigame/rules/plugins/opentasks/DefaultOpenTasksRule.java
            trunk/hudson/plugins/ci-game/src/main/java/hudson/plugins/cigame/rules/plugins/opentasks/OpenTasksRuleSet.java
            trunk/hudson/plugins/ci-game/src/main/java/hudson/plugins/cigame/rules/plugins/pmd/DefaultPmdRule.java
            trunk/hudson/plugins/ci-game/src/main/java/hudson/plugins/cigame/rules/plugins/pmd/PmdRuleSet.java
            trunk/hudson/plugins/ci-game/src/test/java/hudson/plugins/cigame/rules/plugins/findbugs/FixedFindBugsWarningsRuleTest.java
            trunk/hudson/plugins/ci-game/src/test/java/hudson/plugins/cigame/rules/plugins/findbugs/NewFindBugsWarningsRuleTest.java
            trunk/hudson/plugins/ci-game/src/test/java/hudson/plugins/cigame/rules/plugins/opentasks/DefaultOpenTasksRuleTest.java
            trunk/hudson/plugins/ci-game/src/test/java/hudson/plugins/cigame/rules/plugins/pmd/DefaultPmdRuleTest.java
            trunk/hudson/plugins/ci-game/src/test/java/hudson/plugins/cigame/rules/plugins/warnings/DefaultWarningsRuleTest.java
            http://fisheye4.cenqua.com/changelog/hudson/?cs=24476
            Log:
            JENKINS-5022 ci game failed with last pmd plugin.
            use classes from analysis-core.
            upgrade dependencies versions :

            • tasks to 4.0
            • pmd to 3.1-SNAPSHOY
            • warnings to 3.0
            olamy Olivier Lamy added a comment -

            fixed in rev 24476.
            This will need new version of :

            • findbugs
            • pmd
            olamy Olivier Lamy made changes -
            Assignee redsolo [ redsolo ] olamy [ olamy ]
            Resolution Fixed [ 1 ]
            Status Open [ 1 ] Closed [ 6 ]
            redsolo redsolo added a comment -

            Just got this: http://hudson.ramfelt.se/job/Hudson%20plugin%20The%20Continuous%20Integration%20Game/152/console

            Is there any reason why there are two snapshots dependencies in the pom.xml?

            olamy Olivier Lamy added a comment -
            kohsuke Kohsuke Kawaguchi added a comment -

            Older version of the findbugs plugin, like http://maven.glassfish.org/content/groups/public/org/jvnet/hudson/plugins/findbugs/3.9/, deploys the jar.

            Looks like this is a bug in the release process or the maven-hpi-plugin.

            I see that other recently released plugins exhibit the same lack of jar files, such as http://maven.glassfish.org/content/groups/public/org/jvnet/hudson/plugins/batch-task/1.9/

            I've opened JENKINS-5037 to track this issue separately.

            mindless Alan Harder made changes -
            Link This issue is duplicated by JENKINS-5027 [ JENKINS-5027 ]
            mhenoch mhenoch made changes -
            Link This issue duplicates JENKINS-4992 [ JENKINS-4992 ]
            olamy Olivier Lamy added a comment -

            I have installed a patch version on my company production hudson and it works
            A build is available here fopr testing : http://people.apache.org/~olamy/hudson/JENKINS-5022/.

            olamy Olivier Lamy made changes -
            Link This issue is duplicated by JENKINS-5051 [ JENKINS-5051 ]
            abarbieri Andrea Barbieri added a comment -

            using this proposed patch [1.16-SNAPSHOT (private-12/08/2009 11:19-OLAMY)] with the following Hudson plugins:

            • pmd 3.1
            • findbugs 4.0
            • warnings 3.1
            • tasks 4.1
            • analysis-core 1.1

            triggers the following error:

            29-Dec-2009 16:10:04 hudson.model.Executor run
            SEVERE: Executor throw an exception unexpectedly
            java.lang.NoSuchMethodError: hudson.plugins.checkstyle.CheckStyleResultAction.getResult()Lhudson/plugins/checkstyle/util/BuildResult;
            at hudson.plugins.cigame.rules.plugins.checkstyle.DefaultCheckstyleRule.hasNoErrors(DefaultCheckstyleRule.java:47)
            at hudson.plugins.cigame.rules.plugins.checkstyle.DefaultCheckstyleRule.evaluate(DefaultCheckstyleRule.java:29)
            at hudson.plugins.cigame.model.ScoreCard.record(ScoreCard.java:34)
            at hudson.plugins.cigame.model.ScoreCard.record(ScoreCard.java:54)
            at hudson.plugins.cigame.GamePublisher.perform(GamePublisher.java:56)
            at hudson.plugins.cigame.GamePublisher.perform(GamePublisher.java:42)
            at hudson.tasks.BuildStepMonitor$3.perform(BuildStepMonitor.java:36)
            at hudson.model.AbstractBuild$AbstractRunner.perform(AbstractBuild.java:583)
            at hudson.model.AbstractBuild$AbstractRunner.performAllBuildStep(AbstractBuild.java:564)
            at hudson.model.AbstractBuild$AbstractRunner.performAllBuildStep(AbstractBuild.java:551)
            at hudson.model.Build$RunnerImpl.cleanUp(Build.java:158)
            at hudson.model.Run.run(Run.java:1221)
            at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
            at hudson.model.ResourceController.execute(ResourceController.java:88)
            at hudson.model.Executor.run(Executor.java:122)

            olamy Olivier Lamy added a comment -

            so upgrade an other one : checkstyle plugin

            abarbieri Andrea Barbieri added a comment -
            • checkstyle 3.1

            is there a newer version?

            http://wiki.jenkins-ci.org/display/JENKINS/Checkstyle+Plugin reports:
            Latest Release 3.1

            abarbieri Andrea Barbieri added a comment -

            just to be clear...

            the reported NoSuchMethodError is happening with the latest released checkstyle hudson plugin (v 3.1).

            olamy Olivier Lamy added a comment -

            reopen due to user comment.
            ci-game will need a checkstyle plugin version update.

            olamy Olivier Lamy made changes -
            Resolution Fixed [ 1 ]
            Status Closed [ 6 ] Reopened [ 4 ]
            olamy Olivier Lamy added a comment -

            dependencies version updated in the ci-game plugin.
            new snapshot build updated here http://people.apache.org/~olamy/hudson/JENKINS-5022/.

            Please give a try !

            abarbieri Andrea Barbieri added a comment -

            will report soon on the new version [1.16-SNAPSHOT (private-12/29/2009 08:03-OLAMY)]

            many thanks for the promptness!

            abarbieri Andrea Barbieri added a comment -

            so far no issues... it will be a few days before I'll have tested it thoroughly on the production system.

            olamy Olivier Lamy added a comment -

            release done

            olamy Olivier Lamy made changes -
            Resolution Fixed [ 1 ]
            Status Reopened [ 4 ] Closed [ 6 ]
            mindless Alan Harder made changes -
            Link This issue is duplicated by JENKINS-2207 [ JENKINS-2207 ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 135106 ] JNJira + In-Review [ 203262 ]

              People

              Assignee:
              olamy Olivier Lamy
              Reporter:
              olamy Olivier Lamy
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: