Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-50561

Add @Symbol to "throttle builds" job properties

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      Currently the snippet generator suggests/generates:

      properties([[$class: 'JobPropertyImpl', throttle: [count: 1, durationName: 'hour', userBoost: true]]])
      

        Attachments

          Issue Links

            Activity

            reinholdfuereder Reinhold Füreder created issue -
            oleg_nenashev Oleg Nenashev made changes -
            Field Original Value New Value
            Component/s branch-api-plugin [ 18621 ]
            Component/s workflow-job-plugin [ 21716 ]
            oleg_nenashev Oleg Nenashev made changes -
            Assignee Stephen Connolly [ stephenconnolly ]
            oleg_nenashev Oleg Nenashev made changes -
            Labels newbie-friendly
            abayer Andrew Bayer made changes -
            Assignee Stephen Connolly [ stephenconnolly ] Andrew Bayer [ abayer ]
            abayer Andrew Bayer made changes -
            Status Open [ 1 ] In Progress [ 3 ]
            abayer Andrew Bayer made changes -
            Status In Progress [ 3 ] In Review [ 10005 ]
            abayer Andrew Bayer added a comment -

            PR up at https://github.com/jenkinsci/branch-api-plugin/pull/127 adding the symbol rateLimitBuilds - I wanted to avoid having "throttle" in the symbol since it means something different here than it does over in Throttle Concurrent Builds.

            abayer Andrew Bayer made changes -
            Remote Link This issue links to "PR #127 (Web Link)" [ 21301 ]
            ifernandezcalvo Ivan Fernandez Calvo added a comment -

            I have hit this today, the Directive Generator generates the following code that it is wrong

              options {
                rateLimitBuilds([count: 60, durationName: 'hour', userBoost: false])
              }
            

            it should be this one, notice that it missed adding the `throttle` part

              options {
                rateLimitBuilds(throttle: [count: 60, durationName: 'hour', userBoost: false])
              }
            
            bitwiseman Liam Newman made changes -
            Resolution Fixed [ 1 ]
            Status In Review [ 10005 ] Resolved [ 5 ]
            bitwiseman Liam Newman made changes -
            Comment [ [~ifernandezcalvo]
            Please open a new issue. Should be an easy fix. ]
            bitwiseman Liam Newman made changes -
            Assignee Andrew Bayer [ abayer ] Liam Newman [ bitwiseman ]
            Resolution Fixed [ 1 ]
            Status Resolved [ 5 ] Reopened [ 4 ]
            bitwiseman Liam Newman added a comment -

            Ivan Fernandez Calvo
            Does the generated code not work?

            ifernandezcalvo Ivan Fernandez Calvo added a comment -

            not at all

            reinholdfuereder Reinhold Füreder added a comment -

            (I can confirm that it is not working and just silently ignored )


              People

              Assignee:
              bitwiseman Liam Newman
              Reporter:
              reinholdfuereder Reinhold Füreder
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

                Dates

                Created:
                Updated: