Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-51138

Links inside LoadRunner Analysis Reports not working [Performance Report]

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      After executing a build using the hp-application-automation-tools-plugin 5.3 with the Execute HPE tests from file system build and Publish HPE test results, we go to the Performance Report and click on the hyperlink to see the LoadRunner Analysis Report.  This report shows the Summary page only.  The left hand links (i.e. Running vusers, Hits per second, etc...) are not accessible (e.g. when clicking on them nothing happens).

      Even when we paste the URL from the links into the browser we are taken to a page with no graph (see attached)

       

      We ran the following script but it did not work for us (didn't resolve this issue) 

      System.setProperty("hudson.model.DirectoryBrowserSupport.CSP", "sandbox; default-src 'none'; img-src 'self'; style-src 'self' 'unsafe-inline'; script-src 'self' 'unsafe-inline'; child-src 'self';")

       

        Attachments

          Activity

          Hide
          sudhakar15_dev sudhakar sidhu added a comment -

          Hi Rolando,

          I was able to run the java commands successfully. Issue is resolved reports links are working now thanks for support.

          --Sudhakar

          Show
          sudhakar15_dev sudhakar sidhu added a comment - Hi Rolando, I was able to run the java commands successfully. Issue is resolved reports links are working now thanks for support. --Sudhakar
          Hide
          rolandomihaivlad Rolando-Mihai Vlad added a comment -

          Hello Sudhakar,

          You have to modify the java command when running jenkins (java -Dhudson.model.DirectoryBrowserSupport.CSP= -jar jenkins.war). Please check https://wiki.jenkins.io/display/JENKINS/Configuring+Content+Security+Policy.

           

          Regards,

          Rolando

          Show
          rolandomihaivlad Rolando-Mihai Vlad added a comment - Hello Sudhakar, You have to modify the java command when running jenkins (java -Dhudson.model.DirectoryBrowserSupport.CSP= -jar jenkins.war). Please check  https://wiki.jenkins.io/display/JENKINS/Configuring+Content+Security+Policy .   Regards, Rolando
          Hide
          sudhakar15_dev sudhakar sidhu added a comment -

          Hello, 

          We are having same issue running System.setProperty("hudson.model.DirectoryBrowserSupport.CSP", "")  in script console resolved issue temporarily every time Jenkins is re-started  its not working.

          Can you provide arguments that we can add to Jenkins.xml to resolve issue permanently please.  

          Regards,
          Sudhakar 

          Show
          sudhakar15_dev sudhakar sidhu added a comment - Hello,  We are having same issue running  System.setProperty("hudson.model.DirectoryBrowserSupport.CSP", "")   in script console resolved issue temporarily every time Jenkins is re-started  its not working. Can you provide arguments that we can add to Jenkins.xml to resolve issue permanently please.   Regards, Sudhakar 
          Hide
          gront Daniel Gront added a comment -

          No response from the creator, If the issue reoccurs please reopen the ticket.

          Show
          gront Daniel Gront added a comment - No response from the creator, If the issue reoccurs please reopen the ticket.
          Hide
          gront Daniel Gront added a comment -

          Perftst1 SQAD is the given solution solved your issue? can we close this issue?

          Show
          gront Daniel Gront added a comment - Perftst1 SQAD is the given solution solved your issue? can we close this issue?
          Hide
          rolandomihaivlad Rolando-Mihai Vlad added a comment - - edited

          Hello,

          Run the following script instead System.setProperty("hudson.model.DirectoryBrowserSupport.CSP", "") and force a cache refresh by pressing ctrl+f5 on the page you are viewing.

           

          Regards,

          Rolando

          Show
          rolandomihaivlad Rolando-Mihai Vlad added a comment - - edited Hello, Run the following script instead System.setProperty("hudson.model.DirectoryBrowserSupport.CSP", "") and force a cache refresh by pressing ctrl+f5 on the page you are viewing.   Regards, Rolando

            People

            Assignee:
            rolandomihaivlad Rolando-Mihai Vlad
            Reporter:
            perftst1 Perftst1 SQAD
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: