Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-51226

debian package must depend on *some* jre

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Duplicate
    • Component/s: packaging
    • Labels:
      None
    • Environment:
      ubuntu 16.04
    • Similar Issues:

      Description

      While trying to test 2.107.3 I ran into the debian package not depending on any jre anymore.

       

      I.e.:

      1) apt-get install jenkins fails, jenkins can't be started because java NotFound

      2) apt-get install default-jre-headless jenkins fails, systemd tries to start jenkins before installing the jre.

       

      Requiring users to do 'apt-get install default-jre-headless' then 'apt-get install jenkins' is not the way package dependencies should work IMHO.

       

       

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              kohsuke Kohsuke Kawaguchi
              Reporter:
              vila vila
              Votes:
              1 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: