Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-5123

NullPointerException during M2 Extra Steps tear-down

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: m2-extra-steps-plugin
    • Labels:
      None
    • Environment:
      M2 Extra Steps 1.1.2, Hudson 1.321, JDK 1.6.0_17, Windows XP Professional 2002 SP2
    • Similar Issues:

      Description

      During tear-down the following NPE shows up and causes the build to be marked as failed (even though the actual build does succeed):

      ...
      [INFO]
      ------------------------------------------------------------------------
      [INFO] BUILD SUCCESSFUL
      [INFO]
      ------------------------------------------------------------------------
      [INFO] Total time: 12 minutes 18 seconds
      [INFO] Finished at: Mon Dec 14 09:53:46 PST 2009
      [INFO] Final Memory: 17M/31M
      [INFO]
      ------------------------------------------------------------------------
      Waiting for Hudson to finish collecting data
      channel stopped
      ERROR: Processing failed due to a bug in the code. Please report this to
      users@hudson.dev.java.net
      java.lang.NullPointerException
      at
      hudson.plugins.m2extrasteps.M2ExtraStepsWrapper.shouldPostStepsRun(M2ExtraStepsWrapper.java:101)
      at
      hudson.plugins.m2extrasteps.M2ExtraStepsWrapper.access$000(M2ExtraStepsWrapper.java:46)
      at
      hudson.plugins.m2extrasteps.M2ExtraStepsWrapper$1.tearDown(M2ExtraStepsWrapper.java:134)
      at
      hudson.maven.MavenModuleSetBuild$RunnerImpl.doRun(MavenModuleSetBuild.java:494)
      at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:354)
      at hudson.model.Run.run(Run.java:1106)
      at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:301)
      at hudson.model.ResourceController.execute(ResourceController.java:93)
      at hudson.model.Executor.run(Executor.java:122)
      project=hudson.maven.MavenModuleSet@169dc09[FormEditorRelease]
      project.getModules()=[hudson.maven.MavenModule@1496e57[FormEditorRelease/com.intuit.engine.tpe:tpe-tool-formeditor-ui]]
      project.getRootModule()=hudson.maven.MavenModule@1496e57[FormEditorRelease/com.intuit.engine.tpe:tpe-tool-formeditor-ui]
      FATAL: null
      ...

      We initially thought that this was an intermittent problem, but ever since the first failure of this type all subsequent builds failed with the same issue. It is not a blocker since the actual build still completes, but our dashboard now shows this particular build as always failing.

      A similar issue was reported earlier on the mailing list: http://n4.nabble.com/Maven-Extra-Steps-Error-td367919.html

      Thanks for looking into this,

      Mirko Raner
      Senior Software Engineer
      Consumer Group Tools Team
      Intuit, Inc.

        Attachments

          Activity

            People

            Assignee:
            abayer Andrew Bayer
            Reporter:
            raner raner
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: