Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-51291

'new view' wrong url - not relative

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      Hi,

      My jenkins is behind proxy server  [ngnix] and for node connection [with .jar agent] i had to configure the direct servers url and not the proxy's one as my ngninx cannot transfer none http/s connection and it's unnecessary. 

      now, when i want to create a new view [by pressing on 'new view' on the left bar at the home page] it takes me to jenkins's server url and not the proxy's.

      it's now: -http://jenkins-server:8080/jenkins/newView

      and should be: https://gateway.com/jenkins/newView

        Attachments

          Issue Links

            Activity

            apresfiux Kirill Kamaldinov created issue -
            oleg_nenashev Oleg Nenashev made changes -
            Field Original Value New Value
            Component/s core [ 15593 ]
            Component/s _unsorted [ 19622 ]
            oleg_nenashev Oleg Nenashev added a comment -

            Do you Have Jenkins Roor URL configured correctly in the global configuration?

            oleg_nenashev Oleg Nenashev made changes -
            Assignee Oleg Nenashev [ oleg_nenashev ]
            apresfiux Kirill Kamaldinov added a comment -

            My root URL configured to server's URL not proxy's and that's because if I configure it to proxy's , than I couldn't connect windows nodes with jar agents as they will try to connect via proxy and my proxy unable to proxy such connections

            oleg_nenashev Oleg Nenashev added a comment -

            Then it behaves as designed.

            If you want agent connections to bypass the proxy and connect directly, use the "hudson.TcpSlaveAgentListener.hostName" system property on master. It will expose proper metadata to connecting agents so that they will go directly to the host instead of the default URL>

            oleg_nenashev Oleg Nenashev made changes -
            Resolution Not A Defect [ 7 ]
            Status Open [ 1 ] Resolved [ 5 ]
            apresfiux Kirill Kamaldinov added a comment -

            I got you. But I reported a bug because only new view link is not relative.. All of the others are relative and works well

            oleg_nenashev Oleg Nenashev added a comment -

            OK, I am happy to reopen it for further triage. There were related patches in the recent versions

            oleg_nenashev Oleg Nenashev made changes -
            Resolution Not A Defect [ 7 ]
            Status Resolved [ 5 ] Reopened [ 4 ]
            danielbeck Daniel Beck made changes -
            Labels newbie-friendly
            wfollonier Wadeck Follonier made changes -
            Status Reopened [ 4 ] In Progress [ 3 ]
            wfollonier Wadeck Follonier made changes -
            Assignee Wadeck Follonier [ wfollonier ]
            wfollonier Wadeck Follonier added a comment -

            I think the linked PR will correct your problem The link was absolute, using the rootUrl and now it will use the internal feature of relative link for actions.

            wfollonier Wadeck Follonier made changes -
            Remote Link This issue links to "#3633 in core (Web Link)" [ 22564 ]
            wfollonier Wadeck Follonier made changes -
            Labels newbie-friendly newbie-friendly view
            oleg_nenashev Oleg Nenashev added a comment -

            Likely it is fixed by JENKINS-48447

            oleg_nenashev Oleg Nenashev made changes -
            Link This issue duplicates JENKINS-48447 [ JENKINS-48447 ]
            oleg_nenashev Oleg Nenashev made changes -
            Link This issue duplicates JENKINS-48447 [ JENKINS-48447 ]
            oleg_nenashev Oleg Nenashev added a comment -

            UPD: it's not 

            erutan409 Michael Keyser added a comment -

            Can confirm this is still an issue and my environment is configured similar to original reporter.

            wfollonier Wadeck Follonier made changes -
            Assignee Wadeck Follonier [ wfollonier ]
            wfollonier Wadeck Follonier made changes -
            Status In Progress [ 3 ] Open [ 1 ]
            wfollonier Wadeck Follonier added a comment -

            Initial PR closed. Another approach seems to be required.

            austry Ilia Zasimov made changes -
            Assignee Ilia Zasimov [ austry ]
            austry Ilia Zasimov made changes -
            Status Open [ 1 ] In Progress [ 3 ]
            jglick Jesse Glick made changes -
            Link This issue is caused by JENKINS-48447 [ JENKINS-48447 ]
            jglick Jesse Glick made changes -
            Labels newbie-friendly view folders newbie-friendly view
            jglick Jesse Glick added a comment -

            JENKINS-48447 broke usage in folders: inside a folder, the New View link actually creates a view at the Jenkins root.


              People

              Assignee:
              austry Ilia Zasimov
              Reporter:
              apresfiux Kirill Kamaldinov
              Votes:
              2 Vote for this issue
              Watchers:
              5 Start watching this issue

                Dates

                Created:
                Updated: