Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-52016

Build parameters & env variables not working to Publish Over SSH

    XMLWordPrintable

Details

    • Bug
    • Status: Fixed but Unreleased (View Workflow)
    • Blocker
    • Resolution: Cannot Reproduce
    • None
    • Redhat 7.4 PPC Big Endian

    Description

      The build parameters and environment variables not working in Publish over ssh. Previously it worked. Now in this version 1.19.1 , it is not working. The parameter values are null so that no files are copied over.

      Attachments

        1. $1AAC62AC63F72136.jpg
          $1AAC62AC63F72136.jpg
          23 kB
        2. $2E738BC7C06B1B7E.jpg
          $2E738BC7C06B1B7E.jpg
          33 kB
        3. $7475F403A56A076E.jpg
          $7475F403A56A076E.jpg
          39 kB
        4. $77B3423DA6BCF691.jpg
          $77B3423DA6BCF691.jpg
          35 kB

        Activity

          ayappan Ayappan Perumal created issue -
          slide_o_mix Alex Earl added a comment -

          Do you have a log of a previous run that I could compare?

          slide_o_mix Alex Earl added a comment - Do you have a log of a previous run that I could compare?
          slide_o_mix Alex Earl added a comment -

          Also, please highlight the issue in the log so I know exactly what you are trying to show.

          slide_o_mix Alex Earl added a comment - Also, please highlight the issue in the log so I know exactly what you are trying to show.

          Sorry for the late response.

          If you see the first image, the "$" variables are put into the Publish over SSH plugin. But they are not getting set inside this plugin because of which no files are copied over. I am attaching the older log.

           

          ayappan Ayappan Perumal added a comment - Sorry for the late response. If you see the first image, the "$" variables are put into the Publish over SSH plugin. But they are not getting set inside this plugin because of which no files are copied over. I am attaching the older log.  
          ayappan Ayappan Perumal made changes -
          Field Original Value New Value
          Attachment $7475F403A56A076E.jpg [ 43977 ]
          slide_o_mix Alex Earl added a comment -

          I can't reproduce this. I setup an environment variable in the global config for Jenkins and also setup a parameter for the build. I used both in the remote directory and it worked just fine, the variables were expanded and the correct stuff was done. Is there a specific field that is having issues?

          slide_o_mix Alex Earl added a comment - I can't reproduce this. I setup an environment variable in the global config for Jenkins and also setup a parameter for the build. I used both in the remote directory and it worked just fine, the variables were expanded and the correct stuff was done. Is there a specific field that is having issues?
          slide_o_mix Alex Earl added a comment -

          I even tried using variables in the source files text box and that worked fine too.

          slide_o_mix Alex Earl added a comment - I even tried using variables in the source files text box and that worked fine too.
          ayappan Ayappan Perumal made changes -
          Attachment $1AAC62AC63F72136.jpg [ 44574 ]

          I tried today also. The issue is still there.

          If you see the latest attachment (image) in this Jira, $PKG (and also$REL) is defined as a string parameter in the job. 

          $COM_VER is defined under the Build step (Execute shell). 

          I hope you are trying to reproduce this with the latest plugins. 

           

           

          ayappan Ayappan Perumal added a comment - I tried today also. The issue is still there. If you see the latest attachment (image) in this Jira, $PKG (and also$REL) is defined as a string parameter in the job.  $COM_VER is defined under the Build step (Execute shell).  I hope you are trying to reproduce this with the latest plugins.     
          ayappan Ayappan Perumal made changes -
          Environment Redhat 7.3 x86 Redhat 7.4 PPC Big Endian

          Jenkins is actually running on a PPC (PowerPC) 64 bit Big Endian RHEL 7.4 machine. 

          ayappan Ayappan Perumal added a comment - Jenkins is actually running on a PPC (PowerPC) 64 bit Big Endian RHEL 7.4 machine. 
          slide_o_mix Alex Earl added a comment -

          Environment variables defined in an execute shell step will not propagate past that step. You would need to use something like EnvInject to get them back to be usable in another build step or post-build step. I don't have any access to a PPC machine, but I don't think running on that type of HW is an issue.

          slide_o_mix Alex Earl added a comment - Environment variables defined in an execute shell step will not propagate past that step. You would need to use something like EnvInject to get them back to be usable in another build step or post-build step. I don't have any access to a PPC machine, but I don't think running on that type of HW is an issue.

          Okay we can leave those variables defined in an execute shell step. But the PKG variable defined under "This project is parameterized" should be passed. But that is not happening here. 

          ayappan Ayappan Perumal added a comment - Okay we can leave those variables defined in an execute shell step. But the PKG variable defined under "This project is parameterized" should be passed. But that is not happening here. 
          slide_o_mix Alex Earl added a comment -

          I am not able to reproduce this issue. It works for me locally just fine.

          slide_o_mix Alex Earl added a comment - I am not able to reproduce this issue. It works for me locally just fine.

          Okay. I will test this in one more machine Ubuntu PPC64 Little Endian and update the status.

          ayappan Ayappan Perumal added a comment - Okay. I will test this in one more machine Ubuntu PPC64 Little Endian and update the status.
          slide_o_mix Alex Earl made changes -
          Resolution Cannot Reproduce [ 5 ]
          Status Open [ 1 ] Fixed but Unreleased [ 10203 ]

          For your information, all publish-over-ssh component type JENKINS issues related to the Publish Over SSH plugin have been transferred to Github: https://github.com/jenkinsci/publish-over-ssh-plugin/issues

          Here is the direct link to this issue in Github: https://github.com/jenkinsci/publish-over-ssh-plugin/issues/106
          And here is the link to a search for related issues: https://github.com/jenkinsci/publish-over-ssh-plugin/issues?q=%22JENKINS-52016%22

          (Note: this is an automated bulk comment)

          gmcdonald Gavin McDonald added a comment - For your information, all publish-over-ssh component type JENKINS issues related to the Publish Over SSH plugin have been transferred to Github: https://github.com/jenkinsci/publish-over-ssh-plugin/issues Here is the direct link to this issue in Github: https://github.com/jenkinsci/publish-over-ssh-plugin/issues/106 And here is the link to a search for related issues: https://github.com/jenkinsci/publish-over-ssh-plugin/issues?q=%22JENKINS-52016%22 (Note: this is an automated bulk comment)

          People

            slide_o_mix Alex Earl
            ayappan Ayappan Perumal
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: