Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-529

Exception in the configuration of the jira plugin

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Fixed
    • Component/s: plugin-proposals
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      When using the jira plugin configuration, returning to the screen I get a stack
      trace error - presumably this is stopping the plugin from working too:

      1.105, tomcat5.5.23

      javax.servlet.ServletException
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:279)
      org.kohsuke.stapler.MetaClass$9.doDispatch(MetaClass.java:240)
      org.kohsuke.stapler.NameBasedDispatcher.dispatch(NameBasedDispatcher.java:30)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:270)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:207)
      org.kohsuke.stapler.Stapler.service(Stapler.java:72)
      javax.servlet.http.HttpServlet.service(HttpServlet.java:802)

      root cause

      java.lang.NoClassDefFoundError
      org.apache.axis.client.Service.getAxisClient(Service.java:104)
      org.apache.axis.client.Service.<init>(Service.java:113)
      hudson.plugins.jira.soap.JiraSoapServiceServiceLocator.<init>(JiraSoapServiceServiceLocator.java:12)
      hudson.plugins.jira.JiraSite.createSession(JiraSite.java:67)
      hudson.plugins.jira.JiraProjectProperty$DescriptorImpl$2.check(JiraProjectProperty.java:158)
      hudson.util.FormFieldValidator.process(FormFieldValidator.java:40)
      hudson.plugins.jira.JiraProjectProperty$DescriptorImpl.doLoginCheck(JiraProjectProperty.java:147)
      sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      java.lang.reflect.Method.invoke(Method.java:585)
      org.kohsuke.stapler.Function$InstanceFunction.invoke(Function.java:95)
      org.kohsuke.stapler.Function.bindAndinvoke(Function.java:51)
      org.kohsuke.stapler.MetaClass$1.doDispatch(MetaClass.java:63)
      org.kohsuke.stapler.NameBasedDispatcher.dispatch(NameBasedDispatcher.java:30)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:270)
      org.kohsuke.stapler.MetaClass$9.doDispatch(MetaClass.java:240)
      org.kohsuke.stapler.NameBasedDispatcher.dispatch(NameBasedDispatcher.java:30)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:270)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:207)
      org.kohsuke.stapler.Stapler.service(Stapler.java:72)
      javax.servlet.http.HttpServlet.service(HttpServlet.java:802)

        Attachments

          Activity

          kohsuke Kohsuke Kawaguchi added a comment -

          This was a problem in Hudson core. Fixed in 1.106.

          bruyeron bruyeron added a comment -

          Same here: jira plugin 1.1, Hudson 1.105, JDK5 or JDK6 (I tried both) and tomcat
          5.5.20

          It was working in 1.100, it started failing when I upgraded to 1.105

          This is what happens in details:
          1) the first time the jira plugin is invoked (when one goes to the configuration
          page) Axis fails to init:
          java.lang.ExceptionInInitializerError
          org.apache.axis.handlers.BasicHandler.<clinit>(BasicHandler.java:43)
          org.apache.axis.client.Service.getAxisClient(Service.java:104)
          org.apache.axis.client.Service.<init>(Service.java:113)
          hudson.plugins.jira.soap.JiraSoapServiceServiceLocator.<init>(JiraSoapServiceServiceLocator.java:12)
          hudson.plugins.jira.JiraSite.createSession(JiraSite.java:67)
          hudson.plugins.jira.JiraProjectProperty$DescriptorImpl$2.check(JiraProjectProperty.java:158)
          hudson.util.FormFieldValidator.process(FormFieldValidator.java:40)
          hudson.plugins.jira.JiraProjectProperty$DescriptorImpl.doLoginCheck(JiraProjectProperty.java:147)
          sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
          sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
          sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
          java.lang.reflect.Method.invoke(Method.java:597)
          org.kohsuke.stapler.Function$InstanceFunction.invoke(Function.java:95)
          org.kohsuke.stapler.Function.bindAndinvoke(Function.java:51)
          org.kohsuke.stapler.MetaClass$1.doDispatch(MetaClass.java:63)
          org.kohsuke.stapler.NameBasedDispatcher.dispatch(NameBasedDispatcher.java:30)
          org.kohsuke.stapler.Stapler.invoke(Stapler.java:270)
          org.kohsuke.stapler.MetaClass$9.doDispatch(MetaClass.java:240)
          org.kohsuke.stapler.NameBasedDispatcher.dispatch(NameBasedDispatcher.java:30)
          org.kohsuke.stapler.Stapler.invoke(Stapler.java:270)
          org.kohsuke.stapler.Stapler.invoke(Stapler.java:207)
          org.kohsuke.stapler.Stapler.service(Stapler.java:72)
          javax.servlet.http.HttpServlet.service(HttpServlet.java:802)

          2) On subsequent attempts, the exception becomes:
          java.lang.NoClassDefFoundError: Could not initialize class
          org.apache.axis.client.AxisClient
          org.apache.axis.client.Service.getAxisClient(Service.java:104)
          org.apache.axis.client.Service.<init>(Service.java:113)
          hudson.plugins.jira.soap.JiraSoapServiceServiceLocator.<init>(JiraSoapServiceServiceLocator.java:12)
          hudson.plugins.jira.JiraSite.createSession(JiraSite.java:67)
          hudson.plugins.jira.JiraProjectProperty$DescriptorImpl$2.check(JiraProjectProperty.java:158)
          hudson.util.FormFieldValidator.process(FormFieldValidator.java:40)
          hudson.plugins.jira.JiraProjectProperty$DescriptorImpl.doLoginCheck(JiraProjectProperty.java:147)
          sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
          sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
          sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
          java.lang.reflect.Method.invoke(Method.java:597)
          org.kohsuke.stapler.Function$InstanceFunction.invoke(Function.java:95)
          org.kohsuke.stapler.Function.bindAndinvoke(Function.java:51)
          org.kohsuke.stapler.MetaClass$1.doDispatch(MetaClass.java:63)
          org.kohsuke.stapler.NameBasedDispatcher.dispatch(NameBasedDispatcher.java:30)
          org.kohsuke.stapler.Stapler.invoke(Stapler.java:270)
          org.kohsuke.stapler.MetaClass$9.doDispatch(MetaClass.java:240)
          org.kohsuke.stapler.NameBasedDispatcher.dispatch(NameBasedDispatcher.java:30)
          org.kohsuke.stapler.Stapler.invoke(Stapler.java:270)
          org.kohsuke.stapler.Stapler.invoke(Stapler.java:207)
          org.kohsuke.stapler.Stapler.service(Stapler.java:72)
          javax.servlet.http.HttpServlet.service(HttpServlet.java:802)

          magnayn magnayn added a comment -

          Jira plugin v1.1

          kohsuke Kohsuke Kawaguchi added a comment -

          Which version of the JIRA plugin do you use?

          magnayn magnayn added a comment -

          In tomcat 5.5.20 installed through XAMPP, I get a vaguely different error :

          HTTP Status 500 -

          type Exception report

          message

          description The server encountered an internal error () that prevented it from
          fulfilling this request.

          exception

          javax.servlet.ServletException: javax/xml/rpc/Service
          org.kohsuke.stapler.Stapler.invoke(Stapler.java:279)
          org.kohsuke.stapler.MetaClass$9.doDispatch(MetaClass.java:240)
          org.kohsuke.stapler.NameBasedDispatcher.dispatch(NameBasedDispatcher.java:30)
          org.kohsuke.stapler.Stapler.invoke(Stapler.java:270)
          org.kohsuke.stapler.Stapler.invoke(Stapler.java:207)
          org.kohsuke.stapler.Stapler.service(Stapler.java:72)
          javax.servlet.http.HttpServlet.service(HttpServlet.java:802)

          root cause

          java.lang.NoClassDefFoundError: javax/xml/rpc/Service
          java.lang.ClassLoader.defineClass1(Native Method)
          java.lang.ClassLoader.defineClass(ClassLoader.java:620)
          java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124)
          java.net.URLClassLoader.defineClass(URLClassLoader.java:260)
          java.net.URLClassLoader.access$100(URLClassLoader.java:56)
          java.net.URLClassLoader$1.run(URLClassLoader.java:195)
          java.security.AccessController.doPrivileged(Native Method)
          java.net.URLClassLoader.findClass(URLClassLoader.java:188)
          java.lang.ClassLoader.loadClass(ClassLoader.java:306)
          java.lang.ClassLoader.loadClass(ClassLoader.java:299)
          java.lang.ClassLoader.loadClass(ClassLoader.java:251)
          org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1342)
          java.lang.ClassLoader.loadClass(ClassLoader.java:299)
          java.lang.ClassLoader.loadClass(ClassLoader.java:299)
          java.lang.ClassLoader.loadClass(ClassLoader.java:251)
          java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)
          java.lang.ClassLoader.defineClass1(Native Method)
          java.lang.ClassLoader.defineClass(ClassLoader.java:620)
          java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124)
          java.net.URLClassLoader.defineClass(URLClassLoader.java:260)
          java.net.URLClassLoader.access$100(URLClassLoader.java:56)
          java.net.URLClassLoader$1.run(URLClassLoader.java:195)
          java.security.AccessController.doPrivileged(Native Method)
          java.net.URLClassLoader.findClass(URLClassLoader.java:188)
          java.lang.ClassLoader.loadClass(ClassLoader.java:306)
          java.lang.ClassLoader.loadClass(ClassLoader.java:251)
          java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)
          hudson.plugins.jira.JiraSite.createSession(JiraSite.java:67)
          hudson.plugins.jira.JiraProjectProperty$DescriptorImpl$2.check(JiraProjectProperty.java:158)
          hudson.util.FormFieldValidator.process(FormFieldValidator.java:40)
          hudson.plugins.jira.JiraProjectProperty$DescriptorImpl.doLoginCheck(JiraProjectProperty.java:147)
          sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
          sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
          sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
          java.lang.reflect.Method.invoke(Method.java:585)
          org.kohsuke.stapler.Function$InstanceFunction.invoke(Function.java:95)
          org.kohsuke.stapler.Function.bindAndinvoke(Function.java:51)
          org.kohsuke.stapler.MetaClass$1.doDispatch(MetaClass.java:63)
          org.kohsuke.stapler.NameBasedDispatcher.dispatch(NameBasedDispatcher.java:30)
          org.kohsuke.stapler.Stapler.invoke(Stapler.java:270)
          org.kohsuke.stapler.MetaClass$9.doDispatch(MetaClass.java:240)
          org.kohsuke.stapler.NameBasedDispatcher.dispatch(NameBasedDispatcher.java:30)
          org.kohsuke.stapler.Stapler.invoke(Stapler.java:270)
          org.kohsuke.stapler.Stapler.invoke(Stapler.java:207)
          org.kohsuke.stapler.Stapler.service(Stapler.java:72)
          javax.servlet.http.HttpServlet.service(HttpServlet.java:802)


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            magnayn magnayn
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: