Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-5305

Backup Plugin: cannot use tar in windows

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: backup-plugin
    • Labels:
      None
    • Environment:
      Windows XP Professional
    • Similar Issues:

      Description

      when using tar.gz or tar.bz2 on Windows I get an ArchiverException/IOException: "Request to write '3020 bytes' exceeds size in header of '330623' " Zip works fine though.

        Attachments

          Issue Links

            Activity

            calid calid created issue -
            aknuds1 Arve Knudsen made changes -
            Field Original Value New Value
            Link This issue is duplicated by JENKINS-6578 [ JENKINS-6578 ]
            rseguy Romain Seguy added a comment -

            Known issue: tar.gz archives can be used only on Unix, not on Windows.

            rseguy Romain Seguy made changes -
            Component/s backup [ 15696 ]
            Component/s plugin [ 15491 ]
            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in hudson
            User: : rseguy
            Path:
            trunk/hudson/plugins/backup/src/main/java/org/jvnet/hudson/plugins/backup/BackupLink.java
            trunk/hudson/plugins/backup/src/main/java/org/jvnet/hudson/plugins/backup/utils/compress/CompressionMethodEnum.java
            http://jenkins-ci.org/commit/31204
            Log:
            [FIXED JENKINS-5305]

            scm_issue_link SCM/JIRA link daemon made changes -
            Resolution Fixed [ 1 ]
            Status Open [ 1 ] Resolved [ 5 ]
            rseguy Romain Seguy made changes -
            Assignee rseguy [ rseguy ]
            rseguy Romain Seguy made changes -
            Status Resolved [ 5 ] Closed [ 6 ]
            ssbarnea Sorin Sbarnea added a comment -

            I do get the same error on OS X, so this is not Windows specific.

            [ INFO] Backup started at [09/30/10 10:03:58]
            [ INFO] Setting hudson in shutdown mode to avoid files corruptions.
            [ INFO] Waiting all jobs end...
            [ INFO] Number of running jobs detected : 0
            [ INFO] All jobs finished.
            [ INFO] Full backup file name : /var/root/.hudson-bkp/backup_20100930_1003.tar.gz
            [ERROR] org.codehaus.plexus.archiver.ArchiverException: Problem creating TAR: request to write '1422' bytes exceeds size in header of '68' bytes
            org.jvnet.hudson.plugins.backup.BackupException: java.io.IOException: org.codehaus.plexus.archiver.ArchiverException: Problem creating TAR: request to write '1422' bytes exceeds size in header of '68' bytes
            at org.jvnet.hudson.plugins.backup.utils.BackupEngine.doBackup(BackupEngine.java:115)
            at org.jvnet.hudson.plugins.backup.utils.BackupTask.run(BackupTask.java:125)
            at java.lang.Thread.run(Thread.java:637)
            Caused by: java.io.IOException: org.codehaus.plexus.archiver.ArchiverException: Problem creating TAR: request to write '1422' bytes exceeds size in header of '68' bytes
            at org.jvnet.hudson.plugins.backup.utils.BackupEngine.handleEnd(BackupEngine.java:104)
            at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:336)
            at org.jvnet.hudson.plugins.backup.utils.BackupEngine.doBackup(BackupEngine.java:113)
            ... 2 more
            [ INFO] Cancel hudson shutdown mode
            [ INFO] Backup end at [09/30/10 10:18:34]
            [ INFO] [875.497s]

            ssbarnea Sorin Sbarnea made changes -
            Resolution Fixed [ 1 ]
            Status Closed [ 6 ] Reopened [ 4 ]
            rseguy Romain Seguy added a comment -

            JENKINS-8282 created to handle the bug for OS X.

            rseguy Romain Seguy made changes -
            Resolution Fixed [ 1 ]
            Status Reopened [ 4 ] Closed [ 6 ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 135394 ] JNJira + In-Review [ 203456 ]

              People

              Assignee:
              rseguy Romain Seguy
              Reporter:
              calid calid
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: