Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-53285

Update plugins used in Evergreen to remove "Created .../WEB-INF/lib/classes.jar; update plugin to a version created with a newer harness" messages

    XMLWordPrintable

Details

    • Evergreen - Milestone 1

    Description

      Issue

      We get a bunch of WARNINGs back to Sentry backend for Evergreen.

      Typical message:

      Created /evergreen/jenkins/var/plugins/authentication-tokens/WEB-INF/lib/classes.jar; update plugin to a version created with a newer harness
      // or
      Created /evergreen/jenkins/var/plugins/conditional-buildstep/WEB-INF/lib/classes.jar; update plugin to a version created with a newer harness
      ...
      

      Expected

      We should probably make a pass to either update to last versions that might already be fixed, or propose patches around to have this cleaned up.

      list of plugins suffering from this visible through Sentry

      • authentication-tokens
      • conditional-buildstep
      • icon-shim
      • javadoc
      • jsch
      • mapdb-api
      • maven-plugin
      • node-iterator-api
      • run-condition

      Attachments

        Issue Links

          Activity

            batmat Baptiste Mathus created issue -
            batmat Baptiste Mathus made changes -
            Field Original Value New Value
            Sprint Evergreen - Milestone 1 [ 511 ]
            batmat Baptiste Mathus made changes -
            Description h3. Issue

            We get a bunch of WARNINGs back to Sentry backend for Evergreen.

            Typical message:

            {noformat}
            Created /evergreen/jenkins/var/plugins/authentication-tokens/WEB-INF/lib/classes.jar; update plugin to a version created with a newer harness
            // or
            Created /evergreen/jenkins/var/plugins/conditional-buildstep/WEB-INF/lib/classes.jar; update plugin to a version created with a newer harness
            ...
            {noformat}

            We should probably make a pass to either update to last versions that might already be fixed, or propose patches around to have this cleaned up.
            h3. Issue

            We get a bunch of WARNINGs back to Sentry backend for Evergreen.

            Typical message:

            {noformat}
            Created /evergreen/jenkins/var/plugins/authentication-tokens/WEB-INF/lib/classes.jar; update plugin to a version created with a newer harness
            // or
            Created /evergreen/jenkins/var/plugins/conditional-buildstep/WEB-INF/lib/classes.jar; update plugin to a version created with a newer harness
            ...
            {noformat}

            h3. Expected

            We should probably make a pass to either update to last versions that might already be fixed, or propose patches around to have this cleaned up.

            h3. list of plugins visible through Sentry
            batmat Baptiste Mathus made changes -
            Labels evergreen-triggered evergreen evergreen-triggered sentry
            batmat Baptiste Mathus made changes -
            Description h3. Issue

            We get a bunch of WARNINGs back to Sentry backend for Evergreen.

            Typical message:

            {noformat}
            Created /evergreen/jenkins/var/plugins/authentication-tokens/WEB-INF/lib/classes.jar; update plugin to a version created with a newer harness
            // or
            Created /evergreen/jenkins/var/plugins/conditional-buildstep/WEB-INF/lib/classes.jar; update plugin to a version created with a newer harness
            ...
            {noformat}

            h3. Expected

            We should probably make a pass to either update to last versions that might already be fixed, or propose patches around to have this cleaned up.

            h3. list of plugins visible through Sentry
            h3. Issue

            We get a bunch of WARNINGs back to Sentry backend for Evergreen.

            Typical message:

            {noformat}
            Created /evergreen/jenkins/var/plugins/authentication-tokens/WEB-INF/lib/classes.jar; update plugin to a version created with a newer harness
            // or
            Created /evergreen/jenkins/var/plugins/conditional-buildstep/WEB-INF/lib/classes.jar; update plugin to a version created with a newer harness
            ...
            {noformat}

            h3. Expected

            We should probably make a pass to either update to last versions that might already be fixed, or propose patches around to have this cleaned up.

            h3. list of plugins suffering from this visible through Sentry

            * authentication-tokens
            * conditional-buildstep
            * icon-shim
            * javadoc
            * jsch
            * mapdb-api
            * maven-plugin
            * node-iterator-api
            * run-condition
            batmat Baptiste Mathus made changes -
            Link This issue relates to JENKINS-53251 [ JENKINS-53251 ]
            rtyler R. Tyler Croy made changes -
            Issue Type Epic [ 10001 ] Bug [ 1 ]
            batmat Baptiste Mathus made changes -
            Remote Link This issue links to "evergreen PR to update most plugins (Web Link)" [ 21407 ]
            batmat Baptiste Mathus made changes -
            Resolution Fixed [ 1 ]
            Status Open [ 1 ] Resolved [ 5 ]
            batmat Baptiste Mathus made changes -
            Assignee R. Tyler Croy [ rtyler ] Baptiste Mathus [ batmat ]
            batmat Baptiste Mathus made changes -
            Remote Link This issue links to "ec2 plugin PR (Web Link)" [ 21410 ]

            People

              batmat Baptiste Mathus
              batmat Baptiste Mathus
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: