Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-5344

checkstyle report calculator show difference between identical builds

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Cannot Reproduce
    • checkstyle-plugin
    • None
    • olaris 10,Glassfish v2, hudson 1.336, checkstyle 3.0

    Description

      have started two builds after each other. The source and build configuration has not changed yet checksytle reported changes in the issues.

      first build reported:

      Checkstyle: 72,184 warnings in 37 Checkstyle files.

      • 72,184 new warnings

      Second build reported:
      Checkstyle: 72,184 warnings in 37 Checkstyle files.

      • 243 new warnings
      • 196 fixed warnings

      third build
      Checkstyle: 72,184 warnings in 37 Checkstyle files.

      • 255 new warnings
      • 197 fixed warnings
        4. build:
        Checkstyle: 72,184 warnings in 37 Checkstyle files.
      • 170 new warnings
      • 193 fixed warnings

      Maybe it is related to JENKINS-2968 & JENKINS-5341 ?

      Attachments

        Issue Links

          Activity

            lynggaard lynggaard created issue -
            drulli Ulli Hafner added a comment -

            Colud you please add an example of the warning that has been reported as new?

            drulli Ulli Hafner added a comment - Colud you please add an example of the warning that has been reported as new?
            drulli Ulli Hafner made changes -
            Field Original Value New Value
            Link This issue depends on JENKINS-5147 [ JENKINS-5147 ]
            nick_stolwijk nick_stolwijk added a comment -

            I have the same issue on multiple warnings, ie

            First build:
            <warning>
            <message>Missing a Javadoc comment.</message>
            <priority>NORMAL</priority>
            <key>436</key>
            <lineRanges>
            <range>
            <start>14</start>
            <end>14</end>
            </range>
            </lineRanges>
            <primaryLineNumber>14</primaryLineNumber>
            <fileName>/svr/hudson-data/jobs/*****.java</fileName>
            <moduleName>***** web-archive</moduleName>
            <packageName>*****</packageName>
            <category>Javadoc</category>
            <type>JavadocMethodCheck</type>
            <contextHashCode>-1131232024</contextHashCode>
            <origin>checkstyle</origin>
            </warning>

            Second build:
            <warning>
            <message>Missing a Javadoc comment.</message>
            <priority>NORMAL</priority>
            <key>440</key>
            <lineRanges>
            <range>
            <start>14</start>
            <end>14</end>
            </range>
            </lineRanges>
            <primaryLineNumber>14</primaryLineNumber>
            <fileName>/svr/hudson-data/jobs/*****.java</fileName>
            <moduleName>***** web-archive</moduleName>
            <packageName>*****</packageName>
            <category>Javadoc</category>
            <type>JavadocMethodCheck</type>
            <contextHashCode>-1131232024</contextHashCode>
            <origin>checkstyle</origin>
            </warning>

            nick_stolwijk nick_stolwijk added a comment - I have the same issue on multiple warnings, ie First build: <warning> <message>Missing a Javadoc comment.</message> <priority>NORMAL</priority> <key>436</key> <lineRanges> <range> <start>14</start> <end>14</end> </range> </lineRanges> <primaryLineNumber>14</primaryLineNumber> <fileName>/svr/hudson-data/jobs/*****.java</fileName> <moduleName>***** web-archive</moduleName> <packageName>*****</packageName> <category>Javadoc</category> <type>JavadocMethodCheck</type> <contextHashCode>-1131232024</contextHashCode> <origin>checkstyle</origin> </warning> Second build: <warning> <message>Missing a Javadoc comment.</message> <priority>NORMAL</priority> <key>440</key> <lineRanges> <range> <start>14</start> <end>14</end> </range> </lineRanges> <primaryLineNumber>14</primaryLineNumber> <fileName>/svr/hudson-data/jobs/*****.java</fileName> <moduleName>***** web-archive</moduleName> <packageName>*****</packageName> <category>Javadoc</category> <type>JavadocMethodCheck</type> <contextHashCode>-1131232024</contextHashCode> <origin>checkstyle</origin> </warning>

            Code changed in hudson
            User: : drulli
            Path:
            trunk/hudson/plugins/checkstyle/src/test/java/hudson/plugins/checkstyle/parser/WarningsDifferencerTest.java
            http://jenkins-ci.org/commit/28596
            Log:
            JENKINS-5344 Added unit test to verify bug.

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in hudson User: : drulli Path: trunk/hudson/plugins/checkstyle/src/test/java/hudson/plugins/checkstyle/parser/WarningsDifferencerTest.java http://jenkins-ci.org/commit/28596 Log: JENKINS-5344 Added unit test to verify bug.
            drulli Ulli Hafner added a comment -

            Hmm, my unit test did not reproduce the bug. Could you please check if the filename is the same in both warnings? Maybe Hudson uses different paths to checkout the files...

            drulli Ulli Hafner added a comment - Hmm, my unit test did not reproduce the bug. Could you please check if the filename is the same in both warnings? Maybe Hudson uses different paths to checkout the files...
            drulli Ulli Hafner added a comment -

            Please reopen if this occurs still in the latest version.

            drulli Ulli Hafner added a comment - Please reopen if this occurs still in the latest version.
            drulli Ulli Hafner made changes -
            Resolution Cannot Reproduce [ 5 ]
            Status Open [ 1 ] Closed [ 6 ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 135433 ] JNJira + In-Review [ 203478 ]

            People

              drulli Ulli Hafner
              lynggaard lynggaard
              Votes:
              1 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: