Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-54261

Submit ( go ) on Email Template Testing produces blank screen

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      Jenkins 2.148 

      Email Template Testing broken - results from submit immediately replaced with blank screen 

      Rollback to Jenkins 2.147 fixes issue.

      Nothing to do with the emailext-template-plugin - no new version, works on jenkins 2.147

      Possibly due to change for :

      -> Make form submit buttons on the Jenkins classic UI compatible with potentially upcoming Firefox bug fix. (issue 53462, Firefox bug 1370630)

        Attachments

          Issue Links

            Activity

            sgjenkins Steve Graham created issue -
            sgjenkins Steve Graham made changes -
            Field Original Value New Value
            Description Jenkins 2.148 

            Email Template Testing broken - results immediately replaced with blank screen 

            Rollback to Jenkins 2.147 fixes issue.

            Possibly due to change for :

            -> Make form submit buttons on the Jenkins classic UI compatible with potentially upcoming Firefox bug fix. (issue 53462, [Firefox bug 1370630|https://bugzilla.mozilla.org/show_bug.cgi?id=1370630])
            sgjenkins Steve Graham made changes -
            Description Jenkins 2.148 

            Email Template Testing broken - results immediately replaced with blank screen 

            Rollback to Jenkins 2.147 fixes issue.

            Possibly due to change for :

            -> Make form submit buttons on the Jenkins classic UI compatible with potentially upcoming Firefox bug fix. (issue 53462, [Firefox bug 1370630|https://bugzilla.mozilla.org/show_bug.cgi?id=1370630])
            Jenkins 2.148 

            Email Template Testing broken - results from submit immediately replaced with blank screen 

            Rollback to Jenkins 2.147 fixes issue.

            Possibly due to change for :

            -> Make form submit buttons on the Jenkins classic UI compatible with potentially upcoming Firefox bug fix. (issue 53462, [Firefox bug 1370630|https://bugzilla.mozilla.org/show_bug.cgi?id=1370630])
            sgjenkins Steve Graham made changes -
            Summary GO on Email Template Testing produces blank screen Submit ( go ) on Email Template Testing produces blank screen
            sgjenkins Steve Graham made changes -
            Description Jenkins 2.148 

            Email Template Testing broken - results from submit immediately replaced with blank screen 

            Rollback to Jenkins 2.147 fixes issue.

            Possibly due to change for :

            -> Make form submit buttons on the Jenkins classic UI compatible with potentially upcoming Firefox bug fix. (issue 53462, [Firefox bug 1370630|https://bugzilla.mozilla.org/show_bug.cgi?id=1370630])
            Jenkins 2.148 

            Email Template Testing broken - results from submit immediately replaced with blank screen 

            Rollback to Jenkins 2.147 fixes issue.

            Nothing to do with the emailext-template-plugin - no new version, works on jenkins 2.147

            Possibly due to change for :

            -> Make form submit buttons on the Jenkins classic UI compatible with potentially upcoming Firefox bug fix. (issue 53462, [Firefox bug 1370630|https://bugzilla.mozilla.org/show_bug.cgi?id=1370630])
            sgjenkins Steve Graham made changes -
            Component/s core [ 15593 ]
            Component/s emailext-template-plugin [ 18764 ]
            slide_o_mix Alex Earl made changes -
            Assignee Alex Earl [ slide_o_mix ]
            slide_o_mix Alex Earl made changes -
            Component/s email-ext-plugin [ 15538 ]
            slide_o_mix Alex Earl made changes -
            Assignee David van Laatum [ davidvanlaatum ]
            slide_o_mix Alex Earl added a comment -

            This may be related to the onSubmit being used on the form in the template testing.

            oleg_nenashev Oleg Nenashev made changes -
            Labels regression
            oleg_nenashev Oleg Nenashev added a comment -
            danielbeck Daniel Beck added a comment -

            AFAIUI this affects https://github.com/jenkinsci/email-ext-plugin/blob/ae7e04dcb716f19489e61f3558432c3478a13d95/src/main/resources/hudson/plugins/emailext/EmailExtTemplateAction/index.groovy

            Steps to reproduce should be something like:

            1. Create a (freestyle) job
            2. Define an Editable Email notification
            3. Save
            4. Select "Email Template Testing" (or similar) in the sidepanel

            Thorsten Scherler Could you please take a look? Would not be surprised if this is the "else" block in your JS.

            tscherler Thorsten Scherler added a comment -

            Daniel Beck I am using Jenkins ver. 2.150-SNAPSHOT and are not able to reproduce the bug.

            annetheagile AnneTheAgile added a comment - - edited

            Daniel Beck for Repro steps, what do you use to setup the answers to the Template test, ie

            Jelly/Groovy Template File Name
            Build To Test

            I haven't used this feature before but I love EmailExt, so I'm checking whether I would have a problem with upgrade.

            //update; where I am now I'm not using custom templates, so I think it doesn't apply.

            References

            1. https://stackoverflow.com/questions/27493574/configuring-content-for-editable-email-notification-jenkins
            2. this ticket made after change for security ; https://jenkins.io/security/advisory/2018-09-25/#SECURITY-1125
            tscherler Thorsten Scherler made changes -
            Attachment Screenshot_2018-10-30_18-31-32.png [ 44917 ]
            tscherler Thorsten Scherler added a comment -

            In my test with the setup described from Daniel it works fine.

            f.entry {
              f.submit(value: _("Go!"))
            }
            

            Will render (as it is my understanding) a <input type="submit" /> and then get patched from hudson-behaviour (as can be seen in the attached screenshot).

            danielbeck Daniel Beck added a comment -

            Thorsten Scherler Are you using Chrome/IE?

            danielbeck Daniel Beck added a comment -

            Steve Graham Could you explain in some more detail how this can be reproduced?

            sgjenkins Steve Graham added a comment - - edited

            Exactly as you described above but with an existing job,

            1. Select Email Template Testing from the side panel
            2. Enter the Jelly/Groovy Template File Name
            3. Select a build ( or use the default already selected ) 
            4. Hit Go

            with 2.147 the results of the template can be seen.

            with 2.148 the results are visible for a millisecond then the Template File Name field is empty and the results are no longer visible.

            ( it does not matter if Auto Refresh is enabled or not, the results are the same ) 

            I'll try it on 2.150 ..

             ... exactly the same results

            • also happens with a new freestyle project
            danielbeck Daniel Beck made changes -
            Link This issue is related to JENKINS-53462 [ JENKINS-53462 ]
            tscherler Thorsten Scherler added a comment -

            I created a branch for testing reasons https://github.com/jenkinsci/jenkins/compare/master...scherler:JENKINS-54333?expand=1 can someone who is able to reproduce the bug test with that in place?

            danielbeck Daniel Beck added a comment -

            New proposed fix in https://github.com/jenkinsci/jenkins/pull/3761, would appreciate if anyone affected by this could test the PR build once it's available.

            sgjenkins Steve Graham added a comment -

            I can test at any time if you let me know how - bit naive here. I normally just download the new war files and updated plugins.

            danielbeck Daniel Beck added a comment - - edited

            https://repo.jenkins-ci.org/incrementals/org/jenkins-ci/main/jenkins-war/2.152-rc27510.acc4eec688a0/ has the jenkins.war for this PR, which currently is 2.151 + the specific change. (Plus a bunch of irrelevant version information in the file name)

            sgjenkins Steve Graham added a comment -

            Jenkins ver. 2.152-rc27510.acc4eec688a0  

            works !! 

            Excellent - Thanks.

            sgjenkins Steve Graham added a comment -

            also fixed in standard release 2.152

            slide_o_mix Alex Earl added a comment -

            This was fixed in Jenkins 2.152

            slide_o_mix Alex Earl made changes -
            Resolution Fixed [ 1 ]
            Status Open [ 1 ] Closed [ 6 ]

              People

              Assignee:
              davidvanlaatum David van Laatum
              Reporter:
              sgjenkins Steve Graham
              Votes:
              1 Vote for this issue
              Watchers:
              6 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: