Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-54854

Warning when trigger spent to much time in a cron execution

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Similar Issues:
    • Released As:
      Jenkins 2.189

      Description

      It would be nice make a warning to a log when Trigger spends too much time in Cron trigger.

      It ssually means a malfunction or other issue in a plug-in and timers initiated by defined crontab(s) aren't working correctly (at least when expected). Given Jenkins cron task design, trigger taking more than 60 seconds to complete can prevent task scheduled for the next minute to run on time.

        Attachments

          Issue Links

            Activity

            pajasoft Pavel Janoušek created issue -
            pajasoft Pavel Janoušek made changes -
            Field Original Value New Value
            Summary Warning when trigger spent to much time in cron execution Warning when trigger spent to much time in a cron execution
            pajasoft Pavel Janoušek made changes -
            Description It would be nice to warning to a log when {{Trigger}} spends too much time in Cron trigger.

            It ssually means a malfunction or other issue in a plug-in and timers initiated by defined crontab(s) aren't working correctly (at least when expected).
            It would be nice make a warning to a log when {{Trigger}} spends too much time in Cron trigger.

            It ssually means a malfunction or other issue in a plug-in and timers initiated by defined crontab(s) aren't working correctly (at least when expected).
            pajasoft Pavel Janoušek made changes -
            Status Open [ 1 ] In Progress [ 3 ]
            pajasoft Pavel Janoušek made changes -
            Status In Progress [ 3 ] In Review [ 10005 ]
            pajasoft Pavel Janoušek added a comment -

            PR sent.

            pajasoft Pavel Janoušek made changes -
            Remote Link This issue links to "PR (Web Link)" [ 22097 ]
            olivergondza Oliver Gondža made changes -
            Description It would be nice make a warning to a log when {{Trigger}} spends too much time in Cron trigger.

            It ssually means a malfunction or other issue in a plug-in and timers initiated by defined crontab(s) aren't working correctly (at least when expected).
            It would be nice make a warning to a log when {{Trigger}} spends too much time in Cron trigger.

            It ssually means a malfunction or other issue in a plug-in and timers initiated by defined crontab(s) aren't working correctly (at least when expected). Given Jenkins cron task design, trigger taking more than 60 seconds to complete can prevent task scheduled for the next minute to run on time.
            danielbeck Daniel Beck added a comment -

            "Cron is not working", often caused by Bitbucket doing networking in the trigger, is a pretty regular complaint, so

             

            olivergondza Oliver Gondža made changes -
            Link This issue relates to JENKINS-19123 [ JENKINS-19123 ]
            oleg_nenashev Oleg Nenashev made changes -
            Released As Jenkins 2.189
            Resolution Fixed [ 1 ]
            Status In Review [ 10005 ] Resolved [ 5 ]
            oleg_nenashev Oleg Nenashev made changes -
            Status Resolved [ 5 ] Fixed but Unreleased [ 10203 ]
            oleg_nenashev Oleg Nenashev made changes -
            Status Fixed but Unreleased [ 10203 ] Resolved [ 5 ]

              People

              Assignee:
              pajasoft Pavel Janoušek
              Reporter:
              pajasoft Pavel Janoušek
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: