This is the preferred style:
As opposed to:
I'm going to point to this issue for a bunch of plugins.
Note: my initial efforts relied on using optionalBlock instead of entry + checkbox. Unfortunately this interacts poorly w/ the form submission magic, and so rather than continue down that path, I'm switching to moving label's from the entry to the checkbox. The rendering won't generally change from the examples above.
Please don't close this ticket when an individual PR is merged, I'm using the same ticket for many plugins.