Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-5606

gcc warnings parser ignores errors in files having an uncommon extension

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Fixed
    • warnings-plugin
    • None
    • using hudson 1.345 on ubuntu karmic

    Description

      The gcc warnings parser just ignores errors happening in files that have uncommon extensions.
      In our project we put C++ template implementations in .inl files, but errors insides these files will just get ignored.
      The regular expression that parses messages seems to be rather restrictive about file extensions.
      I think of one other extension for template implementation that is probably not supported: ".tpp".
      Moreover, if an error is raised when instanciating a C++ standard library class, it will probably not be reported by the plugin because these headers do not have extension.
      Maybe it would be better to make extension optional and allow any characters.
      I joined a piece of build log exposing the problem with .inl files.

      Attachments

        Issue Links

          Activity

            Code changed in hudson
            User: : drulli
            Path:
            trunk/hudson/plugins/warnings/src/test/java/hudson/plugins/warnings/parser/Gcc4CompilerParserTest.java
            trunk/hudson/plugins/warnings/src/test/resources/hudson/plugins/warnings/parser/issue5606.txt
            http://jenkins-ci.org/commit/29241
            Log:
            JENKINS-5606 Added test case.

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in hudson User: : drulli Path: trunk/hudson/plugins/warnings/src/test/java/hudson/plugins/warnings/parser/Gcc4CompilerParserTest.java trunk/hudson/plugins/warnings/src/test/resources/hudson/plugins/warnings/parser/issue5606.txt http://jenkins-ci.org/commit/29241 Log: JENKINS-5606 Added test case.
            drulli Ulli Hafner added a comment -

            Please use the new GCC 4 parser.

            drulli Ulli Hafner added a comment - Please use the new GCC 4 parser.

            People

              drulli Ulli Hafner
              fchateau fchateau
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: