Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-57207

Azure VM agents still provision when Jenkins is "preparing for shutdown"

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Duplicate
    • Component/s: _unsorted
    • Labels:
      None
    • Similar Issues:

      Description

      With the latest version of Jenkins and the plugin on ci.jenkins.io, I noticed today that even when the master is "preparing to shutdown" (i.e. the queue is in read-only mode, etc), the Azure VM Agents plugin continues to provision Azure agents.

      I would expect that "preparing for shutdown" would cause the agents not to provision

        Attachments

          Activity

          jieshe Jie Shen added a comment -

          How can I reproduce this issue or how to detect the "preparing to shutdown" status of the master?

          rtyler R. Tyler Croy added a comment -

          I'm not entirely sure what good reproduction case would be, since I encountered this issue when:

          • An Azure server side error (maximum deployments for quota) caused provisioning of agents to fail.
          • I put Jenkins in "Prepare for Shutdown" mode
          • I deleted deployments in Azure, allowing new deployments to be created.

          It might be reproducible if you disconnected a master from the network, so that it couldn't reach an Azure API. Then triggered a pipeline which would cause a VM to provision. Then once the plugin starts to try to provision, put the master in shutdown mode, and reconnect the network.

          Just a thought, but definitely a tricky failure to reproduce

          timja Tim Jacomb added a comment -

          All issues have been transferred to GitHub.

          See https://github.com/jenkinsci/azure-vm-agents-plugin/issues

          Search the issue title to find it.

          (This is a bulk comment and can't link to the specific issue)


            People

            Assignee:
            jieshe Jie Shen
            Reporter:
            rtyler R. Tyler Croy
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: