Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-57304

Multiple "idle" entries on Build Executor Status for non-existant executors

    XMLWordPrintable

    Details

    • Similar Issues:
    • Released As:
      Jenkins 2.208

      Description

      We have a jenkins environment where we have a single server with multiple executors (4). Sometimes the display has multiple idles, even though all executors are in use:

        Attachments

          Issue Links

            Activity

            drugcrazed Patrick Rose created issue -
            oleg_nenashev Oleg Nenashev added a comment -

            It is for flyweight executors, I believe (e.g. for Pipeline). They may be indicated as idle in Web UI for a while.

            Do they disappear automatically after some time?

            drugcrazed Patrick Rose added a comment -

            I've just checked again now - there's still the same number of extra idles. I can check again tomorrow morning?

            oleg_nenashev Oleg Nenashev added a comment -

            No, it should be about minutes to deprovision them.

            Which version of Jenkins have you been using before the upgrade?

            oleg_nenashev Oleg Nenashev made changes -
            Field Original Value New Value
            Labels regression
            drugcrazed Patrick Rose added a comment -

            2.174. I think we have had this happen before as well, but I'm not 100%.

            drugcrazed Patrick Rose added a comment -

            It looks like they've gone now (and we're updated to 1.746). I don't know whether it was fixed by the upgrade or the fact that the system would have been rebooted.

            May as well close this unless you can think of a reason to keep it open?

            oleg_nenashev Oleg Nenashev added a comment -

            Fine with me. OTOH I do not see any patch which would fix the problem in the recent releases

            initialzero Marc Benstein added a comment -

            I'm seeing this same behavior after updating to 2.176.1. They do not seem to be disappearing automatically.

            spalani Senthilkumar Palanisamy made changes -
            Attachment screenshot-1.png [ 48369 ]
            spalani Senthilkumar Palanisamy added a comment -

            Hi Team,

            We are also seeing the same behavior listing more number of executor and using Jenkins version 2.176.2 recently upgraded.

            Seeing same in chrome and firefox.

            pfarag Pavly Farag made changes -
            Attachment image-2019-09-24-14-41-25-787.png [ 48855 ]
            pfarag Pavly Farag added a comment -

            Hi Team,

            We are also having the same bahavior listing lot of idle executors only for master whenever master executor is set to 0.

            and it keeps increasing with time.. for now it reached 112 lines, we are using Jenkins 2.189

            valencia Valencia Serrao added a comment -

            Hi All,

            We are also seeing the same issue since the last 3-4 days. Current Jenkins version 2.176.2. 

            Any pointers on this issue ?

             

            baychris Chris Bayliss made changes -
            baychris Chris Bayliss added a comment - - edited

            I am seeing the same issue in Jenkins version 2.190.1 We are running one master and all our builds are pipeline builds. 

            baychris Chris Bayliss made changes -
            oleg_nenashev Oleg Nenashev added a comment -
            mramonleon Ramon Leon made changes -
            Labels regression lts-candidate regression
            mramonleon Ramon Leon made changes -
            Assignee Ramon Leon [ mramonleon ]
            mramonleon Ramon Leon added a comment -

            Assigned to me to keep track of it and added the lts-candidate as the PR seems to fix a bunch of tickets.

            mramonleon Ramon Leon made changes -
            Status Open [ 1 ] In Progress [ 3 ]
            mramonleon Ramon Leon made changes -
            Status In Progress [ 3 ] In Review [ 10005 ]
            batmat Baptiste Mathus made changes -
            Remote Link This issue links to "PR (Web Link)" [ 24033 ]
            batmat Baptiste Mathus made changes -
            Priority Trivial [ 5 ] Major [ 3 ]
            batmat Baptiste Mathus made changes -
            Resolution Fixed [ 1 ]
            Status In Review [ 10005 ] Fixed but Unreleased [ 10203 ]
            batmat Baptiste Mathus made changes -
            Released As (towards) 2.208
            olivergondza Oliver Gondža made changes -
            Labels lts-candidate regression 2.204.1-rejected lts-candidate regression
            ianw Ian Williams added a comment -

            See also: JENKINS-60348

            mramonleon Ramon Leon made changes -
            Link This issue is related to JENKINS-60348 [ JENKINS-60348 ]
            mramonleon Ramon Leon made changes -
            Link This issue is related to JENKINS-55811 [ JENKINS-55811 ]
            mramonleon Ramon Leon made changes -
            Link This issue is related to JENKINS-55484 [ JENKINS-55484 ]
            oleg_nenashev Oleg Nenashev added a comment -

            Released in 2.208

            oleg_nenashev Oleg Nenashev made changes -
            Released As (towards) 2.208 Jenkins 2.208
            Status Fixed but Unreleased [ 10203 ] Resolved [ 5 ]
            oleg_nenashev Oleg Nenashev made changes -
            Link This issue is duplicated by JENKINS-55811 [ JENKINS-55811 ]
            oleg_nenashev Oleg Nenashev made changes -
            Link This issue is duplicated by JENKINS-55484 [ JENKINS-55484 ]
            recampbell Ryan Campbell made changes -
            Link This issue relates to JENKINS-53158 [ JENKINS-53158 ]
            danielbeck Daniel Beck made changes -
            Released As Jenkins 2.208 Jenkins 2.208
            olivergondza Oliver Gondža made changes -
            Labels 2.204.1-rejected lts-candidate regression 2.204.1-rejected 2.204.2-fixed regression

              People

              Assignee:
              mramonleon Ramon Leon
              Reporter:
              drugcrazed Patrick Rose
              Votes:
              6 Vote for this issue
              Watchers:
              15 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: