Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-57448

excludeMessage does not work with single quotes

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Cannot Reproduce
    • Component/s: analysis-model
    • Labels:
      None
    • Environment:
      Version 5.0.1
    • Similar Issues:

      Description

      For an output like this

      [WARNING] 'tools.jar' was not found, kapt may work unreliably
      

      the following exclude Filter does not work
      excludeMessage("'tools.jar' was not found, kapt may work unreliably")

      but this works:
      excludeMessage('was not found, kapt may work unreliably'),

      So there is a problem with single quotes inside filter messages

        Attachments

          Activity

          reitzmichnicht Michael Düsterhus created issue -
          reitzmichnicht Michael Düsterhus made changes -
          Field Original Value New Value
          Description For an output like this the following exclude Filter does not work
          {noformat}
          [WARNING] 'tools.jar' was not found, kapt may work unreliably
          {noformat}

          excludeMessage("'tools.jar' was not found, kapt may work unreliably")
          but this works:
          excludeMessage('was not found, kapt may work unreliably'),

          So there is a problem with single quotes inside filter messages
          For an output like this
          {noformat}
          [WARNING] 'tools.jar' was not found, kapt may work unreliably
          {noformat}

          the following exclude Filter does not work
          excludeMessage("'tools.jar' was not found, kapt may work unreliably")

          but this works:
          excludeMessage('was not found, kapt may work unreliably'),

          So there is a problem with single quotes inside filter messages
          drulli Ulli Hafner added a comment -

          This probably looks like a problem with the Groovy build script pipeline (" vs. ').

          drulli Ulli Hafner added a comment - - edited

          Added a test, see commit/ad24232f.

          drulli Ulli Hafner made changes -
          Resolution Cannot Reproduce [ 5 ]
          Status Open [ 1 ] Closed [ 6 ]

            People

            Assignee:
            drulli Ulli Hafner
            Reporter:
            reitzmichnicht Michael Düsterhus
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: