Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-58108

Jenkins is not able to connect to remote server to copy slave.jar while trying to SCP

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Minor
    • Resolution: Fixed
    • ssh-slaves-plugin
    • None
    • my Jenkins ver. 2.131, is working on redhat hat linux 6. the browser is google chrome

    Description

      i have created a new node to connect to a remote server but when i launch the agent it failed with the attached error saying it cannot copy slave.jar to the home directory of the remote server. i manually tried to scp to the remote server from where the jenkins server is installed and it works using the same password and username but the jenkins agent does not gets connected to it. 

      Attachments

        Activity

          `Caused by: java.io.IOException: Peer sent DISCONNECT message (reason code 2): No terminal authorization granted` enable `PermitTTY` on your SSH server https://www.ssh.com/academy/ssh/sshd_config#detailed-sshd_config-file-format

          ifernandezcalvo Ivan Fernandez Calvo added a comment - `Caused by: java.io.IOException: Peer sent DISCONNECT message (reason code 2): No terminal authorization granted` enable `PermitTTY` on your SSH server https://www.ssh.com/academy/ssh/sshd_config#detailed-sshd_config-file-format

          People

            ifernandezcalvo Ivan Fernandez Calvo
            aniket_raj aniket khedekar
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: