Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-58537

Plugin Version Must Be Exact

    XMLWordPrintable

    Details

    • Similar Issues:
    • Sprint:
      GSoC 2019. Coding Phase 2, GSoC 2019. Coding Phase 3

      Description

      I noticed when I was doing some testing that if you specify the blue ocean plugin, version 1.8, the library won't be able to find the url since it is 1.8.0.  

       

      https://updates.jenkins.io/download/plugins/blueocean/

        Attachments

          Issue Links

            Activity

            stopalopa Natasha Stopa created issue -
            stopalopa Natasha Stopa made changes -
            Field Original Value New Value
            Epic Link JENKINS-53767 [ 194275 ]
            oleg_nenashev Oleg Nenashev made changes -
            Sprint GSoC 2019. Coding Phase 2 [ 691 ] GSoC 2019. Coding Phase 2, GSoC 2019. Coding Phase 3 [ 691, 696 ]
            stopalopa Natasha Stopa made changes -
            Link This issue is related to JENKINS-58649 [ JENKINS-58649 ]
            Hide
            stopalopa Natasha Stopa added a comment -

            Variant of same issue reported here: https://issues.jenkins-ci.org/browse/JENKINS-58649

            Show
            stopalopa Natasha Stopa added a comment - Variant of same issue reported here:  https://issues.jenkins-ci.org/browse/JENKINS-58649
            stopalopa Natasha Stopa made changes -
            Status Open [ 1 ] In Progress [ 3 ]
            stopalopa Natasha Stopa made changes -
            Status In Progress [ 3 ] In Review [ 10005 ]
            Hide
            stopalopa Natasha Stopa added a comment -

            Closing this since tool should throw error if users enter the wrong version. After some discussion, it seemed like the case where there's a mismatch between the version of the dependency listed and the actual plugin probably shouldn't happen that often and is probably an error with the plugin that listed the dependencies that should be addressed.

            Show
            stopalopa Natasha Stopa added a comment - Closing this since tool should throw error if users enter the wrong version. After some discussion, it seemed like the case where there's a mismatch between the version of the dependency listed and the actual plugin probably shouldn't happen that often and is probably an error with the plugin that listed the dependencies that should be addressed.
            stopalopa Natasha Stopa made changes -
            Link This issue is related to JENKINS-58649 [ JENKINS-58649 ]
            stopalopa Natasha Stopa made changes -
            Resolution Fixed [ 1 ]
            Status In Review [ 10005 ] Closed [ 6 ]
            Show
            stopalopa Natasha Stopa added a comment - See:  https://github.com/jenkinsci/plugin-installation-manager-tool/pull/59

              People

              Assignee:
              stopalopa Natasha Stopa
              Reporter:
              stopalopa Natasha Stopa
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: