Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-58892

Remove build-pipeline-plugin from setup wizard

    XMLWordPrintable

    Details

    • Similar Issues:
    • Released As:
      jenkins-2.190

      Description

      Placeholder for https://github.com/jenkinsci/jenkins/pull/4147 from Daniel Beck

      "I announced an unfixed security vulnerability in Build Pipeline Plugin today, after a year or so without a response by the maintainer. I tried contacting them via email too.

      Sure, this may be one of the less notable security issues, but IMO it's still a problem for a plugin present in the setup wizard – especially given that there's no warning support here. Right now, users might "Select All" and be greeted with a security warning afterwards. Not good. (I cannot enable/disable them based on core version, only plugin version.)

      "

        Attachments

          Activity

          oleg_nenashev Oleg Nenashev created issue -
          danielbeck Daniel Beck made changes -
          Field Original Value New Value
          Released As jenkins-2.190
          Resolution Fixed [ 1 ]
          Status Open [ 1 ] Resolved [ 5 ]
          danielbeck Daniel Beck made changes -
          Labels installationWizard lts-candidate installationWizard
          Hide
          danielbeck Daniel Beck added a comment -

          2.190 is the chosen baseline, so no need for this issue.

          Show
          danielbeck Daniel Beck added a comment - 2.190 is the chosen baseline, so no need for this issue.

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            oleg_nenashev Oleg Nenashev
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: