Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-58937

exception while connecting to remote host (ssh)

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Duplicate
    • Component/s: _unsorted
    • Labels:
      None
    • Environment:
      Jenkins 2.176.2
    • Similar Issues:

      Description

      AzureVMAgentSSHLauncher: getRemoteSession: Got exception while connecting to remote host ubuntu-jenkinsinfraf4fce1.eastus2.cloudapp.azure.com:22
      java.net.UnknownHostException: ubuntu-jenkinsinfraf4fce1.eastus2.cloudapp.azure.com
      at java.base/java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:220)
      at java.base/java.net.SocksSocketImpl.connect(SocksSocketImpl.java:403)
      at java.base/java.net.Socket.connect(Socket.java:591)
      at java.base/java.net.Socket.connect(Socket.java:540)
      at java.base/java.net.Socket.<init>(Socket.java:436)
      at java.base/java.net.Socket.<init>(Socket.java:213)
      at com.jcraft.jsch.Util$1.run(Util.java:362)
      Caused: com.jcraft.jsch.JSchException
      at com.jcraft.jsch.Util.createSocket(Util.java:394)
      at com.jcraft.jsch.Session.connect(Session.java:215)
      at com.jcraft.jsch.Session.connect(Session.java:183)
      at com.microsoft.azure.vmagent.remote.AzureVMAgentSSHLauncher.getRemoteSession(AzureVMAgentSSHLauncher.java:307)
      at com.microsoft.azure.vmagent.remote.AzureVMAgentSSHLauncher.connectToSsh(AzureVMAgentSSHLauncher.java:453)
      at com.microsoft.azure.vmagent.remote.AzureVMAgentSSHLauncher.launch(AzureVMAgentSSHLauncher.java:115)
      at hudson.slaves.SlaveComputer$1.call(SlaveComputer.java:294)
      at jenkins.util.ContextResettingExecutorService$2.call(ContextResettingExecutorService.java:46)
      at jenkins.security.ImpersonatingExecutorService$2.call(ImpersonatingExecutorService.java:71)
      at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
      at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
      at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
      at java.base/java.lang.Thread.run(Thread.java:834)

      Every jobs are now failing because of ssh connection issues, we didn't change anything in our configuration, and it doesn't seem to have any network issues

        Attachments

          Activity

          jieshe Jie Shen added a comment -

          Olivier Vernin On the Jenkins server, could you please try to lookup the "ubuntu-jenkinsinfraf4fce1.eastus2.cloudapp.azure.com" domain? It seems to be related with DNS.

          olblak Olivier Vernin added a comment -

          Jie Shen The issue seems more global than a network issue, as you can see on this public jenkins instance 'ci.jenkins.io' no vm are created anymore with the azure-vm-agent plugin.
          Would it be possible to be caused by an outdated api on azure side?

          jieshe Jie Shen added a comment -

          Olivier Vernin it is possible to be caused by some outdated arm template. I want to confirm if the agents have been created successfully and in healthy state. If not, could you please provide any provisioning log to indicate which prevents to provision the new agents. 

          olblak Olivier Vernin added a comment -

          I cannot reproduce this issue any more, I am going to wait a little bit more to see if it comes back

          olblak Olivier Vernin added a comment -

          The provisionning issue was related to JENKINS-58961, but the ssh connection issue seems to be gone

          timja Tim Jacomb added a comment -

          All issues have been transferred to GitHub.

          See https://github.com/jenkinsci/azure-vm-agents-plugin/issues

          Search the issue title to find it.

          (This is a bulk comment and can't link to the specific issue)


            People

            Assignee:
            jieshe Jie Shen
            Reporter:
            olblak Olivier Vernin
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: