Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-59090

Micro Focus UFT Jenkins plugin is marking build status as "FAILURE" even when builds are passing

    XMLWordPrintable

Details

    Description

      We are executing the UFT scripts from ALM using the Micro Focus Jenkins plugin and this plugin is marking the build as FAILURE even when the scripts are all passed in ALM. There is no pattern to this and we are consistently seeing this. Please see the attached log

      Attachments

        Activity

          sandeepyadav Sandeep Yadav created issue -
          narcisamgalan Maria Narcisa Galan made changes -
          Field Original Value New Value
          Assignee Maria Narcisa Galan [ narcisamgalan ] Roy Lu [ roy_lu ]
          roy_lu Roy Lu made changes -
          Assignee Roy Lu [ roy_lu ] Maria Narcisa Galan [ narcisamgalan ]
          roy_lu Roy Lu made changes -
          Assignee Maria Narcisa Galan [ narcisamgalan ] Roy Lu [ roy_lu ]
          roy_lu Roy Lu made changes -
          Assignee Roy Lu [ roy_lu ] Daniel Gront [ gront ]
          narcisamgalan Maria Narcisa Galan made changes -
          Assignee Daniel Gront [ gront ] Anda Sorina Laakso [ aslaakso ]
          jmyates86 Joshua Yates made changes -
          Priority Critical [ 2 ] Blocker [ 1 ]
          jmyates86 Joshua Yates added a comment -

          aslaakso  Can we get an update on this? this functionality is critical for the customer and the tool incorrectly marking builds as failures is a big issue.  Let us know if you need anything additional such as logs etc.

          jmyates86 Joshua Yates added a comment - aslaakso   Can we get an update on this? this functionality is critical for the customer and the tool incorrectly marking builds as failures is a big issue.  Let us know if you need anything additional such as logs etc.

          Being a complex test maybe it needs more time to finish running. Remove the timeout setup and run the test again.
          Let me know the result.

          aslaakso Anda Sorina Laakso added a comment - Being a complex test maybe it needs more time to finish running. Remove the timeout setup and run the test again. Let me know the result.
          sandeepyadav Sandeep Yadav added a comment -

          Our other jobs have similar time outs and this happens only when a particular build encounters a failure. From this instance onwards, all future builds are marked as failed.

          sandeepyadav Sandeep Yadav added a comment - Our other jobs have similar time outs and this happens only when a particular build encounters a failure. From this instance onwards, all future builds are marked as failed.

          But can you remove the timeout and just for testing purposes try to run the test again? Thanks.

          aslaakso Anda Sorina Laakso added a comment - But can you remove the timeout and just for testing purposes try to run the test again? Thanks.
          sandeepyadav Sandeep Yadav added a comment -

          Yes aslaakso we did try by taking the timeout after the last suggestion. That did not resolve it.

          sandeepyadav Sandeep Yadav added a comment - Yes aslaakso we did try by taking the timeout after the last suggestion. That did not resolve it.
          sandeepyadav Sandeep Yadav added a comment -

          This is a blocker and still no progress on this. Please provide an update

          sandeepyadav Sandeep Yadav added a comment - This is a blocker and still no progress on this. Please provide an update
          jmyates86 Joshua Yates added a comment -

          aslaakso This has been open for some time, can we please get an update??

          jmyates86 Joshua Yates added a comment - aslaakso This has been open for some time, can we please get an update??

          What version of the plugin are you using? Did you try to udpate the plugin for the latest version?
          Do you have any timeout set on the job configuration page?

          aslaakso Anda Sorina Laakso added a comment - What version of the plugin are you using? Did you try to udpate the plugin for the latest version? Do you have any timeout set on the job configuration page?
          sandeepyadav Sandeep Yadav added a comment -

          We tried taking the timeout and that didnt work. Currently we have the timeout set to 45000. We are on 5.5 and upgrading to 5.6 and 5.7 gave lots of other errors and known issues hence we had to roll back to 5.5

          sandeepyadav Sandeep Yadav added a comment - We tried taking the timeout and that didnt work. Currently we have the timeout set to 45000. We are on 5.5 and upgrading to 5.6 and 5.7 gave lots of other errors and known issues hence we had to roll back to 5.5
          aslaakso Anda Sorina Laakso added a comment - - edited

          Please remove the timeout completely. And second thing is that current version is 6.1.3. So you should update to that one, because there have been quite a lot of changes since 5.7.

          aslaakso Anda Sorina Laakso added a comment - - edited Please remove the timeout completely. And second thing is that current version is 6.1.3. So you should update to that one, because there have been quite a lot of changes since 5.7.
          sandeepyadav Sandeep Yadav added a comment -

          I see the current version as 6.0. Please provide a link to 6.1.3 as per your comment

          https://github.com/jenkinsci/hpe-application-automation-tools-plugin/blob/latest/doc/README.md

          sandeepyadav Sandeep Yadav added a comment - I see the current version as 6.0. Please provide a link to 6.1.3 as per your comment https://github.com/jenkinsci/hpe-application-automation-tools-plugin/blob/latest/doc/README.md

          So current version is 6.1, available here: http://repo.jenkins-ci.org/releases/org/jenkins-ci/plugins/hp-application-automation-tools-plugin/6.1/hp-application-automation-tools-plugin-6.1.hpi

          6.1.3 is still beta version.

          Or you can try to go to Jenkins-> Manage plugins and when looking for our plugin you will find the latest version all the time.

          aslaakso Anda Sorina Laakso added a comment - So current version is 6.1, available here: http://repo.jenkins-ci.org/releases/org/jenkins-ci/plugins/hp-application-automation-tools-plugin/6.1/hp-application-automation-tools-plugin-6.1.hpi 6.1.3 is still beta version. Or you can try to go to Jenkins-> Manage plugins and when looking for our plugin you will find the latest version all the time.

          Did you manage to update the plugin? What is the status of this ticket?

          aslaakso Anda Sorina Laakso added a comment - Did you manage to update the plugin? What is the status of this ticket?
          sandeepyadav Sandeep Yadav added a comment -

          We have scheduled to upgrade the plugin on lower environment before moving in PROD, as the last plugin 5.7 gave a ton of issues and caused 2-3 weeks of work loss for our organization.

          sandeepyadav Sandeep Yadav added a comment - We have scheduled to upgrade the plugin on lower environment before moving in PROD, as the last plugin 5.7 gave a ton of issues and caused 2-3 weeks of work loss for our organization.

          Will you please let me know if the tests runs are working after the upgrade of the plugin? We have a defect opened and I would like to close it soon.

          aslaakso Anda Sorina Laakso added a comment - Will you please let me know if the tests runs are working after the upgrade of the plugin? We have a defect opened and I would like to close it soon.
          pcarenza Peter Carenza added a comment -

          Can confirm this still happens with plugin version 6.2. Pipeline has started failing with no errors, even if all tests pass. Have isolated the test plugin to be the cause. This is very problematic for us.

          pcarenza Peter Carenza added a comment - Can confirm this still happens with plugin version 6.2. Pipeline has started failing with no errors, even if all tests pass. Have isolated the test plugin to be the cause. This is very problematic for us.

          What version of ALM are you using? Did you also setup a timeout for the tests? Send me please an email address where I could send you a possible fix?

          aslaakso Anda Sorina Laakso added a comment - What version of ALM are you using? Did you also setup a timeout for the tests? Send me please an email address where I could send you a possible fix?

          do you have any updates on this?

          aslaakso Anda Sorina Laakso added a comment - do you have any updates on this?
          pcarenza Peter Carenza added a comment -

          Version is 12.53

          Yes, we've used timeouts of varying lengths. An unusual issue, speaking of this, is the occasional freeze after the alm tests have completed. Won't return to jenkins, occasionally have to abort.

          My email is Peter_Carenza@bcbst.com

          pcarenza Peter Carenza added a comment - Version is 12.53 Yes, we've used timeouts of varying lengths. An unusual issue, speaking of this, is the occasional freeze after the alm tests have completed. Won't return to jenkins, occasionally have to abort. My email is Peter_Carenza@bcbst.com

          Do you have any updates?
          Thank you.

          aslaakso Anda Sorina Laakso added a comment - Do you have any updates? Thank you.
          hildaboth Hilda made changes -
          Resolution Cannot Reproduce [ 5 ]
          Status Open [ 1 ] Closed [ 6 ]

          People

            aslaakso Anda Sorina Laakso
            sandeepyadav Sandeep Yadav
            Votes:
            1 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: