Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-59754

Jenkins Micro Focus Application Automation Tools Plugin losing connection with Octane after running pipelines

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      We have configured Octane / Jenkins integration by installing ALM Octane plugin in Jenkins. The connection works for a day and then drops.

      Jenkins is setup as a CI server in Octane, we have found that if we run a pipeline everyday with a Jenkins build that the connection between Jenkins and Octane drops and the Jenkins plugin for Octane cannot get a new connection to the Octane server.

      A few things we have noticed:

      The issue only happens if we run a build once a day, if we have a pipeline running every hour the issue does not seem to happen. We believe that the plugin may not be managing the sessions (cookies/tokens) with Octane correctly and that by running a build every hour might be keeping the session "alive"

      When this happens our only fix seems to be restarting the Jenkins server which we think might make the plugin renegotiate the session with Octane

      We tried the newest plugin 5.9 to see if it might resolve the issue but it did not

        Attachments

          Activity

            People

            Assignee:
            radislavb Radi Berkovich
            Reporter:
            jmyates86 Joshua Yates
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: