Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-59906

durable-task plugin v1.31 fails to execute shell commands on swarm client

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      On our CI/CD build system after updating to Jenkins 2.201 this morning the durable-task plugin was updated to 1.31. After update any attempt to use a shell command within a script block in a pipeline on a swarm agent produced a timeout and eventually "process apparently never started" as an error message.

      Deletion of the plugin and a forced install of 1.30 resolved the issue

        Attachments

          Issue Links

            Activity

            aaronpi Aaron Pellman-Isaacs created issue -
            jloucky Jakub L added a comment -

            What architecture is your client running on? If it's not Linux or MacOS running on amd64 or i386, then the problem lies in the newly added golang binary durable_task_monitor.

            If that's the case, this issue is related to JENKINS-59907.

            aaronpi Aaron Pellman-Isaacs added a comment - - edited

            Linux, specifically Alpine and Ubuntu Docker containers on top of CoreOS

            aaronpi Aaron Pellman-Isaacs added a comment - - edited

            Seems like the same issue as JENKINS-59903

            aaronpi Aaron Pellman-Isaacs made changes -
            Field Original Value New Value
            Link This issue duplicates JENKINS-59903 [ JENKINS-59903 ]
            aaronpi Aaron Pellman-Isaacs made changes -
            Priority Minor [ 4 ] Major [ 3 ]
            carroll Carroll Chiou made changes -
            Assignee Carroll Chiou [ carroll ]
            carroll Carroll Chiou made changes -
            Assignee Carroll Chiou [ carroll ]
            dnusbaum Devin Nusbaum added a comment -

            Closing as a duplicate of JENKINS-59903.

            dnusbaum Devin Nusbaum made changes -
            Resolution Duplicate [ 3 ]
            Status Open [ 1 ] Closed [ 6 ]

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              aaronpi Aaron Pellman-Isaacs
              Votes:
              3 Vote for this issue
              Watchers:
              8 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: