Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-60404

Warning exception after upgrading to Folders 6.10

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      Hi,

      After upgrading to the latest Folders plugin version, 6.10, I am getting a warning exception on the logs:

       

      2019-12-06 13:37:11.802+0000 [id=28]    WARNING h.ExtensionFinder$GuiceFinder$FaultTolerantScope$1#error: Failed to instantiate Key[type=com.cloudbees.hudson.plugins.folder.config.AbstractFolderConfiguration, annotation=[none]]; skipping this component
      com.google.inject.ProvisionException: Unable to provision, see the following errors:1) Tried proxying com.cloudbees.hudson.plugins.folder.config.AbstractFolderConfiguration to support a circular dependency, but it is not an interface.1 error
              at com.google.inject.internal.ProviderToInternalFactoryAdapter.get(ProviderToInternalFactoryAdapter.java:52)
              at com.google.inject.internal.SingletonScope$1.get(SingletonScope.java:145)
              at hudson.ExtensionFinder$GuiceFinder$FaultTolerantScope$1.get(ExtensionFinder.java:439)
              at com.google.inject.internal.InternalFactoryToProviderAdapter.get(InternalFactoryToProviderAdapter.java:41)
              at com.google.inject.internal.InjectorImpl$2$1.call(InjectorImpl.java:1016)
              at com.google.inject.internal.InjectorImpl.callInContext(InjectorImpl.java:1103)
              at com.google.inject.internal.InjectorImpl$2.get(InjectorImpl.java:1012)
              at hudson.ExtensionFinder$GuiceFinder._find(ExtensionFinder.java:401)
              at hudson.ExtensionFinder$GuiceFinder.find(ExtensionFinder.java:392)
              at hudson.ClassicPluginStrategy.findComponents(ClassicPluginStrategy.java:344)
      

      I am using all plugins on latest versions and latest Jenkins 2.208.

       

        Attachments

          Issue Links

            Activity

            michelzanini Michel Zanini created issue -
            michelzanini Michel Zanini added a comment -

            This is a duplicate of JENKINS-60393

            fcojfernandez Francisco Fernández made changes -
            Field Original Value New Value
            Resolution Duplicate [ 3 ]
            Status Open [ 1 ] Closed [ 6 ]
            reinholdfuereder Reinhold Füreder made changes -
            Link This issue is duplicated by JENKINS-60411 [ JENKINS-60411 ]

              People

              Assignee:
              fcojfernandez Francisco Fernández
              Reporter:
              michelzanini Michel Zanini
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: