Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-60418

issue of Integration webhook with bitbucket when using bitbucket pull and push plugin

    XMLWordPrintable

Details

    Description

      Hi Team,

       

      we have faced some  issues. As you suggested in the documentation the Bitbucket pull and push plugin will not work if Bitbucket plugin is still installed. But when we uninstall the Bitbucket plugin the jenkins_url/bitbucket-hook/ throws 404. when I again install the Bitbucket plugin it gives 200 but the job is not invoked. Can you please help us ASAP as we are blocked due to this.

      Attachments

        Activity

          vikas468 vikas goyal created issue -
          vikas468 vikas goyal made changes -
          Field Original Value New Value
          Description Hi Team,

           

          we have faced some kind of issue. As you suggested in the documentation the Bitbucket pull and push plugin will not work if Bitbucket plugin is still installed. But when we uninstall the Bitbucket plugin the jenkins_url/bitbucket-hook/ throws 404. when I again install the Bitbucket plugin it gives 200 but the job is not invoked. Can you please help us ASAP as we are blocked due to this.
          Hi Team,

           

          we have faced some  issues. As you suggested in the documentation the Bitbucket pull and push plugin will not work if Bitbucket plugin is still installed. But when we uninstall the Bitbucket plugin the jenkins_url/bitbucket-hook/ throws 404. when I again install the Bitbucket plugin it gives 200 but the job is not invoked. Can you please help us ASAP as we are blocked due to this.
          vikas468 vikas goyal made changes -
          Priority Minor [ 4 ] Blocker [ 1 ]

          Hi vikas468

          may you deinstall both plugins and after that reinstall only the the Bitbucket push and pull request plugin?

          Thanks

          cdelmonte Christian Del Monte added a comment - Hi vikas468 may you deinstall both plugins and after that reinstall only the the Bitbucket push and pull request plugin? Thanks
          vikas468 vikas goyal added a comment - - edited

          Hi Christian, 

           

          Thanks for the reply. ( Appreciated ) 

          What do you mean by deinstall? Are you talking about uninstall? 

           

          I have tried this. but still no luck.

          vikas468 vikas goyal added a comment - - edited Hi Christian,    Thanks for the reply. ( Appreciated )  What do you mean by deinstall? Are you talking about uninstall?    I have tried this. but still no luck.
          vikas468 vikas goyal added a comment -

          One more question is this plugin works if Bitbucket pull request plugin is installed on Jenkins. 

          vikas468 vikas goyal added a comment - One more question is this plugin works if Bitbucket pull request plugin is installed on Jenkins. 

          Hi, the 404 problem doesn't seem to be related to the plugin itself. It could depend on your Jenkins installation / configuration

          cdelmonte Christian Del Monte added a comment - Hi, the 404 problem doesn't seem to be related to the plugin itself. It could depend on your Jenkins installation / configuration
          cdelmonte Christian Del Monte made changes -
          Resolution Cannot Reproduce [ 5 ]
          Status Open [ 1 ] Closed [ 6 ]

          People

            cdelmonte Christian Del Monte
            vikas468 vikas goyal
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: