Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-60426

All stages show up as UNSTABLE when one stage is unstable

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Duplicate
    • Labels:
      None
    • Environment:
      Jenkins 2.176.3, Pipeline Stage View Plugin 2.12
    • Similar Issues:

      Description

      In the classical GUI all stages are shown as unstable when only one stage is (in BlueOcean it is displayed correct)

      My expectation: Only the unstable stage is displayed as unstable, others are not (while the complete build still is marked as unstable)

       

       

      #!groovy
      
      pipeline {   
      
          agent any
      
          stages {
              stage('successful') {
                  steps {
                      echo ('hello')
                  }
              }
              
              stage('unstable') {
                  steps {
                      unstable(message: "Failed: ${STAGE_NAME} => return UNSTABLE status")
                  }
              }
          }
      }
      
      

       

      Potentially related to JENKINS-39203

        Attachments

          Issue Links

            Activity

            chrop Christian Opitz created issue -
            chrop Christian Opitz made changes -
            Field Original Value New Value
            Description In the classical GUI all stages are shown as unstable when only one stage is (in BlueOcean it is displayed correct)

            My expectation: Only the unstable stage is displayed as unstable, others are not (while the complete build still is marked as unstable)

             

            !2019-12-10_17h49_44.png!

             
            {code:java}
            #!groovy

            pipeline {

                agent any

                stages {
                    stage('successful') {
                        steps {
                            echo ('hello')
                        }
                    }
                    
                    stage('unstable') {
                        steps {
                            unstable(message: "Failed: ${STAGE_NAME} => return UNSTABLE status")
                        }
                    }
                }
            }

            {code}
             
            In the classical GUI all stages are shown as unstable when only one stage is (in BlueOcean it is displayed correct)

            My expectation: Only the unstable stage is displayed as unstable, others are not (while the complete build still is marked as unstable)

             

            !2019-12-10_17h49_44.png!

             
            {code:java}
            #!groovy

            pipeline {

                agent any

                stages {
                    stage('successful') {
                        steps {
                            echo ('hello')
                        }
                    }
                    
                    stage('unstable') {
                        steps {
                            unstable(message: "Failed: ${STAGE_NAME} => return UNSTABLE status")
                        }
                    }
                }
            }

            {code}
             

            Potentially related to JENKINS-39203
            nickbrown Nicholas Brown added a comment - - edited
            nickbrown Nicholas Brown made changes -
            Link This issue relates to JENKINS-39203 [ JENKINS-39203 ]
            nickbrown Nicholas Brown made changes -
            Link This issue relates to JENKINS-58783 [ JENKINS-58783 ]
            chrop Christian Opitz made changes -
            Link This issue duplicates JENKINS-58783 [ JENKINS-58783 ]
            chrop Christian Opitz made changes -
            Resolution Duplicate [ 3 ]
            Status Open [ 1 ] Resolved [ 5 ]
            chrop Christian Opitz added a comment - - edited

            Yes, seems to be a duplicate of the one mentioned. Closing this one.


              People

              Assignee:
              svanoort Sam Van Oort
              Reporter:
              chrop Christian Opitz
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: